Motorola - Motorola Moto G7 Plus - lake - Documentation Suggestions

Please add your suggestions to improve the documentation for the Motorola - Motorola Moto G7 Plus - lake here …

I re-worked quite a bit of the documentation based on my experience. In particular, a NON Optional step to copy partitions described in the Lineage OS docs is missing.

Without this step you get a hard brick.

How can I upload my edited documentation page?

Just put the steps here and we will add it to the documentation site or add a link to it based on the content

Below is a link to a full revised installation page for XT1965 with my changes highlighted in red.

This link is only valid for 7 days.

Pl post as a topic on the forum and I can add a link in the main document. That way it will be available for all user to comment and make suggestions. In case it is already available on the forum pl share the link.

I hard bricked my Motorola G7 Plus XT1965-T by following the TWRP instructions because I missed that you DO NOT INSTALL TWRP but instead just boot TWRP Recovery. This hard bricked my phone.
I was able to get it back to responding to adb/fastboot, but now the phone only boots into fastboot. Instructions on TWRP says to fix it reinstall the stock ROM which I do not know how to do. Any other suggestions to recover the phone and get /e/ installed on it?

Tried installing /e/ in my brand new Moto G7 Plua following the instructions on the official website. Nonetheless, I hard bricked the phone twice (and had to use Windows to fix it - eeeew) until I checked Lineage OS instructions.

The current instructions for /e/ lack the sideloading of the copy-partitions-20200903_1329.zip file, which is necessary to guarantee updated firmware in slot B. After I proceeded with this, I could install /e/ with no problems.

Cheers!

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

2 Likes

This missing section in the documentation has been added. Should be published early next week. The reason for the delay was we wanted the partition copy image to be built by /e/ developer instead of copying from LOS. Since that may take some time , we will add this section to the documentation for now pointing at the LOS partition copying image.

1 Like

I seem to be having similar problems. Hard bricked my Moto G7 Plus after installing TWRP. I got back into TWRP, then finished following instructions. When going to reboot the system after sideloading /e/, I got the message “No OS Installed! Are you sure you wish to reboot?” I rebooted assuming I had done everything correct. Hard brick again. I got back into TWRP.

Then I found this page, and then followed the instructions again adding the step of sideloading the copy-partition from LOS. Now, after sideloading /e/, I still get the message of no OS installed when trying to reboot.

No sure what to try next.

1 Like

I somehow got /e/ working. I kept trying, but every time TWRP said no OS installed. At one point, I was able to get /e/ recovery working instead of TWRP. Kind of happened by accident, so I can’t say exactly how that happened. But once in /e/ recovery, I retried the steps, including sideloading the copy-partition, and then sideloading the EOS. I noticed /e/ recovery seemed to sideload and install with more steps than TWRP did. I rebooted and EOS booted up.

So, the issue may have been the newer version of TWRP (3.5.0_9-0-lake). So if you are stuck, try to get /e/ recovery to work and use that instead.

2 Likes

After getting /e/ to work, my system files take up about 12 GB. Is this correct? I went back to /e/ recovery, formatted and reinstalled, but still show 12 GB for system files. If it’s not, how do I go about erasing all the junk files?

1 Like

That would be about normal. This is a screenshot from a different phone …where also it shows 12 Gb with 11 Gb being system files.
Screenshot_20210203-180625_Settings Screenshot_20210203-180634_Settings

2 Likes

Okay, thanks for letting me know, that means everything worked right! With the problems I had earlier, I thought maybe there were left over files not being erased.

Same happened to me, and now im struggling to unbrick it.

Can you help me please? How did you unbrick yours?
Someone sent me this tutorial:

But i have no clue on which Stock Rom to download, how can i know the correct one?
Im from Brazil, but who sold me, said my G7 Plus is european model.

Thank you.
Att.

Hey,
Brazilian here as well :DD
I used this guide as well. Basically install qualcomm drivers on windows and run the blankflash.bat in the terminal with the phone plugged and recognized by the driver, that should do it. I didn’t need to reinstall the Stock ROM, as I could solve the rest using TWRP.

1 Like

If you are still planning on installing EOS, you do not need to download a stock rom. In the unbricking process, I got my phone to show the bootloader screen, and stopped there. Then I went back to the /e/ installation instructions, and used the /e/ rom. Otherwise you will just be installing the stock rom, formatting it, and then installing EOS. I just recommend not using the TWRP version (3.5.0_9-0-lake). I could not get it to install EOS. I do not know if the previous version of TWRP works, as I was able to get /e/ recovery to work after unbricking it.

1 Like

Cool man! Glad to know other brazilians are trying it!!!
Lets exchange contact, and keep in touch, maybe start a /e/ Brazil on Telegram, what do you think?

It did work by the way, and im using /e/ now, first day, and so far, im enjoying a lot!

Cheers!!! I solved the brick problem with the tutorial i sent, than i was able to correct my mistake, and install /e/! Im enjoying it a lot so far!

1 Like