Motorola - Motorola Moto G7 - river - Documentation Suggestions

Please add your suggestions to improve the documentation for the Motorola - Motorola Moto G7 - river here …

I did create a How-To a couple of months ago. Feel free to compare and copy.

Some suggestions for the /e/ install documentation
(Feel free to use the verbage I type either in the How-To or below. I don’t care about credit.)

URGENT:

  1. You can’t unlock the bootloader without Allowing OEM. After step 3 (enable USB debugging), you must go in the System app > System > Developer Mode and enable “Allow OEM” or the bootloader can’t be unlocked.

  2. The phone will be bricked if Copy_Partitions is not executed. Immediately after backing up and before formatting, the user MUST execute the copy_partitions.zip. If you don’t include this in the instructions, THE PHONE WILL BE BRICKED and the user will freak out. It can be fixed but you don’t want to have to help users through the mess to install blankflash and then install stock ROM. It is best to copy partitions from the A memory to the B memory BEFORE the partitions are formatted. I would suggest the following instructions:
    1: Download copy-partitions.zip and move it to your ADB folder. (Download it at https://androidfilehost.com/?fid=4349826312261712574 - This is the same file LineageOS uses).
    2: In TWRP press Advanced > Sideload > Swipe to Start Sideload
    3: In the command window on your computer type adb sideload copy-partitions.zip
    4: Reboot into bootloader mode
    5: Type fastboot boot twrp-3.4.0-1-river.img (or whatever the name of the TWRP file you downloaded is). Your phone should boot to TWRP home screen.
    (NOW you can wipe and install /e/ and install TWRP Permanently.)

  3. Without this step, the phone will bootloop. At the very end the user will likely go into a bootloop until this command is entered in the fastboot window fastboot erase userdata.

  4. Typo. Step 5 (Temporarily flash a recovery), the code is wrong. The way it is currently documented fastboot flash recovery <recovery_filename>.img, it will permanently install the Recovery but this is the wrong time to do it because it will get deleted (this is why it is entered later in the script). I would suggest it be temporarily flashed by typing fastboot boot <recovery_filename>.img.
    So it should read:
    “Temporarily flash a recovery on your device by typing:”
    fastboot boot <recovery_filename>.img
    and take the part about fastboot flash out.

  5. Typo. Step 6 (Manually reboot into recovery mode) is not necessary because the prior step (if typed correctly) will boot to the temp recovery. If this step remains, it will confuse the user.

  6. Flash TWRP after installing OS or it will be replaced. After step 8 (Sideload the /e/ .zip package:), I recommend the following commands
    9: Go back to the Home screen.
    10: Press Advanced > ADB Sideload and Swipe to Start Sideload
    11: Now type adb sideload twrp-installer-3.4.0-1-river.zip (or whatever name is the TWRP-installer.zip file is). (This is not the same file as you have been using to boot to TWRP, this is the zip file.)

  7. User will get errors if you don’t reboot and install will fail. After step 5 (Now tap Format Data), the user will get errors if the person is on stock. If the user is not on stock then the reboot is not necessary. In either case it is good to reboot after the formatting of the data regardless. I recommend the following commands replacing step 5 and 6 (because step 6 is wrong too, the G7 doesn’t have a Cache, it has a Dalvik cache):
    5: Press Wipe > Format Data > type yes and enter to continue with the formatting process. This will remove encryption as well as delete all files stored on the internal storage.
    6: Go back to the Home screen
    7: Press Reboot > Bootloader > confirm. The phone should reboot back to Bootloader Mode (the Adroid laying down).
    8: In the command prompt on your computer, type fastboot boot twrp-3.4.0-1-river.img (or whatever the name of the TWRP file you downloaded is). Your phone should boot to TWRP home screen.
    9: Press Wipe > Advanced Wipe > select Dalvik, Data, and System (only those three) and Swipe to Wipe at the bottom.

PLEASE CONSIDER THESE:

  1. The first warning given is a certainty so it should be changed from “may” to “will”. When I downgraded from Q to Pie, I lost my IMEI number and baseband so I couldn’t call or get 4G data. It didn’t brick the phone but it is no longer a phone, it is just a mini tablet. There is a workaround and is documented on the Telegram Moto G7 group.

  2. Backing Up. Prior to downloading /e/, it is strongly recommended to backup all the partitions so that portions of the backup can be restored if there is a problem. If the backup will fit on an Micro SD card, great (TWRP calls this directory /external_sd) and will be stored on the Micro SD card at /TWRP/backups/. If not, it will need to be copied to the internal storage (TWRP mistakenly calls this directory /sdcard for some reason). If the backup was copied to the internal memory, the user should pull the file off the phone to the local computer. boot the phone, connect the USB cable, tap on the Android notification “Android System - Charging this device via USB”, tap it again, then click on File Transfer. This will enable the computer to read the internal memory and be able to copy it to the local computer.

  3. One more caveat about backups. IF the person is already on stock Android Q (10), the data directory will not backup and will need to be excluded from the backup or you will get errors and abort the backup. TWRP cannot backup the stock encrypted Data directory for Q but it can for Pie.

  4. Could you please have the person download all the necessary files before the user begins tinkering with the phone. Imagine formatting the phone and then have a slow download of /e/ taking a few hours with the phone out of commission all that time. (I am not saying your download speeds are slow but the user may only be able to download at slow speeds.) That wait time could be avoided if the downloads were first. This would be a best practice for all installs.

  5. It might be a good idea to mention the Telegram group created for this phone model. https://t.me/motoG7River At least it would give someone a place to go if they have questions or issues.

Well I have to go. I will check check back again in a day or so. Thanks for making these updates.

Paul
J.O.Y.

4 Likes

As I try to do the ADB sideload, my Moto G7 play screen says:

Finding update pacakge…
Opening update package…
Verifying update package…
E:footer is wrong
Update package verification too 0.2 s (result 1).
E: Signature verification failed
E: error:21
Installation aborted.

Any ideas how I can work past this problem? It seems like I can make connection via ADB and USB, but frankly, I’m pretty lost by now and the phone (which was aftermarket updated from Android 9 to 10) won’t boot at all.

You are trying to install TWRP ?

Be careful, your device is a Moto G7 Play (channel) and not a Moto G7 (river) (according to what you said).

There is an unofficial build for your device here.

So you are probably trying to install a wrong version of TWRP which is why it fails. There is a TWRP for channel here but no idea where it comes from or if it works, at your own risk.

I’m trying to lock the bootloader after flashing successfully, only to get rid of the warning and delay at startup. I was able to do this on the Moto G7 Plus (lake) but not on the Moto G7 (river).

adb reboot fastboot

fastboot oem lock
(bootloader) WARNING: This command erases all user data.
(bootloader) Please re-run this command to continue.
OKAY [  0.002s]
Finished. Total time: 0.002s

fastboot oem lock
(bootloader) Still require signed boot.img
OKAY [  0.005s]
Finished. Total time: 0.005s

I was going to flash the OEM boot.img but thought better to ask before I potentially brick the phone :).

Any help is appreciated.

Danny

Your how to document saved the day for me. It should be at the top of the instructions page. Thanks also for the Telegram link!

1 Like

The ‘how to’ page link created by pmoody should be placed at the top of the documentation page for the G7, as it has instructions that are more specific to the G7 and is generally more detailed and clear than the instructions in the documentation. I found it late because it’s right at the bottom of the page but it saved the day for me as a beginner.

3 Likes

Also maybe it should be noted that in some cases you cannot boot the recovery image from a Linux distro like Ubuntu. See: Fastboot stuck on "Sending 'boot.img'" (TWRP, Moto G7 plus "lake") - Android Enthusiasts Stack Exchange. I’ve experienced the same issue and avoided it by installing from Windows 10, without installing a proprietary driver from the official website (I installed /e/ OS on a computer at a Internet cafe).

1 Like

The installation instructions need to be updated - I came from using Lineage OS and when I saw that the instructions were a copy of their instructions (which are up-to-date), that’s what saved me from thinking I’d bricked my phone. There’s a lot of extra steps in there now that aren’t necessary.

Hi

I’m running 1.17-s-20231113351092-dev-river.

Is there any more info out there regarding upgrading to /e T?
I have seen the official upgrade https://doc.e.foundation/devices/river/upgrade
It doesn’t seem very detailed and refers at the end to using the same method when first installing /e.

Which is it? Can I copy over existing? Has it even been tried?

Thanks

Cliff

There is a significant difference between the install and upgrade method, this upgrade page does not tell you to format data.

It has been a long standing thing that one may have to return to stock ROM and Format data at Android version upgrade. The T upgrade pages omits both …

… you may well be one of those fairly early to try !

This would be found in the Development Updates pages over the past few weeks. From about Week 38 on there were difficulties that clouded the T release.

Thanks aibd

I’ll wait a little longer. I have at least solved the data backup issue that was plaguing me