MTP connections not working on 0.11

Hi all
I just got my very first /e/ device (Galaxy S7) and I like it a lot!
I upgraded the pre-installed /e/ from 0.9 to 0.11.

There seems to be a problem with the MTP connections, though. When plugging the USB cable into phone and PC (tried multiple OS’s), the PC does recognize that a MTP device was connected. But trying to access it, results in an error (all along the lines of “No storage media found. Make sure your device is unlocked and has MTP enabled in its USB connection settings.”).

I would expect a popup on the S7 asking for permission, but none appears.

I have already set the default USB usage protocol to MTP in developer options.

I browsed through the forum here and searched the net, but didn’t find anything.
Is this a known issue?
Is there a way to better debug the issue?

Thanks for any hints!

best /m


USB default setting is always > battery. No way to configure MTP as default.

You have to manually enable MTP from the phone:

  • swipe back, a notification says you’re in filing-battery mode,
  • tap on it to launch ‘Connecting mode’ window,
  • choose MTP.

Yes, a toast notification would be a cool feature, because you have to do this each time you will transfer files to/from PC.

Thanks for the info!
I just saw there is a notification under the status bar when the phone is plugged in (have to swipe down to see). Tapping on it opens the “Use USB to” popup. I can choose “Charge this device”, “Transfer files” and “Transfer photos (PTP)”.
But unfortunately, “Transfer files” results in the same behaviour as “Charge”, which is the error described above (the PC sees a storage device in both cases).
Selecting PTP does result in the PC changing the device type it sees from Storage to Camera. But no pictures are shown, although I already took some on the S7.
Thx /m

You don’t see pictures files in DCIM > OpenCamera ?

Or you can’t see previews of your pics while browsing from PC ?

When using MTP I don’t see any files or directories, as the access does not work at all.

When using PTP there is no error, but also no images are shown under camera/:

When looking at /storage/emulated/0/DCIM/OpenCamera on the phone directly, I see the files there.

Good news.

After wiping the data partition and encrypting the phone, I can now access the phone via MTP.
(See my other issue Should phone encryption work on S7 /w 0.11? for details).

‘Solved’ but we don’t know why…