Murena Task app: How to add another synchronized task list?

I’m using to Tasks App on my FP3 with /e/OS and have one synchronized list with my Murena account. I can access the list “Personal” on the PC through the Murena Cloud in the browser and I’m happy with it.
I would like to add another synchronized list (not local), but I can figure out how to do it? If possible at all?

In your browser, go to the Tasks app in your account:

The pane on the left shows your existing task lists, and there is an 'Add List` link below the lists

Thanks, I see it. I already added a list there, but it does not show up on my phone in the Tasks App. Can you give me a hint?

You need to persuade the phone to refresh its list of calendars for the Murena account. I’m not sure exactly how to do it in /e/'s Account Manager - I use DAVx5 for contacts, calendar, tasks and notes sync.

Try going into Settings, Accounts, choose your Murena account, and see what options are available. There’ll be a screen with the list of calendars. Refresh that list, and your new task list shoud appear. Enable sync for the list, then do a sync.

1 Like

Thank you for insisting!! I now found the menu entry - it was not easy (it is also quite unintuitive that it is even required to make special steps to archive this). I was not aware that the calendar and the tasks are somehow the same (I was not looking for calendar at all until your hint) Here are the 8 necessary steps:

Accounts accout
My Account
(chose the account from a list with a single item in the Account Manager)
tip on the three dots and select “Kalender neu erkennen” (recgonize new calendar?)

Someone else had the same or very simular issue:


This is a very important tip. Thank you!!! :grinning: I wasted so much time without finding the solution. I wish I read your tip earlier! I think your instruction should be listed with BIG LETTERS somewhere in the front page of eOS documentation. Thanks again!

Worked for me too. Thanks!

I have the same problem, but sadly the solution provided by nilsl did not work for me. I dont see the new Task-list (which was created in the cloud on the computer) and can not make it visible. I already tried syncing with no success. Would be very appreciative if someone can help me out as its quite frustrating using only one Task-list for everything.

As other users have commented on sync failures I just ran a little test that sync was working correctly with Tasks for me.

But is the opportunity to add a new task on the phone app missing? I see

… and I find it synced to cloud.

My initial thought had been to identify if this is a sync issue, or a shortcoming in Tasks app.

1 Like

Thanks for the reply. As far as I can see you have your local and your Personal Task-list. This is the same for me, Im struggling to get a second Task-List (not the personal-list but a new one) synced which I opened myself on the cloud. I synced everything as far as I can see but the second List doesnt show up.

If I add a second List on the phone its only stored locally which is not something I find useful as I switch between devices a lot.

This bit I don’t reproduce.

Indeed all I tested the ability to sync starting from the phone. But my new tasks in Personal do sync to cloud and another phone.


Of course I am still only trying to test if you have a sync issue.

  • Our situations are significantly different as my “Personal” list happened to be empty as I just changed phone and made a fresh start.

However I do reproduce the OP issue that a List created using the PC interface is not synced to devices without (in my case) [1] “special” measures.

This didn't work

I just tried from PC to Export of the “newMurenaList.ics” to the phone by email, but adopting the List was so far unsuccessful so far as the phone cannot yet be persuaded to open the .ics with Tasks. It might be worth describing what you tried and where it failed.

[1] I did solve adding the (PC added) Murena List from

Settings > Accounts > Murena a/c (that is top listing) > My account > Settings > Tap on the account > Select CALDAV > Tap the “Refresh Folders” icon.

This is the same route as @nilsl’s post#5 but I was thrown by not finding “Calendar” where I find CALDAV.

Yeah, not sure why its not working. I suspect its a limitation of the task-application?
I tried syncing a couple of times in various ways but it did not affect anything. I have a List on the cloud created by me that won’t sync with the phone and if I create a List on the phone it won’t sync with the cloud (altough it warns me on the phone that its only stores locally). When I try to share it via a link from the cloud to the phone the phone says “Error: Strict Cookie has not been found in request”.

The standard Task-List “Personal” works without any problems.

I had hoped to untangle whether this was a sync problem or Tasks app problem. But, forgive pure curiosity, what did happen when on the phone you tried

Settings > Accounts > Murena a/c (that is top listing) > My account > Settings > Tap on the account > Select CALDAV > Tap the “Refresh Folders ” icon

I saw some animation straight away and then the new folder appeared on that view in say 15 seconds.

The actual sync of new contents in Tasks was less immediate.

No worries asking! I get a little animation vor .5 seconds and then nothing happens. No folder appears, just the current task-list and my two calenders.