My experience so far (warning: negative content)

Hi everyone,

I installed /e/ on my FP3+ since about a week. Here is a list of my issues so far. I search this forum for each one of them but was unable to found satisfying answers nor solutions.

  • Battery draining: lost more than half of my battery duration (in battery usage, various apps are using a lot of battery but the system does not see any problem).
  • Bliss launcher: regularly mess up my apps placement, randomly and for no reason. I open an app, close it, and suddenly the bar at the bottom of the screen is empty and my apps are now using 1-2 screens more than before.
  • Google apps: I know, I know, the main goal of /e/ is to get rid of Google, and I’m all in when it comes to my personal accounts. But, my work requires the whole Google apps suite. Most of them are working fine, but some (critical) apps are not, like for instance Google Chat (stays stuck on “choose account” screen) and Google Meet (just doesn’t start).
  • Phone book synchronization error: temporary solved by deactivating all sync, but terribly annoying (notification every 5-10 seconds).
  • Some apps (available in Apps) are just not working: NissanConnect EV, Chargemap (this one require Google Maps, that does not work either).
  • Empty Calendar notifications: apparently not possible to deactivate anymore on Android 10.
  • Impossible to connect my phone to my laptop and browse the files anymore. I set the USB setting to “File transfer” but the phone does not mount in Windows 10.

Quite negative impression so far. All those issues seems to not have solution at the time of writing.

On the positive side, I really like the platform. I’ll keep it anyway as my personal account, even if I revert back to standard Android. Magic Earth is really nice and useful.

The community seems to be very active and maybe I just need to be patient and all my problems will be solved soon. In the mean time, if someone can help me with one or more of those issues, that would be really helpful !

Thanks for reading.

Probably it does but not as an ordinary USB drive like normal people would expect. In Windows 10 it appears in the tree:

There’s than an “FP3” entry which shows both the internal memory and the SD card, you can read and write both. You never get a drive letter for that. Under Linux it’s much more complicated.


Sorry, but /e/ totally is the wrong OS for this requirement. And any OS with microG would be the wrong OS for that matter, as microG can try its best (and does so), but conceptually it can never run any Google-dependent App reliably enough for a work environment. You’re just seeing this play out in practice, there’s nothing much that can be done about that. microG is not Google.


That’s too bad. As @AnotherElk said you are probably not the best use case. Sadly I am in the same boat not ready to give up the goog completely and also /e/ isn’t on Ulefone.

I was a bit worried my wife wanted a degoogled phone. She is both a good and a bad use case Because she is tech-phobic I worried about bugs. But she she doesn’t use her phone much, and the only non standard app she uses is Viber to talk to family.
I bought new Motorola phone and with help from this forum I got /e/ installed and it works perfectly. A little bit of change to use the new email app for her and the Magic Earth. Viber works great for video calls. So far it has worked great.

One thing I thought of and not sure it is supported in /e/ is the “work” profile that sandboxes apps. My old job had a BOD plan where they paid you each month to put their security stuff and work profile on your phone in a separate supposedly sandboxed context. Now with a new phone I set up my own “work” context where I am putting some apps that I might want to run but don’t want part of my regular context. Does /e/ support this?


1 Like

Hi newts,
search about shelter


Not all issues on your list have a solution, as @AnotherElk has pointed out, however you can solve two of them quite easily.

  1. Bliss Launcher: Just install another one. Personally I like Lawnchair from F-Droid. However, any launcher out there can be used to replace Bliss. I do have the same problem with scrambling apps and hope it will be fixed some time soon, since I do like the launcher. Till then, Lawnchair is a great replacement.

  2. Contact Sync: This is a known issue I had faced as well (see Gitlab). Bad news: as of yet no direct fix. Good news: easy to use workaround: Just deactivate WebDAV sync, download Davx5 from F-Droid and follow the instructions to set it up. It does the exact same thing as WebDAV with the only difference being that it actually works.


Yes, that’s the one. I have it on my stock android. Is anyone using it with /e/ to let a little google in when they need it? It has the advantage you can kill all the apps (supposedly) when you are done.

Yes, I use Shelter to separate a few apps from the rest in the “Work” profile. If you want to see what can be seen by the apps (at least in part of what they can see) in each profile I have found PrivacyBreacher helpful. Edit: Another helpful app to scan for trackers in apps is ClassyShark. This may duplicate some info if using Exodus already (in default /e/ app store or as the individual app. I mostly use FDroid followed by Aurora and then use various tools to find and block Trackers. Below is a good thread if you’re searching. Also, on this subject it would do you well to review @marcdw 's posts.

1 Like


??? Debian Buster + Xfce: just plug, open file-manager and browse internal storage or SD card (when FTP enabled on phone).

About FTP: few problems with notification in status bar decided me to enable it as default setting on all phones: enable ‘dev options’, ‘scroll’ back to USB settings, choose FTP, disable ‘dev options’ if you don’t need them, enjoy.
Worked fine with my Debian and a lot of Windows, updated or not, in ‘my’ schools…
Edith: FTP can’t be set as default from normal settings and needs to be enabled each time you plug. That’s why I’d use ‘dev options’ way…

1 Like

I think you talk about MTP because FTP also exist but it another thing (proto cloud)

But we must insist on a point :
a PC running a linux OS is easier to apprehend and easier to use for a new user even childs or old people than a PC running Windows OS.
Most people are just victims of their habits and their brain is formated


yes, ‘Media’ not ‘File’, sorry…

when W$ decide your printer or scanner is too old, it’s pretty much difficult than with GNU/Linux, for a non-tech user, to reinstall and keep across updates the right driver. And generally you loose some device’s capabilities…
What a wonderfull word… :roll_eyes:

1 Like

On plain Linux (I use Arch) you would for sure get the idea to mount the device or parts of the device (the SD card) as an ordinary USB drive. Other OSes (Blackberry 10) allow this without any problems and without using any special software on any side. With Android this is not easy, even if you use packages like android-file-transfer (which crashes often) or mtpfs. (just saw that there’s also an android-udev, will try this …)

A good, robust and simple solution for Linux is in my opinion to have an FTP server on the device and an FTP client like Filezilla on the computer.

Hi @irrlicht , off topic, so will keep it short. My first attempt, with Debian Buster and Thunar, a FUSE issue was reported. I got this result from a quick search. Media Transfer Protocol - ArchWiki