My latest build for Xperia XZ1 Compact (lilac) is rebooting to TWRP after showing the /e/ boot animation for a while


I have managed to build for my Z1C without Docker, using the script. I used the branch v1-q
When I flash the build, I see the Sony boot screen followed by the /e/ boot animation. After about a minute the device powers off and reboots into TWRP.

I have tried wiping and formatting the data partition with the same result.

Is this because my built has picked up the faulty version 12 code?

Will I get a better result if I try using one of the latest tags such as test-15-q?

I would better try an older version. As far as I remember was 12 OK

Do you mean v0.12.10-q or something else?

Isn’t that the version that caused all the problems?

I think it was on pie not on q

1 Like

Built with `v0.12-q’ and same problem.

I’m building a version for Xperia Z5 Compact (suzuran) using the same branch. If/when the build succeeds, I’ll see if that runs.

[Later:] The suzuran build seems to work :slight_smile: I’ll post a link somewhere . The sad news is that the lilac build doesn’t work. Probably a problem with the stuff I’m picking up in my local manifests, so that gves me something to spend time debugging.

1 Like

Still having this problem after another rebuild, this time with Docker. Using twrp-3.3.1-0-lilac-android10-1.img (from

  • Before installing I am wiping everything via TWRP (Dalvik / ART cache, system, data, cache) formatting data.
  • Installing ROM from external SD card via TWRP Install
  • After install, in TWRP, doing wipe/factory reset and format data.
  • Repeated the above, but installing via adb sideload
    I’m fresh out of ideas :frowning:

If anyone wants to try to see if the build works any better for them it is on AFH