My little experience with /e/ on Redmi Note 4 and Pocophone F1

xiaomi
user-experience

#1

Hello,

here is my little experience with /e/ on two devices. Redmi Note 4 and Pocophone F1.

First of all, thanks a lot for all the team for your work on this great project.
I hope that /e/ will become a must to have in doing without GAFAM.

Context :
I never had smartphone before I discovered the /e/ project because I don’t want to give all my data to GAFAM.
At home, I have selfhosted apps on raspberry pi for, cloud, dns, secrets, etc.
I started to use /e/ 6 month ago.

As the project seems to be a good idea, I decided to buy a device from the compatibility list to test if it could be compatible with my life without google, facebook, etc
I bought a Xiaomi Redmi Note 4 to begin and I was seduced by /e/. I started with version 0.1 on it.
The only things I didn’t want to do was to open some “e accounts”, I want using a smartphone without any specific account except for the accounts I manage at home.
So I installed a Baikal server for my contacts and Calendar, Turtl for share Documents/pictures with my family, I already had a cloud with Seafile and I tested Owntrack successfully.

Calls are OK, no problems with SMS, bluetooth works with : my PC, my rapsberry media server, my radio in car.
I can make calls with bluetooth in my car, I can use GPS and Magic Earth to navigate, (sometimes GPS takes time to hang a satellite, but in general, it’s okay.)
photos are in good quality, I can surf on web with the default browser or the Tor browser, I can read my webmail, I can play music, pilot my drone and play games.
The update system is OK.
So /e/ is fully usable on my Redmi Note 4.
It’s compatible with my life without GAFAM and my desires for modernity. I decided to use it as main phone.

I use Apkpure and F-Droid as stores.
I disable for most apps the registration in microG.
I apply Privacy Guard by default to new apps.
I don’t want to have to root my phone.
I don’t use finger sensor, pattern is enough for me.
I use profiles, this is a great feature ! So in the morning, when I leave home, the bluetooth turns on, the bluetooth connection with the car is automatic and when I arrive at work, the bluetooth is turned off and the wifi is automaticaly turn on. And so on when I leave work.

I encountered some problems in version 0.1 of /e/ but nothing blocking. (- little problem with icons for example, now solved - problem to install “FreeFlight Pro”, now solved, etc)
One thing never worked on this device, it’s the weather on the page with search and suggestions. It never missed me, I prefer to look at the window. :slight_smile:

When version 0.5 came out, some more serious problems arrived :

Some other problems are less important. (weather widget theme sometime change from transparent to dark, or cosmetic issues)

Now, I still have the Redmi Note 4 with version 0.5 and I planned to give a Pocophone F1 in my family. So I bought a new Pocophone F1.
First of all, I noticed that the weather on the page with search and suggestions is working on this device, I have weather forecasts without any intervention. :sunglasses:

But unfortunately, I consider /e/ not usable in the state on Pocophone F1, I can’t give this to a non tech user in my family.
Too many blocking problems.

Other problems are less important, but present :

  • I always have annoying notifications like “Signal is using battery” or “Music is running in background”.
    Ok, it comes with Oreo, but it’s boring.
    As I was used to have a smartphone with Android 7 (the Redmi Note 4), maybe I’m not used to version 8 of Android enough.

  • At upgrade procedure, in TWRP, there is a message “Unable to mount storage”. But it seems to make the update anyway…

Note on TWRP :
On both devices, I had problem to flash TWRP. In the procedure, after the “fastboot flash recovery twrp-x.x.x-x-mido.img”, if I reboot, the recovery was still the one from Xiaomi.
I had to make two “fastboot flash recovery twrp-x.x.x-x-mido.img” command in a row to have the recovery really flashed… strange. 8-/

In general, I would like to see improvements on Bliss, like :

  • The possibility to place icons anywhere on the screen, not just all aligned.
  • The possibility to modify app icons order in a submenu as I group games together or apps together.

Some apps comes with /e/ but is not needed for me, I used this procedure to remove the unwanted system apps. (in fact just Telegram.)

I didn’t test an e account, but maybe one day, I will ask for one to see what comes with it.

In conclusion,
I still use /e/ and I planned to use it in the future on my Redmi Note 4.
I’m not using /e/ on the Pocophone F1 as there is too many blocking problems. In fact I don’t use at all the Pocophone… just make the updates to see if problems are gone.
And I hope, these problems for the Pocophone F1 will be solved in future releases as I realy would like to use it with /e/.

I’m convinced that version 1.0 will be even better.
Many thanks for all the team of the project, keep going, it’s a great job !


#2

So weird u have all those problems with the pocophone. I have it too with eelo on it but the only problem I encountered was the 1 with the camera.


#3

Hello,

Here are what I made to solve some problems :

After the answer of Eelo and when I had some time, I decided to reinstall /e/ with a fresh install.
Unfortunaly, no changes except about the date. After the reinstall, the phone always starts at the date and time of the installation…

So, I decided to test Lineage on the phone.
The recommended version of TWRP for Lineage is not the same as the one recommended for /e/. I started to install this version.
When I try to made the installation of Lineage, at the sideload command, it says that the firmware is not the good one, it recommend to install a MIUI version…
The error message makes me thinking about that /e/ procedure : https://gitlab.e.foundation/e/wiki/en/wikis/device/beryllium/install_post_android_9
As the MIUI version originaly installed on my phone was a version with Android 8, I haven’t applied that procedure for the first install.

I decided to try that before reinstall /e/.

So I flashed MIUI back this the version recommended in the procedure : V10.0.6.0.
Note that, if you do this, you will see that it relocks the bootloader.
You have to reapply the unlock procedure from Mi, but without any time to wait.

After that I installed /e/ with the classic procedure, but I kept the TWRP version that is the latest for this decive. (twrp-3.2.3-2-beryllium)

Now :

  • if I start the phone without any sim cards, it starts at the date and time of the installation. And when I start the phone with a sim card, the date and time are correct.

  • No change for the notch. It would be a feature improvement.

  • Opencamera still make very ugly pictures but good videos. I use SimpleCamera for photos.

  • Account manager still don’t work with my Baikal server, but the workaround with DAVx5 works now ! (https://gitlab.e.foundation/e/wiki/en/issues/45)

  • The blueetooh issues are gone. I can use it in the car (main use), with my rapsberry pi media server…

  • No more error message in TWRP during update.

Is there any firmware update that came with the MIUI installtion ??? I don’t know. Anyway, it’s better. The situation is close to my Redmi Note 4.
I decided to switch from my Redmi Note 4 to my Pocophone F1 as main phone.

I noticed that for the weather on the page with search and suggestions, it works only if I set GPS setting to “High accurate”.
If I set it to “Device only”, this app ask to activate GPS…

HTH.
Once again, many thanks for all the team of the project, keep going.


#4

Hi,

Pfff…
I just installed the update e-0.5-o-201905028808-dev-beryllium.

  • in TWRP, the message “Unable to mount storage” is back… But it made the update.
  • after reboot my phone is back at the date 2009-01-01 1:00… I have to set it manualy…

Thanks.


#5

Regarding the procedure that re-locked your devices’ bootloader:

Note that, if you do this, you will see that it relocks the bootloader.

Following the procedure should not lock your devices’ bootloader.

However, one step in the procedure (which if not followed correctly, could lock your devices’ bootloader) was possibly easy to miss and has now been emphasized.


#6

Indeed, I did not see that. I probably went a little too fast.
Thanks.