Naturalist (Ornithologist App) gets no location

I’m using a Samsung S8 and Naturalist App. This data is used by local nature services so i cannot change the App.
Unfortunately, the location isn’t working anymore. After Updating to 1.8.1 it was working, then failed and after reinstalling it was working again.
But now it is completey broken and i cannot get a GPS fix. GPS is working in Organic Maps, Magic Earth and a lot other Apps.
This would be really a essential App, because i cannot use an Alternative.

Thanks for your help

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Have you checked Advanced Privacy? Think the update turns on the fake location.

Hey @jalmer … so I’m not alone using Naturalist on e-OS :slight_smile:

Unfortunately, it’s a known problem with no solution as for now : see GPS no more working on S9+ for some apps since 1.2 (#5984) · Issues · e / Backlog · GitLab :frowning:

I got an answer from Biolovision, the Team behind thé App. Probably this help.


Change from continuous (fast) or so won’t help as it only change the frequency queries are made to the satellite.

We indeed use the GooglePlayServices to access the GPS device for several reasons:

  • The access is unified and we don’t need to program specifically for each device independently
  • It’s faster as it use Google geolocalised database of all access point (WIFI, GSM) to do a rough estimate that sensibly accelerate the initial fix.
  • It use less energy as it don’t relay as much on the satellites as other solution will.

So, we don’t plan to get ride of that for now. We have no experience with microG but I know some users use it.

That said, the GPS is not mandatory. What count is the location of the red marker, so you can still submit record but of course it’s less convenient than with a working GPS.


Your Biolovision support Team,

1 Like

I use the normal location for all Apps in Advanced Privacy.
Is there a better solution ?

I think there isn’t. :frowning_face:

I already know the arguments of Biolovision, the editor of the app, but there are many (FOSS and others) applications that work very well without this f…g Google layer … see OSMAnd as an example, or GeoPortail, or … The Open Source code for doing the GPS job could well be used “as is”, and activated through an option in the app, as a fallback (like the Sygic app and it’s “custom” geolocation mode).
AND there’s 1 wrong point here : YES, the GPS position DEFINITELY counts when you are using on-field protocols like french “EPOC” for the national surveil project, where it’s mandatory to save the location of the user / phone in order to be able to compute the distance between each observed bird and the user (these observations are then used to apply the Distance Sampling method :
I suppose this kind of protocol and data exploitation technique is used outside of France …

I realise @jpmeuret, that you have researched this thoroughly, but I read from my installed Local NLP Backend.

Note: The microG configuration check requires a location from a location backend to indicate that it is setup properly. However this backend will not return a location until it has mapped at least one mobile cell tower or two WLAN/WiFi access points, or data was imported. So it may be necessary to run an app that uses the GPS for a while before this backend will report information to microG.

This supports my idea that installing and using OpenTracks which runs on “pure gps” seems improve the general #gps performance of /e/OS in my case.

PS. OpenTracks offers the ability to set “markers” … just a thought, untidy, but if the apps are run together, maybe these markers can be shared / added to Naturalist app in some way ?

Thanks @aibd for your research and experience.
No marker / position shareable between any app. and Naturalist unfortunately (and actually, this should be a streamed sharing, as location is needed on a “under-minute” resolution for many features).
As for the “improved general #gps performance of microG / e-OS” in some apps by using other apps requesting GPS data to the system …

  • I generally do that with GPSTest before starting Naturalist … an habit that came because of this very GPS issue since 1.2, to check for sure that the 1st GPS fix has actually been done before considering that Naturalist actually does not get it (by its faulty use of the Android APIs and / or their returned values / status, whatever),
  • but not taken the habit of keeping such anoth app. running while using Naturalist => thanks you for the idea, will try it and report here :expressionless:

Thanks for your ideal. But OpenTracks isn’t Workung With Samsung S10.
can i change some settings. Thé includedMagic Magic Earth is working fine.
Best regards Johannes

I also have seen that error. I did a little research, I found I had to go to OpenTracks Settings > GPS accuracy. By reducing the accuracy and using the app in in order to allow the app to start triangulating successfully to the map, the message stopped.

My phone is a Samsung A3 (2016), GPS does not seem a strong feature of the phone, but I feel that sustained use helps the phone collect a database which in time becomes more serviceable.

I found another possibility. I added Local NLP Backend and now Naturalist is working. GPS is still slow in contrast to other Apps like Organic Maps, but functional.
this can be downloaded in F Droid Store.

Best regards Johannes

1 Like

Thanks @jalmer for the info.
For my understanding, do you have an idea of how - technically - this local NLP backend can help at the precise moments when the GPS is NOT working in Naturalist ?
Would it be that, by accessing to the local GPS chip data through another (working OK with microG) API than the one used by Naturalist (GStuff, not always working through microG), it somewhat “forwards” this precise GPS location through the NLP protocol to Naturalist (thus lying on the “nearby”, but that’s for good) ?

Dear @jpmeuret,

I don’t know exactly but although deactivating Mozilla Location Service didn’t help.
Is Naturalist working for you, too?
Probably the Backend isn’t communicating correctly with MicroG.

Best regards Johannes

It worked all the morning long with Local NLP Backend activated … but as the working / not working scheme has been until now unclear to me over time (and apparently changing somewhat after 1.9 or 1.10 or … some other unknown event happened meanwhile) … I prefer to go on trying for some weeks before starting to become confident again …
Thanks again for the lip : let’s only see if it is a confirmed workaround :slight_smile:

Unfortunately, I got stuck GPS the same way last Tuesday or Wednesday, after a few mn working (after a kicking ass stop / clear storage of microG).

Now, just trying to check if this Local NLP backend is still active (one never knows) … I can no more find where it can be activated or deactivated … neither in Settings / Location or in System / microG / Location … no more any trace of any NLP stuff … is it a new “feature” of 1.12.3 (just updated) or of the associated 0.2.28 microG ? :tired_face:

As an installed app, I first look in Settings > Apps and notifications > See all … apps > Local NLP backend.

Under permissions there you can check you gave Location permission.

Settings > Apps and notifications > See all … apps > top right 3 dot menu > Show system reveals Mozilla Unified Nlp Backend. App permissions > Location allowed

Now in Settings > Location >App permission you can expect to find Local NLP backend, microG Services Core, and in my case Apple UnifiedNlp Backend. Mozilla Unified Nlp Backend does not show for me today !

(You might be interested in this thread, where ideas for improvement of Network location are being discussed.)

Interesting; there is the idea that MicroG Services Core as the provider of Location services, maintains a cache on the device which is drawn upon to provide Location service in a timely way.

It is my experience that any time you start a device after format data, it will be some time before the device can maintain a useful network location service. I would very much like to know the location of this cache (if only to be able to curate it !)

e-1.12.3 | microG

1 Like

Thanks @aibd, clear and accurate explanations !
Same for me, no Mozilla Unified Nlp Backend in the Settings > Location >App permission list.

But what I had in mind was a settings page somewhere, that I’m 100% sure I have seen and used after installing Local Nlp Backend, where I was able to activate it through an “Off to On slider” (kind of checkox) … and I was not able to find this page again today :frowning:

e-1.12.3 (dev) | microG too

What you remember is no longer the case with microG 0.2.28. Everything has changed as far as location.

EDIT: For those on Telegram, the pinned post in the microG channel warns against blindly updating if location services are a necessity.

The fact that /e/OS 1.12.3 includes 0.2.28 we may find ourselves dealing with a new set of location related issues.


This is definitely not good news : 'cause on the S9+, we are still on Android Q = 10 …
And IIUC, these changes are killing the features of all NLP backend “plugings” (like Local NLP Backend), except for the Mozilla one … quite a strange way of serving users (non-regression, backward compatibility, …) in my opinion :frowning: ; and quite strange that /e/ developers also released this microG version given the release notes warnings :face_with_raised_eyebrow:
=> is there some communication about this somewhere (can’t see anything but the raw /e/ release notes, simply referencing the microG one, which is rather technical) ?

But by the way, this all morning long, the GPS was working quite fine on my side (but GPSTest reported no issue with the GNSS time … so let’s wait for some moment where this Bad GNSS time issue is back … unless this full rework fixed it ? … definitely need for some explanations on user-level impacts here !).