Need some advicse to update

My eOS version is now 0.23 and I’m wondering what version I should update to?

I did not update beause I read that a couple of update where to runing smooth.
So my question is, what version is the best to update between 0.23 and 1.5. And can I update directly or do I have to updatr in several steps?

Thanks for the advice

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

Hi snowest, you can update to the latest directly, in one step. Each update is the complete OS, so you can pick and choose.

You ask which version may be best so tell us what device and android version you are runnung.

See this post if you need it!

1 Like

Oh yes, sorry…
My phone is a FP3

Which android version?

Other Fairphone 3 users may help you. :wink:

I have Android 10 and eOS 0.23 from 13. Mai 2022

I think you are on dev branch, but it would be nice to be certain.

Go to Settings - About phone - Android version (← tap on it) - /e/ OS version (← long-tap it, copy it to clipboard and paste it here.

FP3 is not completely straightforward; you are going to have options and you will need to make a decision or two maybe…

0.23-q-20220513185542-dev-FP3

Correct, what dose that mean?

Is there a way to backup all the fone in a simple way like apple backup? If I have to reinstal a stable version, shall I do somthing before installing to be able to backup? Or is it now in the newest stable version?

I think dev builds on FP3 are for users who have installed the eOS themselves and the stable builds are for the Murena FP3’s, bought from /e/. Maybe @AnotherElk (Fairphone afficianado!) can comment?

Backing up is a topic in itself.

As far as I can tell you should not have to manually install an update at this point in time. You could choose to update to the latest Q 1.5 and se how that goes. But I would say be careful how you choose what to update to from the list you have in your system updater. You can long press them to get the url to copy/paste somewhere and check the exact details.

Have a read of this weeks Development Updates thread, there is a paragraph especially for the FP3 with links to explainations of the differences between dev, stable, beta etc.

You may decide to try the OTA version update to R, for example.

1 Like

Okay thanks, I don’t mind havin the dev version. I had some trouble before 0.23 that I don’t want to run into in newer versions. Yes I know, it is a development project and bug are totaly normal. But some bugs are biger than others, like not beeing able to make some calls.

Hi Snowest, you are missing out on the september 5 Android security updatei included n eOS 1.5 running versión 0.23 of eOS. Personally I’m quite keen to get those, it was actually my reason to switch from Lineage to eOS when Lineage stopped supporting my old phone and eOS was still providing those Android security updates.
As for the dev channel, there is no difference once the stable version is released.
The dev channel offers the developement versions once those have been tested by a group of testusers. The critical flaws (as far as known) should be gone by then.
People that are on the stable channel only get final eOS versions but will get the Android security updates later as a tradeoff.

@Manoj, correct me if I’m wrong.

Originally this was the case. In the meantime, every user can choose to install stable on the Fairphone 3/3+ manually or via the Easy installer.

This is not always true. Example:

In my opinion, I would prefer to’load a stable build as it is supposed to be more stable than the dev ones…

@Snowest This is very interesting…
If you look at the link below you will see that the Q build is stable. And most Q builds tend to be on version 1.4 at least. Is there any reason why your phone is not on the stable branch?

https://doc.e.foundation/devices/FP3

Hi,
Can I just jump into this topic because I have a very similar question?
If not, please correct me.

I have a Samsung S8 that I bought directly from the Murena shop, and which I always updated by going to the Settings and than to the Update-app.
But since the release of v1 the Update-app does not propose me anymore to install a newer OS-version.
And whenever I check for updates, it gives me the message that no new update is available…
The current version is: 0.23-20220406176461-stable-dreamlte

Is there something I can do to fix this problem?

Thank you in advance.

1 Like

This version info is missing the Android version your /e/OS 0.23 is based on, but looking at what’s available for the S8 there seems to be no variety in that regard, all publicly available dreamlte builds are “p” = Pie = Android 9 (see Settings - About Phone - Android version).

0.23 was the last /e/OS version based on Android 9 and prior, update support was dropped after that (the Android 9 base wasn’t getting security updates from Google anymore for a while already before /e/OS followed suit), so the message your updater gives would be correct.

Since currently there don’t seem to be builds for manual install available based on newer Android versions for the S8, you can currently only wait and see whether the developers manage to finalise the announced OTA upgrade via the updater on the S8, you can follow proceedings here …Topics tagged development-updates

(S = Android 12)

1 Like

Hi AnotherElk and thank you for your kind help.

It is indeed android 9 that is installed on the phone.

It is very helpfull for me that you gave links to the things that you mention.
That way I can learn about it and follow it up also.

So an OTA upgrade is planned, but it is not sure that it will ever see the day.
That’s already a better expectation than the one I had (I doubted that the device was not supported anymore).

Thanks again.

I can not say ehy I’m on dev, but I use eOS over two years and I regularly did updates until some serious issues (battery problems, call problems) appears around version 0.19 or 0.20, can’t remember exactly. Version 0.17 was very good. So I went to version 0.23 witch work fine. Yes I have some minor bugs like apps rearanging, but this is probably because of a sertain app that makes thr bliss launcher to crash. I tried other launchers bht none is as good as the bliss in my optinion. So I stayed on v 0.23.

I see a lot of updates, so this is actualy great. And I feel now that I have to update otherwise I will maybe run in some problems maybe. Like app compatibilities or somthing similar.

So this is why I asked what version I should go to.

I would like to update ota, but if someone recomand me to make a new install with the stable version. I can also imagine to make a complet fresh install. I’m runing all my data on a nextcloud self hosted server.

@Snowest Like I mentioned last time. I suggest you go to stable and not dev. You should be on version 1.4, if not 1.5 by now. I even sent you the link, did you have a chance to look at it? For Fairphone 3 you should be able to use the easy installer to get it to stable and up todate. After that you should be able to get OTA updates easily.

@Seven yes I did look at the link and I apologize not responding to your message.

To be honest, I don’t want to make a new fresh install but if nothing else is left I will do it ofcourse. I still don’t see the big diference betwwen dev and stable. Because the stable is based on the dev and if I’m not updating to all new dev versions but wait one or two version behind, then I imagin not runing in troubles. Probably I’m extremly wrong with my thinking.

I will do it like that, update to version 1.4 ota in the dev version. If I run into Problems, then I will definitly switch to Stable and make a full new install.

I don’t now when I will do that, maybe in december.

Thanks for your ansere it helped me a lot.

1 Like

@Snowest No apologies needed and you are welcome :sunglasses:. I can understand you don’t to make the switch , but there is a massive difference between version 0.23 and 1.4 or 1.5. This can mean massive difference in applications compatibility as well as issues with privacy, or things as simple as functions that are depreciated. If the dev version is on 0.23 that there maybe a good chance that the devs have moved on to more current versions,which is why I sent you the link to fair phone 3 to show you which version they are on for your phone, which can mean your phone has some software vulnerabilities.

If you look deeper into the link I sent you, you would see the current development branch… it’s on 1.5, 1.1 at the least. So I’m pretty sure the devs have moved on from 0.23.
https://images.ecloud.global/dev/FP3/

Here is the stable branch. Same here. The lowest being 1.1 but highest on 1.5.
https://images.ecloud.global/stable/FP3/

I highly encourage you to make a back up of your phone and either use the easier installer or do a manual installation so your phone is up to date on features as well as privacy and security. Not to mention improved app compatibility and features. I think you will be happy with the new version, and all that it will brings to your phone. Hope this helps as well.

1 Like