Need some help with custom recovery

Hi @FreeSpace check this link he mentioned his OEM unlock was on. Pl can you check

1 Like

here is a full guide

Apparently @Manoj you were right. I can go further now, I can reach the recovery mode which is like the picture below. So, how to install /e/ with that ( → the part “Installing /e/ from custom recovery” seems to be written for the use of Official TWRP App, don’t it?)? Should I restart from the beginning or not?

Thank you :wink:


Not sure as I do not have a samsung device.
@rhunault any help here. @FreeSpace now seems to be in the default recovery mode and not TWRP. Can the /e/ rom be placed on the sdcard (if available) and flashed with the Apply update from SD card option.

The /e/ rom is already on the sdcard. I did it earlier.

Ok have you tried to run it by selecting the option given on your screen ‘Apply update from SD card’ what is the error you are getting

No, I haven’t tried. But I think I have understood what’s wrong. I checked and the device is not rooted (so I cannot used TWRP) however I did the following steps before :
The enable developer mode procedure:

Go to Settings.
Scroll down to "About Phone".
Software Information.
Look for the infobox "Build number".
Tap this 7 times, after 3 times you will get a notification "you are x tabs away etc"
Head back to "Settings".
Scroll Down.
Select "Developer options".
Enable: "OEM unlock".
Enable: "USB debugging".  

@rhunault If you want we can continue this conversation in pm.

You can use TWRP without rooting device. But you have to enable OEM unlock. Now you did that, it should work.

I did it without rooting my phone.

I think you don’t know the defiifernt between rooting and unlocking. For TWRP and/or flashing a custom rom there is no need for rooting. But the boozloader must be unlocked. And I think your bootloader is NOT unlocked nd that’s the problem

You’re right. Also, I can tell you there’s something wrong with fastboot. Adb detects my device but not fastboot.

I’m still searching for a solution. What do you think about flashing the recovery image with heimdall-frontend?

Seem to have only recovery and download modes on Samsung .: See last comment here.

fastboot detects your phone only when you are in bootloader mode. Try using adb reboot bootloader from your device with adb enabled.

Also, when you are in bootloader, adb is not available.


Still no change.

When I tried to use the recovery mode I went to default recovery mode and I got this following message at the bottom of the screen :

#fail to open recovery_cause (No such file or directory)#

#Reboot Recovery is [UNKNOWN]#

File-Based OTA
Supported API: 3


Successfully verified dmverity hash tree
E: Failed to clear BCB message: failed to find /misc partition

I read again the thread and as you work with a Samsung device, you can’t use fastboot (use heimdall instead).

When your device is on download mode (the blue screen), do the following:

  1. run heimdall print-pit
  2. your device will reboot automatically. You have to manually reboot in download mode
  3. run heimdall flash --RECOVERY twrp-x.x.x-x-a5y17lte.img --no-reboot
  4. When it’s done, you have to reboot your device into recovery mode
    • hold home + power + vol up + vol down
    • when screen becomes black, release vol down and continue holding home + power + vol up until you see TWRP logo

If you see TWRP logo, you succeeded! Otherwise, you have to try again all the process.

1 Like

Thank you a lot, I’ve succeed in installing /e/. Also, thank you to all guys who helped me earlier. But… I have these problems:

Good news! For the problems you described:

  1. SIM card issue seems to be device dependent and have to be fixed.
  2. Is the device plugged when you power off? I faced this issue sometime when my device was plugged on power delivery.

You can find more details here :
Sim card not detected

Thank you for sharing the link. An issue is already raised on GitLab here.