Sim card not detected

samsung-galaxy
build-issues
support

#1

Hi everyone,

I’ve installed /e/ yesterday on my Samsung Galaxy A5 2017. And I’ve encountered 2 issues : The first one and the main, my sim card is not detected. I read that arrived earlier with others users on the same device ( https://gitlab.e.foundation/e/management/issues/59). I also read that was because of the IMEI which was lost during the installation of the rom. The second issue, less serious it’s when I try to power off my device it restarts.


Need some help with custom recovery
#2

I read threads on several forums about lost IMEI. Most of the app which could fix that uses root access. So, I rooted my device but that didn’t let me all the access of apps like MTK Engineering Mode or Mobileuncle tools. Anyway, since I’ve rooted my phone, it powers off normally anymore.


#3

I thought that my efs folder was completely deleted. But using Root Explorer, I realized that wasn’t the case. The files on the screenshot should be corrupted and need to be fixed… I think so but how??


#4

I confirm I too encountered the same problems : SIM card undetected, powering off actually restarts the phone.
SIM card : French Bouygues Telecom.

While the issue is not fixed, a warning in the installation tutorial may be welcomed : https://gitlab.e.foundation/e/wiki/en/wikis/device/a5y17lte/install .

Edit : Warning have already been made : https://gitlab.e.foundation/e/wiki/en/wikis/device/a5y17lte/info .


#5

Hi,
Sorry I was quite busy these last weeks. I don’t know for you but the reason that the sim card is not detected is that the IMEI number and baseband were erased while I’ve installed /e/. Also, I was so a dumb not to do a backup. I’m looking for a solution to fix it but I’m quite desperate and hopeless after looking some threads in different websites.

@gael @Manoj Do you have an idea please?


#6

Thanks.

I don’t think i got that, since i succeed to install back Android 8.0 with a working SIM detection.
LineageOS had the same problem as /e/.

I tried to save a backup but it didn’t worked (problems about mounting some things…).

The phone is my girlfriend’s. I used for her all i learned with /e/ : F-Droid, Yalp, Signal and so on. To limit Google presence. If you have trouble getting back Android, i succeed with the lastest version of Odin and a firmware from Sammobile.