New and unknown PIN requested after having updated /e/OS

there is a /e/OS device that is locked by a new and unknown PIN after having updated /e/OS…

I recentyl recommended a friend of mine to update his SAMSUNG S7 SM-G930F (bought 2020 with /e/OS 2020 something) with the new /e/OS/. She never did before. So she updated from /e/OS/ version 2020 something to /e/OS 1.21. The update ran fine, but after the first restart the device is locked completely because the device requests to enter a PIN that was never been asked before. Before having updated the /e/OS the device asked only for PINs:

  1. SIM PIN
  2. personal PIN to unlock the device

Now the verify first PIN that is asked for (before SIM and personal PIN!) requests (translated from german):

After the new start of the device it is required to enter a PIN

But neither the SIM PIN nor the personal PIN works in that case. In between we tried about 30 different PINs without success, we also used possible default PINs like 0000 or 9999 or 1234…

What kind of PIN is it that pops up now and keeps the user locked from the device?
How can we circumvent that PIN and use the device…without resetting to factory defaults and loosing all the data?

I am lost…I also use a Sasmung ePhone with /e/OS 1.21 and never was asked for that kind of PIN.

Thank you in advance

Regain your privacy! Adopt /e/OS the deGoogled mobile OS and online servicesphone

I get that you are uncertain about version number and build type for your friends phone …

In advising your friend you might look together at the published ROMs (below) to find your start point, and whether what was performed was an Android version upgrade; and was it on stable or dev.

a) If the phone was on stable there was a slightly complex Upgrade path notified here Week 08 2024: Development and Testing Updates - #9 regarding the OTA Upgrade that would have been offered. Also special release note here

b) Later edit. This question is about the OTA system updater, so no OTA Android version upgrade should have been available for a dev build. (If the phone was on the dev build, was an Android version Upgrade involved ? This would have required Format data. Fail to format data in this case might have caused some corruption which might cause PIN failure.)

Fingerprint scanner fallback PIN?
I haven’t used any fingerprint scanner, but from what I read when you set up the scanner with your fingerprint(s), you are required to give a fallback PIN which then gets prompted for if the scanning fails, perhaps it’s even mandatory after a reboot.

Here’s a reference on a OnePlus with a screenshot … … does this look like the screen you are facing? (Well, it looks pretty generic, but the scrolling text seems to fit.)

1 Like

I am am pretty sure that the recent update was a stable version, because this is what is offered usually in the ‘System Update’ settings (as far as I see it). And I am pretty sure that the recent update included an Android version upgrade, because the last version was one of the year 2020.

I will try to get the device and to look at using recovery mode and ADB…

There was also a support topic on this upgrade

On the basis that we are talking about the stable releases (found on any device bought from Murena) … there would be risk of loss of data, but in the case that a “new” Android 11 (R) build has failed to be initiated you may be able to sideload an earlier Android 10 (Q) ROM so that you are able to take the correct stable Upgrade path via v1.17.1-q.

Worth searching for forum posts February / March time where SAMSUNG S7 SM-G930F users had some success “going back” where the OTA upgrade got tripped up by missing the “v1.17.1-q warning”, here’s one Stuck at "finalizing the system update".

What we tried in between:
starting in recovery mode, delete cache, restart → no change, PIN still requested
starting in recovery mode, factory reset → failed. I have no idea why.

So I think about to sideload a new stable version of /e/OS . Where do I get it from for the brand and make of the hardware SAMSUNG S7 SM-G930F? I remember in the beginning of ephone it was offered to download the OS only for dedicated hardware and there was documentation how to migrate from a Google Android to /e/OS. But it is no longer mentioned on . Is it still an option to sideload an new /e/OS?

The links to the ROM images are in Post #2, the install instructions are linked from

Following the line of @AnotherElk’s comment, here are two links which may give insight to the unusual state of this device and also

I see two ways forward, a) to treat this as a new install and accept Data loss. [1]

b) Generally speaking you cannot “go back” simply from Android 11 (R) to Android 10 (Q) … but as I said in my last post you might however be able to this if Android R never booted.

You will have noticed from the links I already gave that it is significant to this issue whether the phone had an SD installed as Portable storage. In this case was there an SD installed as Portable storage ?

What I think I would attempt is to sideload and see if by any chance the phone will boot.

[1] Edit You might check on the Download mode screen to see if Factory Reset Protection – written top left as FRP: ON. If on this may affect your ability to run a standard Fresh install.

Thank you for all the hints! In between I could check the phone in error.
We started the phone with no SD and no SIM, but no improvement, neither in case of normal start nor in case of start in recovery mode…

The initial problem that the user is asked for a PIN allow to enter a PIN with possibly no limit in the digits. I could enter a PIN with more than 20 digits, totally unusual to me. After having entered the (wrong) PIN I get a message to wait for 30 or 60 seconds before trying the start the nexrt try. Possibly this behaviour explains which service is asking for that new and unknown PIN that locks from further usage.

The main problem now is that the phone is stuck in recovery mode because the owner tried some options in the recovery mode panel. In recovery mode the phone stuck in a ‘Download’ mode of a custom OS and I see no way how to get rid off.

Whenever we start in recovery mode we end up in the ‘Downloading’, even after the battery went to 0%. So any idea how to get out of that ‘Downloading’ lock? I need see to the menu of the recovery mode to have a chance to ‘factory reset’ or ‘cache delete’ or to sideload…

I hope I will not sound too blunt :slight_smile: This is an unusual and special case where an unusual for /e/OS required Pre Upgrade measure was not applied.

I do not have the phone, so no direct experience, just reading posts from other users who faced this. Full reading of my earlier links will be a good idea.

This question was asked as it was significant to the required Pre Upgrade measure, and the answer will help me to speculate less about the current issue.

Regarding the PIN issues I said

This was to avoid speculating but I can visualise that no PIN can be validated due to the current state of the data partition and probably its encryption; this would be linked to any absence of any earlier installed SD card used as Portable storage (unknown to me).

Your images are of Download mode show that FRP is off (good) :sunny:

Download mode is a solid part of Samsung and is protecting the phone (good) :sunny:

Just checking … Recovery mode is reached from

With the device powered off - hold Volume Up + Home + Power. When the blue text appears, release the buttons – but you say

You can use Download mode to reinstall Recovery using the install page instructions

Some users have said this looks a bit intimidating, I think as the methods for Linux and Windows seem mixed, but actually the logic is correct.

There is also the method in this link for Windows: [HOWTO] Install /e/ on a Samsung smartphone with Windows easily. Written when TWRP was the regular Recovery the instructions apply equally for e-Recovery. If you were going to attempt to sideload back to e-1.17.1-q- you would probably choose recovery-e-1.17.1-q-20240208379201-stable-herolte.img

Since it says ODIN MODE at the top, and I suppose you are not doing anything with Odin at the moment … The internet says to press and hold Volume Down and the power button to exit this mode.

Got it!
After having started in Recovery mode and with NO cards in the phone I wiped the cache → no improvement
After that I tried Factory Reset → failed, I have no reason why
After that I formatted → successful

After having restarted /e/OS came up with the most current release and I could go through the initial startup steps.

Thank you all for your patience!


Try to register a fingerprint and see whether you get asked to give a fallback PIN.
If so, give one, then reboot :wink: .

This topic was automatically closed after 60 days. New replies are no longer allowed.