Stuck at "finalizing the system update"


I just updated my Samsung Galaxy S7 (herolte) yesterday.
I went from the penultimate update of November to the latest one.

FYI, I installed /e/os originally via the easy-installer and install the updates automatically (not manually) via the settings.

The process went smoothly and the phone restarted without a hitch.
Once switched back on, I connect without any problem, but in the notifications, an Android notification indicates “system update finalized” and since then (it was yesterday), nothing has changed…
Android seems to be working, but no application is functional. I’ve tried rebooting and restarting in safe mode, without success…

Do you have any idea how to fix this?

Thanks and have a nice day,

Regain your privacy! Adopt /e/OS the unGoogled mobile OS and online servicesphone

So it seems you missed this warning:

and you seem in a similar position to Problem update 1.20 on Samsung Galaxy S7

Late edit In case it helps others, there is this support topic, Revealed with an image from e-1.17.1-q in this post Installation OS 1.20 sur Samsung S7 - #3 by Commando961

Thank you very much !

Indeed, I miss the warning… :confused:

The link, you send me, seems to present the same problem as me. However, since I use an adoptable storage (which doesn’t seem to be the case of that person), I wonder if the only solution is not to re-install /e/os on the phone via the easy_installer…

I have an almost complete backup of my data, so it may be an easier solution…

First I would be nervous of using the Easy Installer as there have been unexpected errors with recent versions.

You could simply reinstall 1.20 by the sideload method described on the install page (There are alternatives.) I would advise that you should Format data during the reinstall.

Should you need any support with this, are you using the e-Recovery ?

To deal with Adoptable storage situation (this is something of a guess about the possible current state):

  • Can your SD card be read on a PC
  • is it reported as “unusual” or corrupted on the PC
  • and / or can you take a backup off it ?

I would advise, if anything is corrupt about the SD card that you format it before use in your phone, or at the minimum, leave it to one side till you know the phone works again. After reinstall of 1.20, run the First start wizard with no SD card or else with a fresh clean SD card installed as “Portable” that is External storage.

Returning to the state of the phone, in taking this action, we do not yet know if Format data is sufficient.

Good morning,

Thanks for your message that I read after… A lot of tweaking… But that comfort me in my choices ^^

After disconnecting the SD card and restarting the phone, I found out that the update was finalized ! Ok, so that was good news.

I made a pretty complete backup before the update, so I wasn’t anxious too much about the SD card. But I tried to connect it to a PC. It was recognized but “corrupted”. I tried to repair it, but it didn’t work…

Finally, I decided to delete the card from the phone settings and to use a fresh new one as portable (I will not make this mistake again…)

I moved back all my data back to the phone and reconfigured all my apps. The phone seems to work fine now. Since yesterday, I have only had one unexpected reboot.

I think I will not have to reinstall /e/os at all, and that’s good news.


This topic was automatically closed after 60 days. New replies are no longer allowed.