New Self Hosting Installation setup failure

I have a Linode 4 CPU Cores, 8 GB RAM, and 160 GB Storage. New Ubuntu 22.04.3 LTS image and then updated and upgraded (With new kernel.)
I have the DNS set up with a reverse DNS at Linode. Also got Linode to give email sending access. (Free but you have to ask with Linode.)
I can run the install script and it finishes fine. It is after that, there is a problem.
The self hosting readme wants a Manual account creation by going to https://$DOMAIN/apps/rainloop/app/?admin (And yes, I put in my domain, not $DOMAIN) but it will not find the page.
I can go to bash /mnt/repo-base/scripts/ and get my user name/passwords. welcome.$DOMAIN did not send me a login invite. $DOMAIN allowed me to log into Nextcloud part with the admin/password. Not able to make a new user that worked.
So how do we get to administer the Self Hosting Installation, and create new accounts?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone


The readme needs a little rework, there is no RainLoop anymore (replaced by SnappyMail).
→ you can find a link to SnappyMail admin, and your random-generated admin password, at bottom of https://$DOMAIN/settings/admin/additional. No need to change the password.

As an alternative to welcome web, you can try /mnt/repo-base/scripts/
:warning: with both web and script methods, about the “current email address”: it is not the address you want to create, but an existing and unique address (preferably not within $DOMAIN). The invite email will be sent to this address.
For example, if you have a “erothoff” Murena account with email address, you could use to get the invite email (you can put anything you want after the “+”).
Please note that this will also be the password recovery address for this user!
Also, one invite address (like can only be used once in your entire instance. You can check /mnt/repo-base/volumes/accounts/auth.file for “burned” addresses.

To check if emails are really going out, you can use postqueue:

  • cd /mnt/repo-base
  • docker-compose exec mailserver postqueue -p

I have got farther, but still not working right.
I had to change the SPF Domain entry, Add the DKIM and DMARC Domain entries. Emails are going out, and postfix gave an error that the config was out of date, when I recreated the VPS, it didn’t come up. (Added the DKIM and DMARC after that install and before initial welcome.$DOMAIN run.)
But when I try to create an account either with welcome.$DOMAIN , /mnt/repo-base/scripts/ or the initial signup line at the end of the installation, I keep getting two different errors, the first is that that the name was invalid (Can’t get the error message again, but in the setup screen, I did not see Display Name either.) and the second is “An error occurred while creating your account!” (Which that creation screen is a little different. It has rows: Display name, Username, Enter Password, Repeat Password.)
*** I finally got past this. I was using a “!” in my password, and when I just put Capital, Lowercase and numbers, it created the account ***
So now I see that the self hosting does not have “Deck”, the “Document”, “Spreadsheet” or “Presentation” like the Murena site, and I was also hoping to add the “Talk” and other apps as well that are in Nextcloud. Are we able to add this?
Finally, how do we submit bug reports / suggested corrections? I was able to submit one or two on the phones I use, but this? Thanks for the help!

I found where I can add apps. I just was looking in the wrong place. Unfortunately, I added the apps before I tried connecting my phone or nextcloud app to the server. So I can’t rule that out as a problem. Like @Epsilon in Legitimation issues, I can not log into the new self hosted server with /e/ OS or a nextcloud app.

Nice find! :smiley_cat:

Selfhosted won’t include Office-like apps OOTB, as they are too heavy for a base VPS.
However, once you have the necessary hardware, you could install an Office solution using iy’s official guide.

I’m currently investigating, will take some time unfortunately :confused:

Please see this one as an example:

Have you tried setting an App Password, generate the QRcode and log in from NC app with that QRcode!?

I wrote something about that here:

it’s the part: ( qr code option, would allow for access through nextcloud app, if you wish )

Hi @make-nz,
Thanks for the suggestion. On another thread, @smu44 had suggested using:

cd /mnt/repo-base && docker-compose exec -u www-data nextcloud php occ config:system:set main_domain

which also fixed the problem. I have installed 2 servers and one of them I reinstalled 7-8 times… a bug report was finally put in, so hopefully we won’t have to correct the installation any more.
Thanks again for your help.

This topic was automatically closed after 90 days. New replies are no longer allowed.