New user's Experience, Problems, Solutions and Doubts

Presentation

Hi, I’m Porru, new user of /e/OS!

I have been looking for a (more) free Android ROM for some years but at the beginning it seemed not so easy. Also, LineageOS seemed not so free as I would like. So I installed /e/, knowing two friends who bought a phone with it:

  • One with a good experience, he is sysadmin.
  • The other with a really bad experience with a lot of bugs and problems, which no one seems to know how to solve.

So I decided to install /e/ and try it out by myself. I obtained a Xiaomi Redmi Note 4 X and installed on it. I had to install TWRP and I also had some other problems, but finally I managed to get it working on a day; I’m GNU/Linux user for some years and I have people near who knew about installing custom ROMs.

Device: Xiaomi Redmi Note 4 X
ROM: /e/ Mido


Experience

Installing

The installing experience was enough easy, doing it half following the guides on /e/ and LineageOS, and half with the experiences of my familiars.
The way I installed the image was:

  1. Puting the .zip file into a SD card and putting it into the phone
  2. Entering in TWRP, deleting previous data on the inner memory (Wipe) and clicking Install > Select Storage > SD card > .zip file

The installation went without any problem.

First impression

I liked the initial configuration with clear messages and only necessary configuration. I did not use an /e/ account and all went as expected.
The aesthetic and workflow of the system was better that I would expect, so I was so impressed!

However, there were some tiny bugs and strange (unexpected) configurations. That was what I would expect on a quite new project as ungoogled android is. But as said, those problems were much fewer than I thinked about.

I’ll deepen on those problems in the section named Problems

Graphical environment (Bliss Launcher)

Previously to install /e/OS I thought it would have a tipical Androidish appearance, but what I found was an iOS-type one. This was quite annoying at the beginning, as I expected and wanted an Androidish appearance.

Here I’ll treat a doubt about graphical environments, on how to understand and work with graphical environments on Android.

I also have some doubts about Bliss Launcher, such as moving or deleting widgets.

Synchronization with Disroot account

As I mentioned before, I didn’t use an /e/ account, but yes a Disroot one. My intention is to replace my previous Google account (with contact, calendar… sync) and to take benefit of the other Disroot services.

I had a tiny problem with Mail app and a Disroot accoun and a bigger one, without solution since now, with Tasks.

The other synchronized apps (calendar, contacts…) went as expected, no problem.

Preinstalled apps

I knew about this characteristic of /e/OS previous to installing it, so it was no such a surprise for me. As more other users, I would like to be able to uninstall preinstalled apps (but this can’t be done unless using TWRP).

Anyway, I got a great surprise with the Recording app, which can record screecasts!!

The bad experience I had with Maps (Magic Earth): it is not opensource!! It is proprietary and free of charge software, according to https://wiki.openstreetmap.org/wiki/Magic_Earth.
In addition, probably as it is not opensource, it’s not available on so many languages, which is so a pitty for little languages.

I would prefer to have OsmAnd as default maps app, which is opensource and translatable. Also, it has so many features and configurations that it can be configured by default (as a fork) to be more user friendly.

As well, I did not liked that the Browser app had Google Search as default searching engine. In my opinion, it would be more consequent to set as default DuckDuckGo or StartPage, or any other.

I had no major problems or upsets with all other apps :slight_smile:

Summary

After configuring a bit and using /e/OS for nearly two weeks, I’m really happy.
I’m starting to get used to the appearance and to the workflow. There are, for sure, some tiny problems; but that’s totally understandable and necessary to improve.

Also I’m glad to have such a good community here!


Problems

Configurations

These are not problems per se, but unexpected behaviours and configurations for new users.

Camera

Camera opens with Power Button

This configuration was by default on my /e/OS: Camera opens when pushing power button some times.
My problem was that that button does not function as expected, so pressing it only one time opened the camera, this way not being able to unblock the phone.

Solution: Settings > Gestures > Open Camera

This is a rough route, I don’t use English locales

Camera unexpected GUI

There are some camera GUI configurations which may result excessive to average user, most of us coming from Google’s Android or iOS:

  • Show Time, Free memory, Battery and ISO
    • Solution: Camera > Settings (upper right gear) > Camera preview...
  • Zoom slider
    • Solution: Camera > Settings (upper right gear) > On screen GUI... > Show zoom slider control

Unable to make Screnshots

At beginning, there’s no apparently way to make screenshots on /e/OS. No power+volume buttons, no three-finger gestures.
So it must be configured manually:

Settings > Buttons > Power Button > Poweroff Menu > Screenshot

This is an rough route, I don’t use English locales

In my case, as I wrote down before, the power button does not function well, so it is very difficult and tedious for me making screenshots.
Is there any other way to take screenshots?

Synchronization with Disroot

Mail

This problem is not directly connected with /e/, but with Disroot and K9Mail:

When adding a new Disroot account on K9Mail, writing address and password, it returns this error:

Username or password incorrect

The solution is pretty simple:

  1. Manual setup
  2. IMAP
  3. Change IMAP server: imap.disroot.org to disroot.org. Next.
  4. Change SMTP server: smtp.disroot.org to disroot.org

Doing this (removing prefixes) you should have a good configuration.

Tasks

On the app named Tasks on /e/OS, forked from OpenTasks, I cannot manage to add a non-/e/ synchronized account. I see no option to add such an account.

I tried to install the original OpenTasks, but is not possible as the system understands Tasks as Opentasks. And as far as I know it is not possible to remove preinstalled apps (on a for-user way).

Music App

I had a problem with the song view mode, as it closed always I opened it, if denied microphone permission to Music App. This was a problem that a friend had also on their device.

Anyway, it’s now solved on this topic:


Bugs

I found some bugs, both linked to Camera:

Camera options from drop-down menu:

  1. Add Selfie Camera, Camera or Record video options to the drop-down menu.
  2. Tap one of them.
  3. Camera will appear correctly, but the drop-down menu will be showed, and horizontally.

From Camera to window-selection view:

  1. Open Camera.
  2. Tap the corresponding button (most of times hardware’s left one) to open window-selection view.
  3. Such view will be displayed horizontally, with no way to turn it vertical.

This seems to be happening on Open Camera for at least 3 years, also on Google’s Android: https://sourceforge.net/p/opencamera/tickets/70/


Doubts

Graphical Environments, Launchers…

Using GNU/Linux distros, it’s known that one can change the graphical environment (GNOME, KDE, MATE, Cinnamon…): the distro will remain same on the root, but the appearance will be changed.

Is it possible to understand this matter on the same way for Android? Are “Launchers” the equivalent to GE/DE on GNU/Linux distros?

Bliss Launcher

Here are some doubts I have about the default graphical environment:

  • Is it possible to modify the appearance?

    • Can the most-left page, where the Search, App suggestions and Widgets are, be deleted?
    • Is it possible to move widgets to another pages else than the most-left one?
  • When adding app icons to a folder, one can move those folders, but is it possible to move the app icons inside the folder?

Another doubts I had were how to hide app icons, whether there was an Androidish menu and how to put app icons where user wants, not in completion order; but I finally deduced that it was the expected behaviour of Bliss Launcher.

Screenshots

When power button does not function well it is difficult to take screenshots.
Is there any other way to take screenshots?

Contributting

I’m a dedicated contributor to free software, both reporting bugs and problems and proponing features, but most of all translating projects.

For translating, as Android environment is not on my knowledge for proponing features, I have two main doubts. Both /e/OS and most of the default apps on it are forks of other projects, so there is my doubt about which project contribute to.

  • If I want to translate the System, such as the Settings: /e/OS, LineageOS or Google's Android?
  • If I want to translate SMS app, forked from QKSMS: Message or QKSMS?
  • If I want to translate Tasks app, forked from OpenTasks: Tasks or OpenTasks?
  • If I want to translate Camera app, forked from OpenCamera: Camera or OpenCamera?

The main doubt, so, is whether to translate the original project or the fork.


That was all!

Thanks for all the work this community does!

Porru
Amon kaj Liberecon

8 Likes

Hi, thank you for your feedback :slight_smile:

Feel free to use another Launcher, you can find a few in F-Droid (or the /e/ Apps installer).

I guess it’s because the Tasks app is made for Nextcloud.

It’s a legitimate concern.
(I personally prefer Magic Earth since it’s much easier to configure (it can take hours with ~OsmAnd), and for me more accurate with a design I prefer and circulation informations.)

Are you sure ?? Google isn’t supposed to be by default, it’s not even supposed to be suggested. Instead it’s supposed to be the /e/ spot meta search engine.

Exactly my situation, and I had to deactivate this option.

I don’t remember exactly how the default configuration is but indeed maybe it could be a little better.

Again, same situation. It took a few weeks before I discovered I needed to press the Power Button + volume down for 1 second.

Now you know there is.

As far as I know, Bliss Launcher is being rewritten so new features will probably come in the future.

To help in the translation, you can go to https://i18n.e.foundation, thanks :slight_smile:

2 Likes

Regarding the launcher, plaese have a look at Open Launcher from f-droid.
https://f-droid.org/packages/com.benny.openlauncher/
It is highly configurable and fun to use.

2 Likes

Regarding the browser & search enginge I learned a lot. The browser is a fork of bromium with several security features.
/e/ spot, the search engine is the default, as pointed out by @Anonyme. This is in turn is a fork of searx with a lot of candy. You prefere duck duck go and startpage. /e/ spot can query searches anonymously to them plus quant, yandex, … . Definately worth a try.

1 Like

Thanks! For now I’m really nice with Bliss Launcher, but I’ll try other launchers on other user-directories!
A doubt I still have is if launchers are equivalent to graphical environments.


What seems strange to me is that Disroot uses Nextcloud, so it should work. But even stranger is that I see no option for account or synchronization on Tasks! I’m a bit lost with this.


About Magic Earth, it’s all about liking. I prefer open-source than comfort, so there’s no much to argue :slight_smile:


I did a grand error, sorry. I feel sorry about saying that about Browser, it’s all okay and I’ll give a try to it!


Wow, I tried that but didn’t function at the beginning. I suppose it’s due to the 1 second time. Thanks @Anonyme!


Great!!


Perfect! I’ll definitely contribute. However, this will only translate the forks and not the original ones, is not?



Thanks for your complete answer, it’s a pleasure!

Yes, you two are right. I’ve been using it since yesterday and seems great! :blush:

  • Regarding the launcher, besides some issues / complaints on Bliss, i guess it’s a matter of taste and we can install and use different launchers as well

Trebuchet (LineageOS launcher)

Lawnchair 1.2 on f-droid (i prefer this one)
it should be in Apps also if you dont have f-droid installed

https://f-droid.org/en/packages/ch.deletescape.lawnchair.plah/

I really have no idea if the comparison between a window manager on a linux distro and a launcher on android is accurate technically even though it feels a bit that way

  • Regarding Magic Earth, if i understood correctly that’s the only closed source app in /e/, and there was discussion between them and e.foundation on that matter. No idea where it’s at though.

I’ve been using OsmAnd for almost 10 years, that’s by far my favorite app for hiking, cycling, driving and i dont reallt get the complaints about OsmAnd being everly complicated, maybe because i’m used to it, i dont know.

Anyway, a good thing is even though some choices had to be made on /e/ default apps, we dont have to have the same preference and it can be customised fairly easily

If i remove apps from system/app or priv-app in TWRP, they are re installed after the next /e/ update.
Someone mentioned a way to uninstall app for the user, so they stay that way after /e/ updates also :
(Need adb enabled in developper settings)

vince@desktop:~$ adb devices
daemon not running; starting now at tcp:5037
daemon started successfully
List of devices attached
dae53173 device

to uninstall bliss launcher for example :

vince@desktop:~$ adb shell pm uninstall --user 0 foundation.e.blisslauncher
Success

1 Like

Thanks for the suggestions about launchers, I’ll try them out!

About Magic Earth, I really don’t understand why OsmAnd is not a good option. It should be configured to be more user friendly as a fork on /e/, not more.

About customization of system…

There’s a huge problem: it’s not easy, or not at least on the usual way, to uninstall preinstalled apps.
Having to use Terminal/commands to uninstall an app is not real for-user.

Thanks for the answer @blaes, I appreciate much them!


By the way, it’s interesting to know how to remove apps via Terminal, thanks :slight_smile: :blush:

I guess the main reason is that OsmAnd~ needs off-line data. Low spec devices (e.g. little memory) would be unable to support this software properly. This in turn means a lot of work for the devs to manage all devices. I prefere OsmAnd~ too. But I must admit that the Magic Earth app is pretty good too. I guess there will be tutorials in future titled like ‘‘10 things to do after a fresh install of /e/.’’

1 Like

You’re right, I didn’t think about the storage memory!

Hello.

France-OSM for Navit ‘weights’ 4.6 Go, for example. Needs a good (fast) SD-card…

Someone tested xda-Trebuchet mentioned above ? Thanks.

And you can’t do a long-distance trip with OsmAnd because it can’t calculate it. And you don’t have traffic informations.

1 Like

Well, I did a 700 kms trip two weeks ago, with OsmAnd~ and by car, and it worked without problem. In fact, it calculated the time perfectly (1-2 minutes up-down)

Then maybe it has changed (almost a year since I haven’t used it) or it depends on the device (I don’t have a very powerful one).

1 Like