Newpipe and guru meditation

Since yesterday evening (or did it start previously and didnt know? it’s been a while since my previous launch) I cant open a vid in newpipe.

As soon as I tap a video in the list I get a Guru Meditation error “YoutubeStreamExtractorDecryptException: could not parse decrypt function”

I tried clearing app storage and cache to no effect.

As advised here (NewPipe app trouble) I uninstalled and reinstalled newpipe, It changed my version from 0.17.4 to 0.18.0. But no effect either.

Edit: the problem arises with a friend’s phone with Android too. It seems to be a newpipe only issue. In France for what matters. Do you guys experience the same or is it local?

I’m experiencing the same in Germany. This is a more or less frequent problem with new pipe and similar apps, and I have witnessed it several times in the past. Apparently, whenever YouTube makes a relevant change on their side, the apps stop working and have to be fixed.


I had to update youtube-dl on my desktop (Debian), yesterday. Seems Youtube made an update…

This is a regular expression bug which is fixed in Newpipe 0.18.2. Unfortunately, only 0.18.1 is available in F-Droid at this time. You’ll need to download the package from github if you want an immediate fix.

Thanks RSI9x.

Do you have an idea on how long before the update is pushed to fdroid?

BTW, f-droid and Apps both distribute the 0.18.0 version of newpipe.

@Pasca1 The /e/ Apps version is 0.18.0, but F-Droid’s version is 0.18.1. I’m not sure when F-Droid will get updated with 0.18.2, but hopefully it will happen in the next few days.

@rsi9x Thanks for your reply. This is really weird, but f-droid is still showing me version 0.18.0 (added 28/12/2019)

You may need to refresh the repository information. Mine updated to 0.18.1 on Jan 23rd.

yes, the new and workig version is available in f-droid.

And pls, when it is working again on your device, pls add to your first post headline [SOLVED], thx



How do I refresh my repository? In my f-droid repo, it is stated that it updated jan 21. Even though I configured f-droid to check for updates every 24hrs.

I just saw that in my fdroid settings, I had “include apps with potentially unwanted functionalities” (or st like that. I translated the sentence from French) was set to False. So maybe it doesnt check for newpipe updates?

In the expert part of fdroid parameters, nothing is checked. Is this OK?

Not working so far, and I dont get why. Will do once it’s OK.

in main f-droid screen swipe from top to bottom


in main f-droid screen swipe from top to bottom

Thank you. This works.

It allowed me to upgrade from Newpipe 0.18.0 but it only brings it 0.18.1which also fails.
Will update when f-droid has a functionnal 0.18.2

1 Like

Crazy, f-droid 0.18.2 is shown

F-Droid’s is still 0.18.1. You sure you didn’t update from github? If you update from another source, then look in F-Droid, it will show whatever version is currently installed, even if it’s newer than the version available in F-Droid.

And I’m not the only one which is seeing 0.18.2 f-droid,
but you are also not the only one which isn’t seeing it in f-droid. Seem to be different which repro is used and from which country yiu are

So what active repos do you have?

i have “F-Droid” and I just activated “Guardian Project Official Releases”, but still 0.18.1 here

Could it be a question of language pack? French UI here.

German language and GUI