Nexus 5X bullhead: vendor image mismatch

Receiving the following message post sideload:

Android System
A vendor image mismatch has been detected. Typically this means your vendor image is out of date. Please ensure your vendor image matches OPM7.181205.001.

This happens on builds
and which are the only two I’ve tried. MD5 checksums check fine.

I have successfully installed adb, fastboot, enabled USB debugging, TWRP etc. The last thing before this message is the “e” logo with bouncing ball underneath during boot.

If anyone has a workaround or fix that would be great. Going to try some fixes based on google results but not sure how successful those are since those are outside of the “e” ecosystem.

Much appreciated.

Did you update to vendor-bullhead-opm7.181205.001.img?

You can get them here:

I am also using Nexus 5x and had no problems so far.

Just attempted a flash of the lineageos rom that you linked to and got the same error message.

I’m guessing that since my phone had Nougat installed originally (7.1…) and the bullhead images are Orea based (going by the naming convention of the image filename prefix) that I need to figure out how or where on my 5X that information is kept and to somehow overwrite it?

OK looks like I was able to resolve it. Had to wrap my brain around what was going on. I used the following gist as a guide:

Not knowing a whole lot about this stuff it seems like there is a location on the device for storing the last known factory image (“vendor.img”) and that if it doesn’t align with the image used to build the boot image then the system will fail to boot. I’m sure there are many gaps or problems with the above statement.

At any rate the gist above covers most everything. The high level is that one will need to download the very last factory image from Google (Dec 2018 for Oreo) and unzip the image to retrieve and copy to the device (/sdcard) the “vendor.img” file. Once that is complete you then need to use TWRP to copy (or rather “install”) it from /sdcard (I’m assuming that is an internal sd card since there is no removable sd card on 5X). This is done in TWRP by Install -> Internal storage -> select vendor.img -> swipe to install.

Then reboot. Problem should go away.