No downloads possible - phone behaves strangely


as I mentioned in this post my FP3 runs into refusal of connection while trying to download an app.
This continues to happen and seems to be connected to the recent installing of NetGuard (which I meanwhile uninstalled).

It also occured that my given settings are ignored, e.g. the sound is activated for screen deactivation or battery charging, instead there is no sound.

I am very insecure about this and would like to get it right from the start.
In fact here I am lost.

Any hints?

So, meanwhile I have the sounds back but there are still issues: Neither or as DNS do work, rebooting doesn’t change anything.
This seems to result in a failure of downloads at F-Droid (as referenced in the above post), though other things work (telephone, Threema etc.), but Brave would not connect to any website and answers


What can I do?

Same issue here, with a Samsung S8. Not always, but often since the last update of OS. Brave, and the app using internet, finally connects after some refresh.

Additional info: Being in my very own WLAN, the phone connects to it (instead of LTE, just like I told it to), but keeps saying that there were “no Internet”.

In fact there is a download of 90,4 and an upload of 38,2 Mbit/s available, but the phone is marked as “not connected” in the router.
The other available router ( offers Internet too, and the phone doesn’t get it.

Strangely the connection via Warpinator (backing up contacts) worked though just a minute ago.

I describe a similar behavior in the official case I made two months ago. Feel free to add informations there.

Interesting is that you also say some apps work over network connection and others do not, at the same time. That’s what I also remember.

1 Like

I’d like to as there is so far no assignee to the issue - it is only impossible for me to register and log in, as GitLab doesn’t like my mail-adress out of strange reasons:

1 error prohibited this user from being saved:

  • Email is not allowed for sign-up. Check with your administrator.

Just dunno what my admin got to do with it. It’s myself anyway.^^

Now I keep wondering how I might get the prospected upgrade of the OS while there is no Internet available for the device.
Can one upgrade via ADB?

Right now I am again in my WLAN, have a IPv4-adress for the FP3.

The router says it has a signal strength of -70dBm and an actual data rate of 390 / 6 Mbit/s.

The device says that it is connected to my WLAN and has no Internet.

It connects via Warpinator though, and this is how I transported this screenshot:

While setting WLAN as connection, it gave me a popup to tell that there were no Internet available…


After a reboot I always had Internet. And it did always really work then.

Just rebooted - no Internet.
Flight mode on/off - no Internet.

Router says it is on IPv4, has -50dBm signal strength and 53 / 2 Mbit/s.


So am I.
To no avail.

May there be #somebody to take care of this?

I am sorry but did you read the link? It contained the solution! :slight_smile:


And if you don’t want to scroll down one page from that post, the solution is…

1 Like

Oh, sorry.
I didn’t realize it was a link, took it for a citation and commented.

Sometimes I’m lazy, right.
My screen and settings require no scrolling anyway, but I had to call the link in the first place…

Thank you.

1 Like

As there are still no downloads possible and no Internet connection (though some things work) for days I’d like to check whether there might be a settings problem or a system mistake.

Is there any structured checklist available for Android 10 to check step-by-step?

Now, we had a system update and my FP3 is on /e/OS 0.21-20220122158537.

I still have no Internet and BTW I wonder how the download of the system update was done as F-Droid or browser always keep telling me they had no DNS.
Anyone able to explain?

So far I have only one provider ( and the settings seem to fit - mobile data on, VoLTE on, only there is but one single APN (Telekom MMS (internet.telekom)).

Even when I’m in my very own WLAN I do not have access to the Internet, the router says it is active on IPv4 and prioritized (signal strength: -66dBm, max. data rate: 433 / 433 Mbit/s, actual data rate: 433 / 6 Mbit/s, WLAN-Standard: WLAN-ac / Wi-Fi 5, frequency band: 5 GHz, channel width: 80 MHz…), it only doesn’t seem to know as F-Droid shows no “News”, no categories, and no search results.
The browser can’t put up a website, the diagnosis is still the s(h)ame:

Please, any hints to find the problem.

If you directly request a well known IP-Address you don’t have a domain in it, so you probably don’t need a DNS for resolving. My guess.

What is in your DNS settings in the OS?

BTW: The DNS settings are also to be used in the same way when the network is mobile and not wifi. When they work on a mobile network they must also work on a wifi.

I use “Network DNS”, and private DNS is “on” and “automatically”.
Worked before.
A change to doesn’t solve it.

And it keeps not working either in LTE as well as in WIFI.

I switched off “Use network DNS”.

In the DNS option below I wrote which was mentioned somewhere here in the forum in another thread as a good DNS.

Before I got app-updates with “Apps”, download and installation worked for all three.

F-Droid is still deaf and dumb, as well as the browser.

Magic Earth actually (and astoundingly) seems to work.
At least it dated up the maps and I could possibly try it out.

Your suggestion is a DNS by vodafone (D2).
Would be kinda strange to use it with D1.
But I do not leave anything untried.

So, I returned to
At least I have a road assistant this way.

Is there really no suggestion to check for DNS methodically?