No mobile data connection on S7 edge

I have installed /e/ on a Samsung S7 edge via easy installer two days ago.
The phone doesn’t connect to internet by mobile data just by wifi.
I have tryed to work around by turning advanced privacy off and that has worked one or two times for the preinstalled browser, but App lounge, messengers, etc. don’t connect, App Lounge starts and starts again in a loop.
After being out of wifi for a while any app won’t get connection.
As far as I see there are no further permissions I can giveor take to make connection.

Has anybody ideas or advices what to try?
Many thanks in advance

Additionally I am puszzled that apps claim to be installed on a S 10 - no idea if that’s an issue.

1 Like

We might face the same or a similar issue, even though yours is an edge and mine is not …not sure…
Does everything work with wifi?
Does no app at all get access to the internet via mobile data?

sorry, haven’t solved it.
Everything worked in wifi. As soon as it switches to mobile data it looses conection and half chance that it gets connected again back in wifi.
Still no idea why…

I am on the same version as you (1.0-20220526188859), on a Galaxy S9.
My phone stops connecting to mobile data after a few hours of connecting to wifi. I have noticed that restarting the phone a couple of times with no wifi causes it to connect to the mobile network. This is obviously not ideal, and I would still love to find a proper fix

So I SEEM to have it working at the moment, but I will comment if anything changes.
Settings > Network & Internet > Mobile network > Advanced > Access Point Names (APNs) , Then select the one you have selected and in the third row (labelled “Proxy”), delete the proxy, and then click on the three dot menu to save the setting.

There also appears to be a more detailed explanation at MMS issue with Fairphone 3 and Orange operator - #26 by p.rcto

1 Like

I noticed someone else note that, yes I do think that is worthy of Report an issue

Checking APN settings seems to be a very good hint !

Finally found a solution that worked for me. After changing a lot of APN settings I found the trick. IPv4. In my APN setting I had IPv4/IPv6 - changing it to force IPv4 worked!

1 Like

@kim.fisker thank you for that info, I´ll add this datapoint to the gitlab issue.