No Sync between selfhosted ecloud instance and phone Poco F3

Hi ! After a clean install of latest debian 12 (on a VM qemu-kvm) and ecloud selfhosted install after documentation reading without install problem : I’ve no sync. No iptables, good NAT with my router. NC no warnings (all security messages have disappears, it’s green). Cannot log into my user (even if he’s in admin group) but it works with nc_admin account.
Also I suspect a mistake with caldav and carddav discovery… My phone Poco F3 run /e/os 1.15-s-20230916331435-dev-alioth.
Any ideas ?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

@BadPuf Did you run the command:

cd /mnt/repo-base && docker-compose exec -u www-data nextcloud php occ config:system:set main_domain

→ should reply “System config value main_domain set to empty string”

There is a bug that has been submitted by @smu44 that doesn’t allow the /e/ OS login. The above command fixed the problem for me. I could log in using the browser but not through the nextcloud app or my /e/ OS phone. I never tried logging in with the nc_admin account with nextcloud app or /e/ OS and I installed on an Ubuntu VPS, so I am not sure it is the same problem.
If that doesn’t work or if it is a different problem, let us know. (And let us know if it worked too. We like to hear when people are successful.)

1 Like


nc_admin is a special account: instead of being stored in MariaDB database, it is a local Nextcloud account (mandatory for the default admin account).
→ it has no email address or mailbox

@erothoff thank you very much ! After your command it works I can log into my user account on the phone with murena account. I’m going to wait for the synchro of my photo. In your opinion, how long for a sync between my phone and the selfhosted app ?

Always no photos on VM side. I think there is no synchro.

Sorry the sync is on but no auto sync… I must select photo and docs even for the first connection with the nc android client. Thanx to erothoff and smu44. Bye !

I have not tried syncing the photos with the self hosted account, but on the server it would sometimes take a while. I will try it tomorrow to see if it is a problem specific to the self hosted server.

As long as the WebDAV access is OK (using for example a browser or Nextcloud client) from the same IP address you want to synchronize from(*), this is probably an Android /e/ Drive app problem(**).
*: if many logon attempts were unsuccessful, this IP address may be flagged as “suspicious” by Nextcloud. Please read here: Legitimation issues - #24 by smu44
**: you could try:

  • from Settings/Apps (show system), force stop /e/ Drive then clear cache + data
  • connect the device to a charger and WiFi network
  • reboot to system, unlock device, let it settle for about 1/2 hour

@ erothoff : ok
@ smu44 : it’s possible I have had the same IP effectively because I had tick the android option “sync by wifi” and VM and smartphone were on the same network. Now I’ve unticked. But

docker-compose exec mariadb mysql --user=root
–password=“$MYSQL_ROOT_PASSWORD” $MYSQL_DATABASE_NC -e “delete from

returns no output, so my device is probably not blacklisted.
For the Drive app I’ve executed your recommends (stop the app, clear data and cache then reboot).
I’m waiting and I’ll see if the first auto sync starts.
Thank you very much.

While testing and debugging maybe whitelist your IP under:


Brute-force IP whitelist

To whitelist IP ranges from the brute-force protection specify them below. Note that any whitelisted IP can perform authentication attempts without any throttling. For security reasons, it is recommended to whitelist as few hosts as possible or ideally even none at all.

@make-nz Hi !
No doubt, it’s certainly a good idea effectively but I don’t find your path ?



Are you logged in as Admin?

Sorry I thought it was a CLI bash path… I’m logged in admin with nc_admin.
I’m no Bruteforce settings in this path… It pass from “passwords politic” to “Clients OAuth 2.0”
No “Bruteforce rubric”… It’s curious no ?

No, all good, I just assumed it would be installed…
You’ll find the NC-APP:

Brute-force settings

as Admin, which will give you the feature.

It’s crutial, when you have CalDav/WebDav coming from devices, with wrong settings, Passwords, or your SSL-Cert does not meet iOS standards…
It can be a life saver, but also a certain risk.

App installed and whitelisting of my IP done. Now I wait. Thank you very much.

It might be more that just the self hosted server. I have a Motorola Lake (Running 1.15-s-…-dev-lake) that doesn’t work for either my self host or for the servers. My Pixel 5 is running 1.15-s-…-stable-redfin WORKED with the servers, but when I tried the self hosted server, it didn’t work. And when I switched back to the servers it still didn’t work… While I reset my Motorola, (It is a backup phone) my Pixel 5 is my primary phone. (so I have some backing up to do before trying to reset it.) I’ll see if a FR will fix my Pixel connection to both servers.

@BadPuf A SQL delete won’t output anything, unless an error message :wink:

Interesting! So your selfhosted is at home? We are not aware of your home network set-up, many unpredictable things can happen here…

Any error message in https://{domain.tld}/settings/admin/logging (logged in as ncadmin)?
Is it working OK from a desktop computer, on same network?

@erothoff strange behavior here…

@ all: you can always test your connectivity with some third-party clients, like for example SimpleEmail for email and MiXplorer for WebDAV (add a bookmark, choose WebDAV). And Nextcloud client, of course :wink:

@smu44 Yes strange, but the contracts and emails come in without a problem. It is only pictures. And I can go in and tell it to sync manually, and the pictures STILL do not upload. I thought it was fixed, as my Pixel 5 was syncing fine, but now that has stopped while trying to check the self hosted server. If I have time, I will FR my Pixel 5 and try again.

1 Like

@smu44 I’m sorry you are right (for the sql command, my sql training goes back a long way).
For me, it works for sync between a VM debian 12 (on proxmox on the www) with desktop nextcloud client and my home selfhosted instance.
Error in log when I do a connect a new account :

session_start(): Ignoring session_start() because a session is already active at /var/www/html/nextcloud/lib/private/Session/Internal.php#219

I’ve commented like :

then no error with new user log into but also no sync with integrated account add app on my smartphone…
But it works (in both direction) with nextcloud client on phone.

Before firmware reset, have you already tried the /e/Drive reset No Sync between selfhosted ecloud instance and phone Poco F3 - #8 by smu44 ?