Not working: moving data via USB-C and otg-cable to external storage ( e.g. Garmin Edge explore)

Hi at all, good morning…
I’m trying to send (.gpx-) data in the following way to external storage:

FP4 with /e/os, 1.12.3

usb-c-adapter and otg-cable or micro-usb to usb-female or…
(i tried different settings)

Garmin Edge explore or a boring usb-data-stick

Unfortunately there is neither any ext. storage detected nor a charging-signal (Garmin)
coming up.

A second nearly identic FP4 was also testet negative similar to a Samsung S5 neo with naked Lineage OS 12 nightly.
Interestingly a FP2 with /e/OS 1.11.3 is working.
(no, i will not switch my FP4 to my daugthers FP2…).

Does anyone knows about this FP4-behavior?
Is there a workaround existing?
Are there some switches to get this otg-service in the deep of the settings?

Thank you for ideas and answers,


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Users experience of OTG seems to differ as suggested by a forum search for OTG. In your case I would first suspect the “chain” of cables you are using. Loosely speaking I think it is roughly correct that OTG, standard USB A connections, and USB C have a different “attitude” to asymmetric connection.

I once bought a USB OTG Adapter and it failed to do the job I wanted.( I often don’t throw things away,) so when I came to try to answer this thread My phone does not recognize usb stick the adapter did work as expected.

I find a storage device sold as OTG-enabled with both a standard USB A connection and a connection to fit my mobile (in your case USB-C) to “work every time”.

This FP3 thread may be useful

At first reading I did not think this could be your issue – as I know of no deep settings.

Just in case …

Use the search facility in Settings to search for USB.

Check that a suitable setting is enabled. Note settings can only be changed when a “live” USB cable is connected.

There is a further Default USB configuration. This is in Settings > System> Developer options. If Developer options are not enabled this is probably set to a sensible default.

If access to Developer options is required …

Settings > About Phone > Build Number or Version > Tap seven times

You will get a message that you are a Developer.

1 Like

Hi aibd,
the usb-settings an dev.options failed, i think i try some new unadaptered cables next.

I will inform here then…


This topic was automatically closed after 180 days. New replies are no longer allowed.