OEM unlocking option on Google Pixel 4 XL

Using the Easy Installer on both the Windows and Linux Ubuntu platforms I’ve not been able to turn on the OEM Unlocking on the phone. It is grayed out. I’ve also tried via the command line but to no avail.

What might I be missing?


Regain your privacy! Adopt /e/OS the deGoogled mobile OS and online servicesphone

Did you enable developer mode? If not tap on “About Phone” then tap on “Build number” seven times.

Yes, I did enable Developer mode.

What android is the 4 XL at?

The device is at Android version 13.

2 weeks ago I unlocked a Pixel 4a, it was done in couple of seconds.

Are you sure you are setup corrrectly and doing everything the correct way?

Activate developer options and adb (then accept the connection from the computer), reboot to the bootloader, use this command [fastboot flashing unlock]. It is fairly easy compared to other manufacturers.

1 Like

I ran through the Easy Installer procedure again. Still getting the grayed out OEM Unlock.

Did you use Easy Installer or command line method or maybe a combination?


mihi, was your Pixel 4a at Android 13?

I think the easy installer is not at android 13 but 12 or even 11. If that is the case he needs to use command line or use the google roll back to tho the android version that matches easy installer.

I will be out for a bit but will check back. Search Pixel 4a5g I ran into this issue with that phone.

Ok, so if I understand correctly, since the device is at Android 13, I need to use the command line method. I checked the Google rollback process and it seems I should speed the time using the command line method rather than rollback. What is your recommendation: Install version 12 (Stable) or the Community version (ver 13)?


Yeah @Jets is right. There is also that hurdle.

But first what version of Pixel 4 XL do you have? Verzion maybe?

I just purchased it off of Amazon this week, refurbished and unlocked. It will be T-Mobile.

Hmm, still please check the version in the system. I know Verzion locks their phones, according to someone on the forum if you have a provider locked phone you can unlock it via some app from the provider. The Verzion person was not able to install it…

What specific version are you looking for? Where do I find it in settings?

Sorry I can’t find it on my e/OS/, maybe with vanilla android it is somewhere in the ‘about phone’.

Else check the packaging, should be something like:
G020P, G020, GA01181-US, GA01182-US, GA01180-US

Look in: About phone > Android version also have a look at the build number.

Looks like this is a Verizon locked phone. Returning to Amazon.

Thanks so much for all the help.

Will try again for a truly unlocked 4 XL with Amazon unless other suggestions.

Thanks again.

1 Like

If you are living in the US you should get a phone with 5G like the Pixel 4a5g or above.

To me the 4a5g is the best value of Pixel’s, 4a5g and above. Has built in fingerprint reader (not on screen like the 6 and 7) plus the CPU(s) doesn’t really get much faster in newer generations. Also the screen is 6.2" so nice size.

But for sure get a 5g phone for much faster data services. I have a few here.

And when you bought it please reply here again maybe with @ so we get message then we can explaintmaybe the offical/stable and community/dev difference. As mentioned before it is related to installation in regards to the installed version

Thanks for the phone suggestion. Just purchased the 4a5g. Should be here tomorrow.

mihi, I’m not familiar with replying with an @. How is that done?

when you write @ and the name, you should get suggestions. like @jazz