OnePlus 5T 'dumpling' /e/OS 'Q' AOSP Android 10

As announced, /e/ OS upgrade to Android ‘Q’ for OnePlus 5T ‘dumpling’ has takes place.

The new /e/OS e-0.14-q-2021020199535-dev-dumpling is accompanied by the eRecovery Build recovery-e-0.14-q-2021020199535-dev-dumpling.

The /e/ documentation Install /e/ on a OnePlus 5T - “dumpling” still links to firmware version 9.0.9 from 2019-10-29 under Downloads for the dumpling [Latest firmware zip file]. However, I prefer to install firmware version 10.0.1 from 2020. The official build 10.0.1 comes from OnePlus itself.

The only thing I have noticed so far is that the 5T switches on when it is switched off and a charger is connected. When it is switched off again, the green LED in the top left corner goes out, the screen goes dark and the system shuts down. A few seconds later, the device boots into the /e/ OS without any intervention. I tried two different compatible Qualcomm 18 W and 25W Quick Charge 3.0 chargers, but not the original OnePlus DASH fast charger.

The mentioned starting of the switched-off OnePlus 5T after connecting a charger depends on the OS used. The error only occurs with custom ROMs, but not with stock Android Oxygen 10.0.1.

To isolate the issue, I installed and tried the following in order: /e/ OS “Q” - LineageOS 17.1 - LinenageOS 17.1 for mircoG - Stock Android Oxygen 10.0.1.

With Oxygen 10.0.1, the OnePlus 5T remains switched off after connecting a charging device, whereas all three CustomROMs based on LOS code switch on. Accordingly, it is an LOS bug on this OnePlus 5T.

Thanks for the heads-up @SuzieQ. I was thinking of upgrading my 5T but after your experience, I’ll wait until this gets fixed - hopefully in the not too distant future :wink:

Yes @Grende, I understand you. On the other hand, the experience of other users would be helpful. Maybe it’s just an isolated case and the bug only occurs on my device.

I agree with you @SuzieQ but as I’m wrestling with an /e/ installation on an A/B OnePlus 6 which is a whole different ballgame as they say. Once I feel confident with having a safe backup device with this phone I might give the upgrade of the 5T a try - should be a lot simpler I hope.

Hello @SuzieQ, Just thought I’d let you know that I managed to upgrade my OP5T to the Q version after following your tip to sideload the latest 10.0.1 firmware, in fact it was the complete stock version so I had to wipe data, etc as described in the official /e/ documentation. Then after a further sideload of the e-0.16 zip file it restarted correctly. I had a few problems with wifi disconnections for a few moments but after a restart everything seems to be back to normal and I could reconnect to my ecloud account. I was also pleased that it kept my original twrp recovery, so I was able to flash magisk and root my phone.
Thanks again for the tips.

Hello @Grendel, I read your postings. You are busy working and testing - and sharing your experiences, the good and the not so good. I like that.

The OP5T is a top notch phone. I like it not only because of its speed, but also because it is ‘relockable’ and starts with ‘Verified Boot’. It’s currently running a hardened LineageOS 18.1 fork (Android 11) on mine. It is similarly spartan as GrapheneOS.

Hi, I’d like to install /e/ on my OnePlus 5T. I’m just wondering does this /e/ firmware need to be installed if it’s already running the latest stock 10.0.1 firmware? The Lineage OS documentation doesn’t seem to mention it. Is it modified for /e/ somehow?


To answer my own question… No, that /e/ firmware file doesn’t seem to be needed. I tried installing /e/
on the latest stock firmware and it installed without any issues.