OnePlus 5T install with TWRP 3.5?


I’m following the install guide for the 5T. I put TWRP-3.5.0_9-0 onto the phone. However, I can’t get it to boot into the familiar UI for TWRP, with the icons of different actions. When I reboot into recovery mode using the vol down + pwr button, it gives me a language selection page, then four more options…

  • Install from internal storage
  • Install from ADB
  • Wipe data and cache
  • Advanced
  • exit

Is this a new look for the TWRP screen, or is it ok to use the “install from ADB” to try side loading the .zip file? Or am I going down the wrong path?

The install instructions of the 5T page skip right to “on the device in TWRP” without any instructions on how to get into TWRP. I’m new to android and terminal work, but this is my third phone I’m putting /e/ onto. Perhaps the instructions haven’t been updated since putting out TWRP 3.5?

Thanks for any suggestions, just don’t want a brick!

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hi @Franko,
the /e/documentation Install /e/ on a OnePlus 5T - “dumpling” refers to TWRP Recovery in the old fashioned way (Paste & Copy), although there is now the matching eRecovery to the /e/ OS ROM.

The OnePlus 5T is a so-called A/B device. In TWRP, you’ve to switch to install the /e/ OS ROM. This isn’t mentioned in the /e/documentation.

However, if you install eRecovery from the beginning, you will not be confronted with this. So enter as follows: fastboot flash recovery recovery-e-0.14-q-2021020199535-dev-dumpling.img

Immediately afterwards reboot into recovery and now tap Factory Reset, then Format data / factory reset and continue with the formatting process. This will remove encryption and delete all files stored in the internal storage, as well as format your cache partition and system partition;

Return to the Main menu.
On the device, select "Apply Update", then “Apply from ADB” to begin sideload.
On the host machine, sideload the package using:
adb sideload

Once you have installed everything successfully, click the back arrow in the top left of the screen, then “Reboot system now”. As you can see, flashing on a OnePlus 5T is as simpl/e/ as that.

I don’t have an OP5T but it’s not A/B slot device is it? ? No recovery partition on A/B devices , so fastboot flash recovery would not work. I hear OP5 comes with twrp installed…so

Well, I’ve and see my ‘OP5T’ and installing /e/OS ‘Q’ works with TWRP as well as eRecovery.

Two advantages of eRecovery I can see for ‘normal’ users:
1] straightforward /e/ OS from installation point of /e/ documentation ‘Installing /e/ from recovery’.

2] OTA update processing in the background (without TWRP messages becoming visible as with TWRP) as well as Update recovery - Update the built-in eRecovery with system updates.

Yes, that’s good, but I question the A/B slots; the two sets of partitions (except data, which is shared).

Hi Franko,
sorry if the issue is closed in the meantime, but maybe you could try the following : 1. wipe data and cache with TWRP, then 2. put .zip on the /sdcard/ of your phone using adb push or transfer the .zip from PC to phone SD card via USB cable, 3. within TWRP Install from internal storage ?
That’s what I did for my LG G3 (different phone than you but worth a try)


Unfortunately the eRecovery method didn’t work for me.

It fastboot flashed with the recovery .img fine. But the next step of “immediately after reboot into recovery” didn’t seem to work. I don’t get the “factory reset” screen.

What I do:

  • adb reboot bootloader
  • fastboot devices (phone is verified as attached)
  • fastboot flash recovery recoveryxxx.img
  • Sending, writing, finishes in less than a second.
  • Phone screen is back to the screen with “start” at the top, in “fastboot mode”, stating the device is unlocked.
  • I use the vol buttons to select “recovery mode”, then press the power button to select.
  • Phone gives the bootloader unlocked warning, I let it proceed.
  • Phone screen goes black, with just the blue LED on solid.

I believe I tired rebooting into recovery by using “adb reboot recovery” as well with the same result.

Did I miss something, or is the phone messed up from having tried a dozen different things over the course of several days?

My hook is that I can’t get into the typical TWRP screen that I have seen on the other two installs I did. I get a different path where I have to choose language first, then I can wipe and do a few things. I got into ADB side load from there, and everything looked OK on the Mac, but I got a fail message on the phone.

The Check Apps also ask themselves this question …

Sideload also failed during my attempt, so I did adb push /sdcard/ (but you can also copy the /e/ OS .zip to the phone SD card with a card reader or via USB cable)
After chosing the language in TWRP, do you see a Install button like in this screenshot? From TWRP/Install you should be able to Install from this .zip file, bypassing the adb sideload step entirely.

So, since the phone doesn’t respond to a manual recovery reboot (vol down + pwr), I just hold the power to do a regular boot- starts up with the same original OS. After that, I shut it down, then I can do vol down + pwr, to recovery boot. Instead of the expected TWRP screens, these are the ones that come up. Pics are of some sub menus as well.

Ugh, one pic per post allowed. And I’m using my OP One, so please be gentle with my bastardized posting.

I use the options on the phone shown above, to sideload the zip file. On the Mac, you can see the % loaded move along nicely, then I get the following screens:

Hi @Franko I think a few things have conspired to get into this tangle and you need to start from scratch. The recovery you show pictures of I think is an official oneplus recovery and obviously you need a custom recovery on the phone for flashing e. I had a 3T that had a similar screen.

The screen with Start at the top where you can select options with rockers is the fastboot mode screen.

I also think you may have been unfortunate in not seeing full e install instructions and also the twrp version you chose may not work for your device.

As for the installation instructions, you may need to make some decisions for yourself about what to follow because sometimes the /e/ version of instructions can be misleading. I can’t make a judgment there, but the lineage os instructions are always worth looking at to make a comparison and arrive at a decision.

Preparing the phone is key for successful outcome. You have fastboot and adb working so you should be ok.

What android os version is the phone on when you started this? Do you need to update it to the latest Q firmware or is it already on the phone?

Whatever you have, first thing is to get a custom recovery flashed and booted. Try flashing the older version of twrp with the command:

fastboot flash recovery twrp-3.4.0-0-cheeseburger_dumpling.img

Then power off the phone (unplug it as well if you like, just to be sure). Wait a little while before pressing vol down/pwr. Does twrp boot?

@chrisrg, different opinions between us users are the order of the day - both of our opinions in particular. I respect that, of course. Nevertheless, I urge you not to contact me about ‘a/b device’ or ‘slot a’ and ‘slot b’ via Personal Message (PM).I can’t pick and choose who reads and criticises my postings. But I’ve the choice to respond or not.

No criticism intended. I was merely concerned that you were offering the OP erroneous information concerning the device partition layout.

I still can’t get TWRP installed.

The phone is a new old stock, so it still has Android 8.0 on it. I tried to update to the latest firmware using the built in OnePlus recovery method, but it failed. The terminal on the Mac said the transfer was complete, but the phone brings up the failure message.

I then tried to install the older TWRP 3.4 via the terminal and adb sideload. It failed as shown in the screenshot below. Something about it trying pre-Kitkat as well.

Final thing I tried (the last attempt shown in the screenshot) was to install the older TWRP 3.4 via the built-in OnePlus recovery function, activating the adb sideload function on the phone. That gave me an immediate transfer of 0.00, so no go there either.

I have rebooted the phone in recovery mode and it still goes to the built-in OnePlus recovery screen.

Not sure why I am struggling so much just to get TWRP installed. Maybe there is a setting on the phone blocking the install?