OnePlus 5T install with TWRP 3.5?

It maybe a bit old documentation,
but talk about fastboot flash TWRP not sideload TWRP
and then sideload /e/OS

You have unlocked the bootloader, yes? Sorry for asking :grimacing:

SuzyQ’s method should have worked, it’s basically by the book instructions. You should be using fastboot to flash twrp or other recovery onto the phone, then power off and do manual reboot of recovery: vol down/pwr.

Isn’t there anyone else with this device to help you troubleshoot?

I’ll try some of these tips later tonight. It seems like there is an issue with the OnePlus Recovery overwriting the TWRP each time. It’s like I can’t force it to boot to TWRP. I have tried numerous key sequences and disconnecting USB at different times, with no success of course. It is frustrating as its literally half a dozen steps. I’ve even watched videos of people doing it, but when it comes to the reboot their phones open up TWRP and mine opens up the goofy OnePlus thing. I’ve tried a few obscure versions of TWRP as well.

I’m also wondering if this paragraph from twrp instructions might be involved?

This device uses dm-verity!
This means that swiping to allow system modifications will prevent you from being able to boot if you are using the stock kernel. In order to bypass dm-verity’s boot prevention, you will have to install a kernel that has dm-verity disabled in the fstab.

Oneplus forum may help. Expect you’ve been there already though.

It would be sweet for someone to start a side business of installing /e/. Totally worth at least a couple hundred bucks for me. Or even to be able to buy a new or used phone with it installed. Too bad /e/ only ships to very few euro countries.

Good point. I looked into dealing with the dm-verity issue, the solution starts out with using TWRP… That’s just hilarious.

Just for fun, I went to the OnePlus site to “upgrade” the software, just trying to start from basics. I used Android File Transfer to move the .zip onto the phone. Then I went to System Updates -> Local Upgrade. The phone went through what seems like a normal process of a minute or two updating, along with a status bar. Phone then goes blank and reboots to the unlocked bootloader warning page, as expected. Booting continues along with a status of updating the system. Then I get a “Installation failed” message, with the only option being to Reboot.

Could this be a bum phone? I can’t see why it won’t handle a legit update.

I don’t know, but I do wonder what happens to all this stuff that’s being loaded onto the phone! Does it clog it up at all? I can’t answer that, but the fact that you have a bootable OS on it with a working recovery is cause for hope that this may get solved eventually

How does the oneplus update versioning work I wonder. Might it help to discover the sequence of updates and try with the oldest one first?

In fastboot mode:

To see device info and may give dm-verity info(as per this 1+ forum thread):

fastboot oem device-info

Also try booting the twrp img directly on the phone (without flashing)

fastboot boot twrpwhatever.img

If twrp boots have a look around

And have you seen this?

I do it as a « non business activity » in France, but noone is interesting by this service

I have to be at a solid 20 hours trying to get /e/ installed. This has been super complicated with each seemingly simple step consisting of rabbit hole after rabbit hole. The installation is more like a web than a list. Android is tough, guess I’ve been spoiled by Apple for too long. I thought a brief search would tell me how to just start all over and completely wipe the phone and start with “new”, but even that seems complicated. Probably going to have to give up for awhile, I don’t have the time to “play”, I just wanted a phone with some attempt at privacy. Thanks everyone for their help so far, I know how hard it is dealing with issues without having the equipment in your hands.

Hope you haven’t given up in despair by the time I write this @Franko. Here are a few ideas of mine.

Having installed /e/ on two different 5T devices, my advice would be to update to the new version 10 of the stock ROM - download from here.

You can then download a version of TWRP by mauronofrio who seems to have the best reputation for for adapting the TWRP recovery to Oneplus devices. I would start with the older 3.3.1 version which worked best for me, but perhaps after updating to version 10 of Oxygen OS the later version may work.
This page on xda-developers will have more information on which version to use:

I had no difficulty in using ADB with fastboot to flash twrp onto my 5T.

You have to reboot into stock rom temporarily to re-enable USB debugging, then reset the permission when you plug in the cable to your computer to allow ADB access. Remember to reflash TWRP after this to replace Oxygen’s recovery.

If you fail this way, try this to boot into straight TWRP:

fastboot boot twrp-xxx.img

Assuming you have the image version. If not download a copy of latest TWRP image from here.

Or else start your phone into bootloader mode by holding volume down button at the same time as power then manually boot it into recovery by pressing the Vol Button for a couple of times till you see recovery in red at the top and then hit the power button to reboot.

If you have an OTG connection to a USB stick you can inverse the operation by booting with the image file first and then using the temporary install to select the USB drive and flash the zip version by mauronofrio from there. But the same holds true, when you leave the temporary recovery select reboot into recovery to get back into your permanent version of TWRP.

AT this point it is essential to to a clean wipe by formatting data to get rid of the encryption of OOS, then also Advanced wipe to clean Dalvik/ART cache, Cache and System.

Two choices after this:

  1. Use ADB to sideload the /e/ zip file
  2. If you have copied it onto your USB stick then flash directly from there (probably the easiest solution)

Of course to allow sideloading, you have to go back to the main menu, choose “advanced” then “sideload”.

One of the best guides I saw was done by a Oneplus 5 user @manish here on the community site.

Although for the earlier model, by just changing the references from “cheeseburger” to “dumpling” the whole procedure is the same. Hope this helps.

After reviewing more closely your attempts to flash TWRP onto your Oneplus 5T, I did a little research.
If you have a problem with a failed update of the OOS, then I suggest trying the classic unbrick tool for Oneplus devices, available here.

This procedure will take your phone back to the stock OOS rom.
Here are signs of a hard-bricked phone:

When connected to a Windows PC using a USB, the phone is detected as ‘QUSB_BULK‘ or ‘Qualcomm HS-USB QDLoader 9008‘ interface under Windows Device Manager.

I can’t be certain that with a Mac that you would get the same message, but the fact that your attempt to update using the System Settings presumably still under the Oxygen OS resulted in “installation failed” makes me think that you were doing a partial update to a system that was already corrupted. Going back to a fresh version of OOS would allow you to start over with the documentation for an /e/ install.

You could try @SuzieQ’s suggestion to try the new e-recovery in place of TWRP, but I can confirm that the 5T is not an A/B device so there is a recovery partition where you could replace the original Oneplus version with a new recovery allowing you to sideload the /e/ zip file.

1 Like

And I can now also confirm an absolutely unproblematic /e/installation on OnePlus 5 “cheeseburger” from /e/ OS ‘Q’ e-0.14-q-20210201 with eRevovery -e-0.14-q-202102019.

This was one of the easiest and most straightforward reinstalls, completed in a few minutes and similar to the result from 21 days ago with the OnePlus 5T ‘dumpling’ /e/OS ‘Q’ Android 10.) on the OnePlus 5 “cheeseburger” from /e/ OS ‘Q’ e-0.14-q-2021020199535-dev- with eRevovery -e-0.14-q-2021020199535-dev-.

Sorry I disappeared for awhile, tax season has to take priority.

I wrote this earlier but accidentally sent it as a PM, here it is again, for public consumption:

OK, all/most of my problems have been solved. As I expected, I was the main issue all along I just couldn’t figure out my mental blocks. I’m on night shifts now so I had some time to focus a little more.

I’m new to Android so perhaps the issue would have been easily spotted by someone who hasn’t been spoiled by the relative simplicity of Apple devices. It all came back to making sure the phone is up to date on the stock Oxygen OS before starting anything with /e/. I checked on the phone for any updates, and the message came up that the system was up to date; that’s the trap I fell into. It turns out the phone was only “up to date” on that version of out-dated OS. In Apple-land it would give you updates regardless. I tried to load the latest version of Oxygen (as issued by OnePlus), but the phone wouldn’t take it, probably because my phone was new-old-stock and was way behind. The OnePlus update didn’t have the ability to update the phone from previous versions of the OS. So, I had to go way way back and install updates, in order, until the phone was caught up into modern times. After about six to eight updates it gained the ability to skip the odd update and jump ahead. I found a good chronological repository at TheCustomDroid

After I spent awhile doing all the back to back updates and caught up to current times, everything went ahead quite well with the rest of the /e/ install process.

I have now completed an install on a OnePlus One, 5 and 5T. The One was my daily driver which will now be replaced by the 5T. My wife uses the 5 as her daily driver and is slowly getting used to it. Our offspring are next on the list to loose Apple and Google. Unfortunate though so many of our schools in Canada are heavily reliant on Google for apps and storage.

Thanks to everyone for their help, I know a few of you will either be ticked or laugh at the problem! Let’s try taking the laugh option, OK? :grimacing: I take full responsibility for the issue… I could have just walked away from the thread but I thought I would share my stumbling with everyone, as I know there are a lot of green people here just trying to do the right thing and support a good cause.


Glad to see @Franko that you finally got your 5T up and working with /e/. I find Oneplus phones the easiest to work with as the company doesn’t make you jump through hoops to get boot unlocked and they produce restore tools which shows they recognise that many users want to flash custom ROMs. I’ve been using a 5T for nearly a year and a half, first on Oreo and then upgraded to Pie and it has never let me down. I’ll be using it as my backup as soon as I do the upgrade to Android Q as recommended by @SuzieQ. As now I finally managed to flash /e/ on a refurbished Oneplus 6, another fine product.

Perhaps you should recommend Privacy Canada to your school managers as they have a good page on how to escape Google. Unfortunately, there’s no mention of the /e/ OS, so perhaps you could put in a good word for us. :wink:

Hi guys

I have a question. My phone says not rooted I used root checker app. Rest everything working with e os.

Did I do anything wrong ?

No, /e/ does not expect to be rooted. :slight_smile:

Okay good to know atleast i know i installed e properly. So now how to root it ?


A search is the usual root. :smiley:

1 Like

The older way to root and keep the Safetynet was to download the magisk zip file and then go into the TWRP recovery to flash this file, but it is now much simpler since the creator of Magisk has joined the zip package to his Magisk manager app (which you used to download separately).

Go to this page and download the apk file for Magisk manager and install it directly on your 5T. It is now called simply Magisk but when you launch it you will see 2 parts, one called Magisk is the actual zip file used to patch your boot image and the other called “App” which is the manager used to launch the patching procedure.

There is an install button beside each which allows you to update and install the latest version of Magisk. You don’t need to go into recovery for this.