OnePlus - 6 - enchilada - Documentation Suggestions

Please add your suggestions to improve the documentation for the OnePlus - 6 - enchilada here …

Well, well.

I finally found the time to approach the upgrade of my OP6 from Android 9 to Android 10.

The positive new that I am glad to share is that it worked.
The negative side is that the procedure is not for the faint-hearted as I had to try it various times to make it work.

Furthermore, you WILL loose ALL your data (apps data, music, videos, photos, everything!) because a format of the data partition is requested during the procedure to disable encryption.

Since this topic is about suggestion to the documentation, here is my feedback:

  • I strongly recommend the reader to read the procedure in full at least once before trying it.
    • If things go (very) wrong, one should have the maker’s restore tool at disposal. For this device it’s the MSM Tool for Oneplus 6 that can be found on XDA.
  • If you are running /e/ OS in its Android 9 version (Pie), your device will be fully encrypted by default and there is no option to decrypt it prior of the upgrade to Android 10 (Q). Please note the documentation suggests the device may be or not be encrypted, but in this case there’s no doubt it is encrypted.
    • Consequently, when you will be requested to format the /data partition to prepare for the installation of Android 10, you will erase everything and return the phone to the factory defaults.
    • So, it is of utmost importance that you take a backup of everything that is stored on your phone, including but not limited to: photos, videos, music, apps data, contacts, messages etc. This is not stressed clearly enough in the existing documentation: YOU WILL LOOSE ALL YOUR DATA. Taking the backup is particularly important if you are not connected to the Google ecosystem that backs up the stuff for you in the cloud. I used Titanium Backup for the apps and did a manual copy of music, photos and videos etc. for the rest.
  • Another thing that is not stated in the documentation, that in one of the first steps requires TWRP as the recovery for performing the installation, is that the installation of the new version of /e/ OS will overwrite TWRP with its own (primitive) recovery.
    • So, I would add the optional step of restoring TWRP from the /e/ recovery after the installation of the operating system. The steps for doing so are the following:
      • [from phone]: /e/ recovery -> Apply Update -> Apply from ADB
      • [from PC]: adb sideload twrp-installer-*
  • Last but not least, after the phone is running Android 10, I would remind the user that not only has to restore the apps and own music, photos etc, but also review the Android settings (e.g. language, themes, DNS…) as the phone will be like after a factory reset.
1 Like

I quite agree with @OnePlus6user that the /e/ installation on this phone with its A/B configuration is of another order of difficulty compared to earler phones. Having installed /e/ on several different models previously I realised after reading the install guides here and elsewhere it was not going to be a cake-walk with this device. Having read the long exchanges that @Lance provoked with his earlier solution I can see that my experience might put others off!

What is confusing appears to be the relatively simple approach in some guides where they just do a clean wipe after unlocking the bootloader and installing TWRP and then proceed with a straight sideload of the custom ROM onto the first available slot. While this may have worked for some when the 1+6 first came out, it seems that the updates to the OxgenOS to version 10 have created bootloop problems.

Not being a specialist I can only observe that problems seem to arise because of a more complicated boot_control system whereby OTA updates must know which slot to boot from and if they fail a safety check then they can go back to the older already-installed system. Better experts than me can explain this more clearly no doubt. But my guess as to what causes bootloops is that an incorrect overwrite of the boot image on one side throws a spanner in the works and so the added steps of flashing to one slot and then the other in the right order, somehow allow the boot control to function correctly.

It’s for that reason that I decided to follow a longer procedure found here, that flashes the latest OOS update twice successively with reflashing of TWRP in between to allow a return to their recovery and prevent a return to stock recovery. Only after this is the sideloaded and installed.

Unfortunately, I missed a final reflash of TWRP and ended up with the e-recovery, and with its limited functions it seems to only be able to do updates by adb sideload and cannot flash zip files loaded on internal memory.

My attempts to reinstall the TWRP recovery failed as it seems A/B devices do not have a recovery partition and when I try to flash a recovery it returns “no such partition”. But I was also blocked by the fact that the usual “fastboot boot” method with the twrp image didn’t work anymore. The “boot.img” gets sent and response is OKAY, but the next line says:
Booting Failed (remote: 'unknown command')

I was reluctant to sideload a zip file of the same twrp version which worked before as I have read that it loads it into the system in the same way as sideloading an e-zip file. Perhaps I’m wrong here.

I tried a suggestion of @chrisrg from the Lineage install page for enchilada which said to:

fastboot flash boot twrp.img

Then I had a problem with which slot so I did the same specifying flash boot to each slot, but result was a failure to boot. But at least I had my twrp recovery back.

At this point I decided to restart the whole installation procedure with installation of OOS to both slots followed reinstall of twrp each time, then finally installation of the e-zip file but this time reflashing twrp before restarting the system.

As you can imagine I spent the best part of a day with all these repeated procedures, however, I have at last got a working /e/ installation with Android 10. Oof! :disappointed_relieved:

I would like to be able to root my 1+6 with Magisk to experiment with backup procedures and see if I can get it working like my 5T, but I fear too much modding will make it difficult to get any OTA update working. My apologies for this long harangue.

1 Like

Updating my Oneplus 6 to Android Q - version 10
/e/ version 0.15-20210312105636 for “enchilada”

Having had a difficult time installing /e/ on my Oneplus 6 as I related above, I decided to wait until I had my backup phone, a Oneplus 5T, had copied over what I have as important for daily usage so that, in case of bootloops or hard bricking my OP 6, I would at least have a working phone.

Following the /e/ updates put online last week as the 0.15xx versions, I decided to take the plunge, but to play safe as I knew the decrypting procedure would erase all my personal data, I decided to treat it as a complete reinstallation from OOS 10. This would involve reflashing the original system back onto both slots and then sideloading the new /e/OS.

Like OnePlus6user, I have rooted my device to be able to use Titanium Backup to conserve all my previously installed apps and data, so I also knew that I would have to re-root my OP 6 once I had finished the update, in order to restore them all.

Having reflashed the mauronofrio version of TWRP on my first /e/ install, I felt safe in being able to start the double flashing procedure. After a first hiccup when I tried a more recent OxygenOS restore file which failed to start, I went back to my initial version and all started well until I made the mistake of going back to recovery before reflashing TWRP, and ended up on the Oneplus recovery, which of course, doesn’t allow installing custom ROMs. But on trying to reboot into TWRP recovery using ADB, I was hit by this blockage:

./fastboot boot twrp.img
Sending 'boot.img' (xxx kb) OKAY [ 0.98 sec]
Booting	     FAILED    (remote: 'unknown command')

I discovered that the restored Oneplus partition had no command to boot into TWRP. Then I learnt that I had to set the slot I needed to get my recovery to boot.

./fastboot set_active a

Then I flashed the TWRP recovery

./fastboot flash boot_a twrp.img

Using the buttons on the phone I finally managed to get back into TWRP. From there I could reflash TWRP on both slots to be able to continue my OOS restoration. From there on I was in known territory so I used TWRP to finally flash the new /e/OS zip file from a USB stick that had all the necessary files for the update procedure. Last but not least, I reflashed TWRP before booting the new /e/ system to be able to re-root my phone with Magisk.

Success finally came after an anxious wait for the bouncing dot to finish and then all went well with reconnecting to Wifi, setting up accounts and the whole system seemed to work as well as before, perhaps a little snappier. I’ll leave my comments on my impressions of the new Q version of Android for another posting, but I hope that if anyone encounters similar problems with the update then my experience might prove useful.

To the installation instructions I suggest clarifying the caution in the “Requirements” section to only update the stock android ota to match the eOS version one is installing.

To the eOS version upgrade instructions I suggest an alteration to the command in the “Steps to Flash the Upgrade /e/OS ROM”, step number 7 to:

fastboot flash boot twrpimagename.img

More importantly the copy partitions instructions should be included here as well, as part of the process. This is exactly the situation where it may be needed most, where the phone may have android 10 one one slot and 11 on the other.

1 Like

I just upgraded two 1+6’s to eOS ver 1.10… and Android 12. I followed
but for a none techie it is still very intimidating.

Challenges and maybe enhancement to instructions:
I could not get ADB Devices to recognize the device. I hardly ever have used ADB and really have no clue what it is for.
I am not sure which of these two finally made it recognize the 1+6.
I turned off IP masking in Advance Privacy and I turned on USB Debugging in Developer Mode. After doing this the device was recognized and the ADB steps in the doc worked. Upon completion I turned USB Debugging off.

Another challenging thing was, for the same devices, the completion info shown in the terminal and each device were different though they both seemed to work.

One terminal/device showed:
ron@Ron-ZorinPro:~/Downloads/eOS/platform-tools$ adb sideload /home/ron/Downloads/eOS/platform-tools/
Total xfer: 1.00x
The phone did not indicate success or completion except to show step 2/2 and the back arrow as described in the document. I hit the arrow and then selected Reboot The Device and PRAYED!

The other terminal/device showed much much more:
ron@Ron-ZorinPro:~/Downloads/eOS/platform-tools$ adb sideload /home/ron/Downloads/eOS/platform-tools/
serving: '/home/ron/Downloads/eOS/platform-tools/e-1.10-s-20230413279105-dev-encserving: '/home/ron/Downloads/eOS/platform-tools/e-1.10-s-20230413279105-dev-encserving: '/home/ron/Downloads/eOS/platform-tools/e-1.10-s-20230413279105-dev-encserving: '/home/ron/Downloads/eOS/platform-tools/e-1.10-s-20230413279105-dev-encserving: '/home/ron/Downloads/eOS/platform-tools/e-1.10-s-20230413279105-dev-encserving: '/home/ron/Downloads/eOS/platform-tools/e-1.10-s-20230413279105-dev-encserving: '/home/ron/Downloads/eOS/platform-tools/e-1.10-s-20230413279105-dev-encserving: '/home/ron/Downloads/eOS/platform-tools/e-1.10-s-20230413279105-dev-encserving: '/home/ron/Downloads/eOS/platform-tools/e-1.10-s-20230413279105-dev-encserving: '/home/ron/Downloads/eOS/platform-tools/e-1.10-s-20230413279105-dev-encserving: '/home/ron/Downloads/eOS/platform-tools/e-1.10-s-20230413279105-dev-encserving: '/home/ron/Downloads/eOS/platform-tools/e-1.10-s-20230413279105-dev-encserving: '/home/ron/Downloads/eOS/platform-tools/e-1.10-s-20230413279105-dev-encserving: '/home/ron/Downloads/eOS/platform-tools/e-1.10-s-20230413279105-dev-encserving: '/home/ron/Downloads/eOS/platform-tools/e-1.10-s-20230413279105-dev-encserving: '/home/ron/Downloads/eOS/platform-tools/e-1.10-s-20230413279105-dev-encserving: '/home/ron/Downloads/eOS/platform-tools/e-1.10-s-20230413279105-dev-encserving: '/home/ron/Downloads/eOS/platform-tools/e-1.10-s-20230413279105-dev-encserving: '/home/ron/Downloads/eOS/platform-tools/e-1.10-s-20230413279105-dev-encserving: '/home/ron/Downloads/eOS/platform-tools/e-1.10-s-20230413279105-dev-encserving: '/home/ron/Downloads/eOS/platform-tools/e-1.10-s-20230413279105-dev-encserving: '/home/ron/Downloads/eOS/platform-tools/e-1.10-s-20230413279105-dev-encserving: '/home/ron/Downloads/eOS/platform-tools/e-1.10-s-20230413279105-dev-encserving: '/home/ron/Downloads/eOS/platform-tools/e-1.10-s-20230413279105-dev-encserving: '/home/ron/Downloads/eOS/platform-tools/e-1.10-s-20230413279105-dev-encserving: '/home/ron/Downloads/eOS/platform-tools/e-1.10-s-20230413279105-dev-encserving: '/home/ron/Downloads/eOS/platform-tools/e-1.10-s-20230413279105-dev-encserving: '/home/ron/Downloads/eOS/platform-tools/e-1.10-s-20230413279105-dev-encserving: '/home/ron/Downloads/eOS/platfoserving: ‘/home/ron/Downloads/eOS/platform-tools/’ serving: ‘/home/ron/Downloads/eOS/platform-tools/’ (~47%) adb: failed to read command: Success

This device did not present a back arrow as in the instructions but showed the screen Reboot The Device, which I did and it seemed to work.

I don’t know why the devices worked differently using the same Zip file and same exact process.

I hope this information is not confusing and may be helpful to either improve the process or just help a user like me.