OnePlus 6T OTA update to 0.14-q results in failed update

I’ve been using /E/ on my 6T for a half a year and a few of the OTA updates have caused to boot to recovery stating I need to do a factory reset to continue. The most recent one being the update.

I’ve tried closing all apps, rebooting the phone before an update, but yet again I’m met with the failure to boot. Is there a way I can check what’s failing, maybe report an error log or is it expected that OTA updates will result in a factory reset half the time ?

For anyone looking for tips on recovering, I’ve managed to do this with ADB with these steps:

  1. Reboot into recovery mode by holding down Volume Down and Power/Wake
  2. Cmdline/Terminal:
    fastboot boot “path\to\twrp-3.5.0_9-0-fajita.img” (TWRP fajita)
  3. After TWRP has loaded, enter your PIN/pass to unlock
  4. Advanced — ADB Sideload
  5. Cmdline/Terminal:
    adb sideload “path\to\” (/E/ fajita, I used the previous installed version)

This installed the previous version on the inactive A/B partition, after a reboot I was up and running again.

1 Like

There has already been some feedback today from various devices with update e-0.14 problems. ROMs have also been withdrawn, e.g. here …

1 Like

Exact same problem here. It would only boot into bootloader after reboot, beside the update taking forever. Had to get into recovery and update through sideload. Fortunately everything came back up after that. I was sweating for a minute .

1 Like

Some people reported OTA issues in recent months. So, I didn’t update my OnePlus 6T /e/OS v0.11.
Did last OTA work fine for anyone?

FYI, I updated my device from 0.11 to 0.15 with success.

1 Like

Did you do the update via System Updates or through a (re)install ? Did you have a PIN code or biometrics enabled ?

I did the OTA update via System Updates. I have a PIN code on my SIM and on my phone, plus the fingerprint biometrics enabled.

1 Like

Interesting, as OTA was broken and if your phone’s memory was encrypted (PIN or biometrics), it would also fail. I’ll try it myself if I find enough time to recover in case of failure.

As I read many bad feedbacks about the last OTAs on this forum, I skipped some of them. And I did a backup of my all data before updating to 0.15.

I just tried upgrading with the 0.15 OTA update from 0.13 and it failed to boot, needing a wipe to continue.

Pl can you share more details as to what is happening with the build. Were you able to download it ? If you have TWRP already installed on the device you can try and manually run the installation as described here

An issue has been created for this here

I was able to download and install through OTA (System Updates) from 0.13, but the 0.15 update as well as the 0.14 update, after a seemingly successful install, it reboots, reboots again and goes into e’s Recovery.
I can then choose to try rebooting or clearing user data, which I’ve had to do in the past as well. It was a stock OnePlus 6T with originally the latest OxygenOS from mid 2020. I rooted it and installed the then latest supported /e/ version for “fajita”. I was able to do OTA updates, but it also went wrong one time updating to 0.13 and afterwards I have had every OTA fail to upgrade, after wiping the storage it works though.

Bad news…

If it can help, my OnePlus 6T was bougth at the end of 2019. I didn’t updated the provided OxygenOS and directly flashed it with /e/OS.