OnePlus 7 Pro issues

I’ve just installed the latest image on my OnePlus 7 Pro.

I got several issues, the first of which makes the phone unusable:

  1. Modem is not working. When I insert a SIM card, it is recognized and I can unlock with PIN, however the network service indicator stays empty (no bars) and I have no connection to the phone network

  2. 5GHz wifi seems to be not working. I can see and connect to 2.4GHz networks, but 5GHz are not visible.

  3. Checked out the Self-Check screen in MicroG settings: “System supports location provider” remains unchecked, as well as “UnifiedNlp is registered in system” and “UnifiedNlp do not have Location to test Geocoder”. The Mozilla Location Service and Nominatim are themselves configured and enabled.

Any advice?


1 Like


regarding point 1 and 2: Do you have had a stock pie on your phone ? If not, the needed pie firmware is missing on your phone. You have to flash pie firmware before flashing eOS

Regarding point 3: That’s happens often. I’m always facing that til I the phone has found the location in an app, for example weather app, When location search has happens, the selfcheck will fish complete

Not sure what was the stock version.

Model is GM1910.

I tried flashing 9.5.9-GM21BA-OnePlus7ProOxygen_21.E.13_OTA_013_all_1907050211_b8852b6-FASTBOOT from here. The phone booted, but the modem was similarly not working. I performed system update and after that everything seems to work fine (modem, wifi, etc.), but it’s updated to Android 10.

Should I try flashing eOS again, or choose a different FASTBOOT image, or does this mean I can not use Pie-based firmware at all?

@dkaparis, I know this problems of flashing with LG and Samsung devices.

I would flash a StockROM 9-Pie (not Android 10). A “Clean Install” is recommended. Among other things, this will flash the important files from /vendor and /Modem to separate partitions. Note: These partitions & files are not overwritten by a custom ROM.
On this basis then install the /e/ OS e-0.7-p-2019121834550-dev-guacamole with TWRP.

I just tried flashing 9.5.13-GM21AA-OnePlus7ProOxygen_21.O.16_OTA_016_all_1908281716_b2bb5-FASTBOOT from the above site. Is there any other source for a stock ROM for my model?

Anyway, after flashing that image everything was working fine out of the box (both WiFi bands, modem, etc.) without doing further updates (reported Android version was 9). I proceeded to install eOS per the instructions (wiped data, system and cache partitions, sideloaded the eOS image) and after booting I have again the problems reported in the original post: modem not working, WiFi only seeing 2.4GHz networks.

Further ideas?

In my search for One Plus 7 Pro Oxygen Firmware version 9-pie (lower android 10) I always end up on XDA.However, I cannot judge whether these versions are country-specific, i.e. suitable for your place of residence.

Since StockROM v 9-pie works, I would try another custom ROM, e.g. LineageOS 16.0. Also try with microG. If it doesn’t work like under StockROM, the error is probably due to LOS 16.0, less to microG. It’s worth a try, right?

I installed the same 18th Dec image as you. However I was on v10 stock firmware already. 10.3 I think. Points 1 and 2 worked for me. Cannot comment on point 3. I did however return to stock due to poor camera experience. I wait to see how the /e/ project develops.

1 Like

That’s what I mean on post #2. Point 1 and 2 are firmware issues.

Do you have tried with enabled camera2 Api 2

1 Like

You know this app for getting the firmware ?

Yep, it’s OK. But not quite there

An update on the situation.

I tried flashing a number of the availabe OOS 9 stock images above and with practically all of them the pattern was this:
After flashing, WiFi (all bands) and modem work, however sensors (proximity, gyroscope, compass) do not work (i.e. no screen rotation, no compass, etc.).
After applying the official OTA update to OOS 10, all sensors work properly.
After clean installing eOS or LineageOS, whether after updating to OOS 10 or directly after flashing OOS 9, sensors again do NOT work.

I managed to use the MSM tool ( to return the phone to stock condition and then the sensors were working correctly (under Oxygen OS 9.5.3.GM21AA). However, again, after clean installing anything LineageOS 16-based, sensors do not work.

1 Like

Could you extract the firmware with the app I have posted a link ?
I was hoping, that you can extract the firmware, flash eOS and than reflash the firmware. So your drivers will be up to date.

I had similar experience from OOS 10.3 to eOS 16base. Sensors did not work for me. Screen rotate was an issue so went back to stock for the time being as phone is my daily driver.

1 Like

Looks like a firmware update issue as @harvey186 mentions above. The /e/ or LOS ROM’s may not be updating the firmware.

Could you extract the firmware with the app I have posted a link ?
I was hoping, that you can extract the firmware, flash eOS and than reflash the firmware. So your drivers will be up to date.

Seems the application extracts firmware from an image file.

I’m not sure which one to use. When flashing any of the FASTBOOT stock images available, sensors are not working initially. The only way to get them to work is either applying OTA update from stock, or resetting the phone with the MSM tool.

I never have used that app because I don’t have an OP device. But I think, you must have an Android 9 stock firmware installed for extracting.

It requires a ROM file to extract from. Problem is, I don’t have access to a ROM image that gives me functional sensors after installing (without further OTA update).

Here is directory of OP 7 Pro roms

Looks like this has been raised as in issue with LOS. I’ve also seen others report similar issues on XDA