OnePlus 7 Pro issues

Someone here using the 7 Pro with /e/ as every-day device? If so, what are the annoyances (doesn’t work) in addtion to the ambient light and rotation sensor (✓&state=opened&label_name[]=guacamole) ?

E.g. real-world experience with the camera since I read nobody managed to install the OnePlus camera app so far, but one has to use OpenCam.

I am close to buying it as my new main device but since the price tag is not the cheapest, I’d like to hear some experience from someone actually using the 7 Pro with /e/.

I just got my OP7Pro (GM1913) setup with e-0.7-p-2020033047438-dev-guacamole.

So far I am happy with basic everyday usage, almost everything works:

  • 4G/LTE, data, calls.
  • 5G untested

Not working is:

  • Adaptive Brightness
  • Auto-Rotation

Regarding Auto-Rotation, manually setting the screen orientation via Mudar Noufal’s app “Rotation Quick Setting” works fine for me.

Thanks to the links here and resources on XDA and elsewhere the sensors are now working on my Op7Pro using latest /e/.


  • Op7Pro, GM1913
  • Software Base: Initially on Stock 10.0.? ROM, having installed /e/ e-0.7-p-2020033047438-dev-guacamole on top, everything fine with the exception that sensors are broken


  1. Try to revert to stock pie rom, get sensors working
  2. Reinstall /e/ from there

What did not work:

What worked:

  • Steps exactly as described here:
  • This gives the desired stock pie 9.5.11 rom with sensors working.
  • Install e-0.7-p-2020033047438-dev-guacamole, which gives /e/ with working sensors.
  • Then use temporary TWRP “fastboot boot ” only, do not try to persist TWRP with “fastboot flash boot ” & install twrp zip
    • fastboot flash boot & install twrp zip: Always resulted in ROM bootup becoming corrupted upon “install ”, leaving OS bootable, but fingerprint sensor and WLAN broken.
    • Tried standard trwp and Mauronofrio
  • TWRP Install of current Magisk installer zip works fine

Adaptive Brightness and Auto-Rotation are now working. Sensors are coming up fine.

I had the sensor problem too, because when I downgraded on oos pie, I had chosen the wrong version, I had installed the gm21aa 9.5.11 all while my device is a gm1913, the right version which restored the sensor is gm21ba 9.5.11. Now everything works as it should. But there is something that I can not understand, I wanted to install Magisk (I know it breaks security) for different reasons but I face a problem that I have never seen before, Magisk installs properly, applications have root access BUT the sensor stops working, no screen rotation, no gestures, no double tap to wake … Anyone have any idea what’s going on ??