Oneplus 8 Pro Bricked when flashing Please help


I first tried to use the easy installer, but it just looped when downloading the os too the phone, so i started doing the the manual build.

I bought this phone just for this purpose, and it took me one night to completely brick it. Everything went smooth, following the detailed guide step by step. Until i flashed it, and rebooted it, and got this recovery screen. (See pictures)

Here i was supposed too chose the the recovery file provided, but iam not able too. And iam not able to use the touchscreen… I have tried OTG cable, and can do some simple stuff, but iam not able to put in th PIN it want me to put it on to reset it… And the other options doesnt really do much, i added some of the debugging log, if that tells anyone anything…If u would have a look?

So what do i do now? I did everything just as it said, this was the T Build as it was the newest android version.

Edit: As a new user i am only able to add one picture in each post. yippey! Guess i choose this then: Before this, it gives me a warning my phone is unlocked and is unsafe to use(It also gave me a pop up one time with a prompt telling me to go to some site to get it fixed) But it never appeared again.

Iam not able to type in this pin, not even when using a keyboard with numpad and a OTG Cable… And not with a mouse either…

Was this brand new, refurbished or “pre-owned” ?

Being asked for a PIN to Format data looks a bit like Factory Reset Protection. It is essential to remove all accounts especially any Google account from the phone. If Pre-owned the seller may be able to help.

Is this menu not driven by Volume and Power keys ?

Is quite common. Unlocking the phone changes the status of verified boot,, maybe it helps to have an understanding of the fuller explanations given for the “colour defined” states.

YELLOW: Warning screen for LOCKED devices with custom root of trust set
ORANGE: Warning screen for UNLOCKED devices
RED (eio): Warning screen for dm-verity corruption
RED (no os found): No valid OS found

I think your images are of the “Original” recovery, rather that any Custom recovery, so this may give a clue to where things failed – perhaps at or before

Installing a custom recovery using fastboot

Edit You seem in a similar position to this or this

1 Like

It was pre owned. And yes it is powered by up and down volume keys, but I cant write a pin with It. Only navigate the menues.

And yes it seems similar, it seemed everything went fine until i used(flashed) the instantnoodles recovery file, but i read later if it is the newest android i should maybe try the lineage os recovery files instead.

I just have no idea how too do this now when I cant turn the phone back on. How can i unbrick it?

And i dont think the old owner have any idea how to fix this, doubts he have the knowledge

Does this debug tell u anything.wish i could upload more pictures at a time

Can you use the menu to get back to fastboot ? That will be the starting position for your next move.

We don’t know it is really bricked, the recovery is still probably original and system is compromised. So put simply those two booting methods are out of use. It is all down to getting back to fastboot.

Just so you know e-recovery, when you flash it successfully will look like images on this thread [HOWTO] use e-Recovery to wipe & format data before sideloading/install eOS

The point of failure is likely the point where you have to

Now reboot into recovery to verify the installation:

  • With the device powered off
  • hold Volume Down + Power

This instruction is unhelpful for first timers. If you allow the phone to do a standard shutdown then reboot to recovery on most / many phones the new, Custom recovery will be wiped; the phone seems to try to preserve the original.

You need to try something like, leave fastboot mode with Volume Down + Power, then as the screen goes black you lift your fingers from the keys for a moment, press again, and relax after a few seconds or a vibrate.

If you don’t see e-Recovery you try again, maybe you find the key presses a slight variation on the above (which seems correct for OnePlus One).

1 Like

Hmm ok I didn’t know about these “secret” steps. Will try them out thnx man :slight_smile:

But this is what i was supposed to do, but what should i do right now? No option in the menu for fastboot?

oh wait i got back into fastboot now!

Are you online, could really need your guidance on what to do right now

This is where iam right now. So what do i do

Great that you have the bootloader !

Now you can pick up the instructions again – where had you got to ?

Where had you got to in this sequence …

fastboot oem unlock clearly done from your image.

[ … ]

  • Since the device resets completely, you will need to re-enable USB debugging to continue.

Flashing additional partitions

Please check that you can get a response with the command from your PC

fastboot devices

One more thing … had you already ensured you met this advice

Before following these instructions please ensure that the device is on the latest Android 13 firmware.

In which case you will be using the top images from | + |

1 Like

I can get it into fastboot rrol time to time. Bu5 not when it is connected 5o my computer.

And there is not really much i can do from the fasboot menu. What am i supposed to fooo. This make me crazy :face_with_peeking_eye:

Oh and I also get this from time to time:

Yes those are done. I got to fast oot glash dtbo mad vbmeta and are now at instøaling a custom recobery using fastboot.

Like seen in this picture

And yes i can see the device with fasboot on my computer. I get two devices though. One named fastboot and one named the serial number

That is the response you want !

Your phone has identified itself as 2f33xxx and told you it is in fastboot mode.

Good to go … with
./fastboot flash recovery recoveryfilename.img

1 Like

So i tried this step again, does it look ok?

Yes, looks ok.

Be prepared to flash the recovery.img again in the event that the finger presses don’t come right first time.

Ok, here it goes, ill try

Ok one step closer but some error

So select Factory data reset … which we know is required with this device.