OnePlus 9 pro - Camera Error

Hello all,

I also have a total failure of the camera.
My phone : OnePlus 9pro.
About 10 days ago I installed /e/OS (1.1-20220629200015) on the factory new phone.
For a few days the camera worked, then I got the following error message: Error opening camera. Camera maybe
in use from another application ID:0

Because this was mentioned here before and helped others, I installed openCamera just to see if it would work with it.
Didn’t work though. Also, this phone has a Hasselblad camera, so I understandably don’t want to settle for a reduced app.

I also cleared the photo cache and the content. But that didn’t do anything either.

Does anyone have any ideas about this? I would be mega happy, because without a camera, the whole thing is not operational.

Many thanks in advance. Many greetings

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hi @silver welcome to the /e/ forum.

I had the error once

Error opening camera. Camera maybe in use from another application ID:0

The problem was indeed another app when uninstalled the issue went away. So maybe first check your own installed apps which have Camera permission. (Perhaps Maps might be glitchy if Camera is allowed full time, idk). Edit, or even a bar code reader.

For an alternative camera I quite liked GrapheneOS Camera Option - Possible foundation for a native /e/OS Camera and Simple camera from www.simplemobiletools.com.

Hi aibd,
thank you very much for your reply.

yes, I have denied all permissions for the camera from other apps and now checked again.
Also, I have already tried your suggested camera apps - neither work.
I have also tried 5 others - everywhere the error message comes up.

What amazes me a lot is that the camera worked and I could take photos for a few days.

I had not inserted a SIM card until then, because I wanted to check the settings or permissions first.
Then at some point I inserted my SIM and after that the camera didn’t work. Neither with nor without the SIM card.
Is there possibly a connection?
The problem with the camera seems to affect many… I hope someone has a suggestion or another solution for me.

Many thanks,
Silver

You might now consider a Factory reset with the SIM card installed? Seems pretty extreme under the circumstances; I cannot really explain a SIM card connection but if you were sure of the timeline … ?

Have you installed many apps yourself? If you were even considering of a Factory reset … you might uninstall every own-installed app … and keep testing the camera.

I fail to remember the name of the app which caused the error for me … it does stick in my mind that it was a fault within the offending app and not an obvious camera hogger.

Late edit, @silver I just saw this app. The blurb includes

This is useful when you get the famous error message “Can’t connect to camera” or similar

https://f-droid.org/en/packages/info.aario.killcamera/ – also available on App Lounge :slight_smile:

Thanks for your further ideas.
I only had 4 custom apps installed at first. Now I have uninstalled all of them except F-Droid.
Has not helped.

Killcamera I had also tried right at the beginning, I did not get anywhere with it.
I installed it now, where you say it again and I get the following message from Killcamera:
I cannot get root access. Are you sure this device is rooted?

I turned off root debugging in the developer options. Is it connected to this?

Thank you and best regards

hmm … my apologies, I did not see rooting mentioned within the app (and did not test it myself before drawing your attention to it). I see here

that it does indeed need root access. It simply does not install on my non rooted device.

Root debugging will not cut it … I can link this How to root /e/OS … but this does not seem the way forward to fix your issue.

Your OP has had a significant number of views already … I think you have something of a one-off situation.

Have you tried a factory reset to see if the issue still persists?

Thank you,
yes I think I will do that next.
Will report back afterwards.

It looks like I have found the bug! :slight_smile:

after the factory reset, I set everything up again one by one and checked the camera after each step.
I had created a tile for quick settings, a button to turn on and off the sensors.
Of course I turned these off and didn’t expect the camera needs them though.
The microphone needs it unfortunately and therefore I put it in a tile to be able to switch faster.

So every time I turn off the sensors, I get the error from the camera.

I am very glad to have found this out.

Thanks a million for your kind help and inspiration.
Maybe this conversation will help others too.
Kind greetings, Silver

1 Like