Oneplus Nord manual installation problems

You are right – this is missing from the install instructions. I regard the following as a prerequisite

Caution: Do not install /e/OS on top of a higher version of stock OS. Before installing /e/OS ensure your device has the latest stock OS of the same version as /e/OS. If only lower versions of the stock are available then install the last available lower version before installing /e/OS.

I can understand your feelings about “Ensuring all firmware partitions are consistent” but this only seems to have gone wrong as the Custom Recovery step had failed for some reason.

hmmm … or you could take on trust that OxygenOS had left everything nicely set up.

I use TWRP (on different devices) – and TWRP is listed for nord. You could check some recent nord threads on the forum for reassurance, perhaps.

Thnx.

I’ll update tot Andriod 11 first.
I already downloaded the latest twrp vrsion from mauronofrio. I think I will try to install that instead of the /e/ recovery for the nord.
Keep you posted

Succes!!! After the MSM reset and upgrading the stockrom to Android 11 everything went competely smooth. I decided to stick to the guide and use the /e/ recovery after all. I got a small heart attack when after sideloading and installing the zipfile, I did get the Total xfer:1.00x message, but on my device not the "Script succeded result was [1.000000] message, but it rebootet to the /e/ os without any problem.
So happy :grin:
Thnx again everyone who helped and especially aidb and hirntot. Now tomorrow I can get some work done :crazy_face:

1 Like

I had what looks like the same ordeal today as you did in this post.
Care to outline the steps one would take to manual install /e/ os?
It seems the guides are not uptodate.
I had previously installed on Android 10 but now with 12 it was a 5 hour disaster

Hello together,
yesterday I bricked the second OnePlus Nord AC2003 avicii. One should have been a present for my daughter. Now I have two zombies.
One shows the “destroyed”-screen from the post of june 14. The other shows

I am out of patience and looking for someone, who will try it for me to bring the phones back to life with /e/. I would like to send the phones by mail. Of course I would pay for the work.
Please write me on f.scholz.wodorf@web.de, my name is Frank.

Hij Frank, I am no expert at all, bit in the end it was nog that hard tot inastall the oneplus firmware andere boring my iPhone back tot life. Andere after that instelling e was a breaze. I’m on a skiing Holiday NOS but next week I’ll be back and I could try tot help you yhen

Cheers
Lange

Frank Scholz via /e/OS community community@e.email schreef op 25 december 2023 11:48:04 CET:

| wodorfer :de:
December 25 |

  • | - |

Hello together,
yesterday I bricked the second OnePlus Nord AC2003 avicii. One should have been a present for my daughter. Now I have two zombies.
One shows the “destroyed”-screen from the post of june 14. The other shows

I am out of patience and looking for someone, who will try it for me to bring the phones back to life with /e/. I would like to send the phones by mail. Of course I would pay for the work.
Please write me on f.scholz.wodorf@web.de, my name is Frank.


Visit Topic or reply to this email to respond.

To unsubscribe from these emails, click here.

– Verstuurd vanaf /e/ Mail.

Hi Diederik,

vielen Dank für Dein Angebot. Ich wünsche Dir einen schönen Winterurlaub und freue mich darauf, anschließend von Dir zu hören. Ich habe mich echt verirrt in dem Dschungel von adb, fastboot, den richtigen Abfolgen usw. Ich verstehe auch nicht richtig, was ich eigentlich tue, sondern folge den Anleitungen. Und wenn die nicht stimmen…

Mit diversen Samsung-Geräten, einem OnePlus 7 und meinem Fairphone 3 hat es bisher immer geklappt. Ich bin Deutscher und mein Englisch ist holperig, so lasse ich ChatGPT das hier übersetzen ins Englische und ins Niederländische. Du bist doch Niederländer?

Herzliche Grüße

Frank

Hi Diederik,

Thank you very much for your offer. I wish you a wonderful winter vacation and look forward to hearing from you afterwards. I’ve really gotten lost in the jungle of adb, fastboot, the right sequences, and so on. I don’t really understand what I’m doing, I just follow the instructions. And if they’re not correct…

It has always worked with various Samsung devices, a OnePlus 7, and my Fairphone 3 so far. I’m German, and my English is a bit shaky, so I’ll let ChatGPT translate this into English and Dutch. You are Dutch, aren’t you?

Warm regards,

Frank

Hallo Diederik,

Dank je wel voor je aanbod. Ik wens je een fijne wintervakantie en kijk ernaar uit om daarna van je te horen. Ik ben echt verdwaald geraakt in de jungle van adb, fastboot, de juiste volgordes, enzovoort. Ik begrijp ook niet echt wat ik doe, ik volg gewoon de instructies. En als die niet kloppen…

Het heeft tot nu toe altijd gewerkt met verschillende Samsung-apparaten, een OnePlus 7 en mijn Fairphone 3. Ik ben Duits, en mijn Engels is een beetje haperend, dus laat ik ChatGPT dit vertalen naar het Engels en het Nederlands. Jij bent toch Nederlands, toch?

Hartelijke groeten,

Frank

Hi, I am trying to bring Frank’s phones back to life, but no luck so far. One still had the flimsey recovery of Oneplus working, so I tried to flash TWRP recovery, but that only resulted in losing fastboot mode :-(. Trying to get the phones in EML mode has not worked so far. I seemed to get 1 phone into EML mode. I could see the Qualcomm HS-USB QDLoader9008 (COM4), but there was a yellow triangle warning sign next to it and nothing happened when I tried to flash the Qualcom firmware. Now I don’t get EML at all anymore. I managed to bring back my own phone back to life with the help of this site: https://community.oneplus.com/thread/1541327.
It suggest a way of getting into EDL mode:
Another way of getting into EDL mode is used if your phone no longer boots into Android. You have to completely power down the phone. Press both the volume buttons simultaneously and hold for 5 seconds (NO POWER BUTTON ) and connect to PC. For devices older than the 7 series, only the volume up button for 5 seconds is required.

This doesn’t work on Frank’s phones Any ideas?

Just a thought; for this method “completely power down the phone” (for some phones) may not be so easy.

Have you tried to fully discharge the battery maybe for an extended time (one would ideally want to simulate disconnect the battery).

Edit At the next stage I am not certain if you can now engage EDL from fully discharged – try first … or whether one would then need to recharge the battery without engaging the faulty system.

This thread mentions “correct drivers” and “timing”. EDL may last only a few seconds (less than the 10 seconds quoted in the OnePlus Community link)

This link (showing 5 Nord variants) may be significant if you need to confirm identification of the device.

aibd, thanks foor the help. I finally managed to get 1 phone recognised by the MSM tool by pressing both the volume + and - and power buttons for mayby 20 seconds like Ytube21 suggested in this thread: https://xdaforums.com/t/how-to-reboot-to-qualcomm-edl-mode-without-adb.4469533/ that you found.
Now I have a working phone with adroid Nord OxygenOS 11.1.10.10.AC01BA on it. I will upgrade it to the latest android version and then try to install E os on it.

Before somethuing goes wrong again, I have a question about the Android version. I have android 11 installed with build no 11.1.1.10.AC01BA (model is AC2003). I read in the E install guide (https://doc.e.foundation/devices/avicii/install) that I have to make shure that I upgrade to the latest version of Andoid 12 before starting the installation of E OS. But when I go to system updates in the device it says that the system is up to date. As I understand, it depends one Oneplus to enroll android 12 to my device and since I just managed to roll back to android 11, I suspect, that waiting for Oneplus can be a long wait.

Now when I follow the link in the installation guide to downloads for Avicii, I find Android Q, R and S. Am I correct in assuming that Android Q stands for Android 10, Android R for 11 and S for 12? And if so, is it safe to download the installation files for Android R for my device with 11.1.1.10.AC01BA on it and install them?

You are correct about Android versions e/OS + Android OS version names and numbers? - #3 by aibd

There is Oxygen Updater to help you update, discussed here https://community.oneplus.com/thread/1591794

And some more questions ;-). I do not understand this part of the installation guide:

Flashing additional partitions

Warning: This platform requires additional partitions to be flashed for recovery to work properly.The steps to flash the partitions are given below

Tip: In case the partition files are not available in the /e/OS recovery zip, users flashing the Android 13 or /e/OS T build, can try and download them from the LineageOS wiki install page specific to this device.

  1. First unzip the /e/OS Recovery file linked in the section marked Downloads for avicii . The following files would show up in the location where you unzipped the contents of the eRecovery zip file
  • dtbo.img
  • vbmeta.img
  1. Next we manually reboot into bootloader or download mode
  • With the device powered off
  • hold Volume Up + Volume Down + Power.
  1. Flash the downloaded image files to your device by typing (replace <...> with the actual filenames):
fastboot flash dtbo <dtbo>.img
fastboot flash vbmeta <vbmeta>.img

Am I correct in assuming that since I reverted to stock rom via de MSM tool, there are no partitions to be flashed? When I tried to install E OS on my own phone it went wrong because there appaerantly were 2 partitions, but after rolling bakc to stock rom via the MSM tool installation was a breeze and I did not flash different partitions. I think the above part was added to the guide later. Should I just ignore this part?

The instructions are a fit with improved packaging of the ROM which happened hand in hand with the introduction of Android 13 (T). These instructions were updated about August / September 2023.

Notice the different package resources on the more recent builds in the downloads page https://images.ecloud.global/dev/avicii/

No, the current /e/ ROM e-1.19.1-t-20240112373116-dev-avicii.zip + Recovery and boot img should be installed after correct preparation with correct dtbo.img and vbmeta.img

I read that thread before, but when I look in system updater it seemed to me it’s already working with Oxygen updater. I will look into it tomorrow.
Thanx for the help. Again.

OK, I updated to Andoid 12 with the help of the Andiod updater app.In the new Android version it is not very clear which version has been installed, but I found this in “About Device”: OxygenOS 12.1 AC2003_11_F.22. I hope that is the latest version. Unfortunately, I haven’t got the time to finish installing E OS because I’m giong on a holiday for two weeks, but afterwards I’ll be back to finish the project. Cheers.

Ok, I’m back and want to finish installing E… Now the devices I have have the latest security update for android 12 installed.

Downloaded the latest e-1.19.1-s-20240109372023-stable-avicii.zip file and extracted it. Then I flashed de dbto and vbmeta files with these commands:

fastboot flash dtbo dtbo-e-1.19.1-s-20240109372023-stable-avicii.img
fastboot flash vbmeta vbmeta-e-1.19.1-s-20240109372023-stable-avicii.img

That seemed to work:

C:\Platformtools\Oneplus\recovery-IMG-e-1.19.1-s-20240109372023-stable-avicii>fastboot flash dtbo dtbo-e-1.19.1-s-20240109372023-stable-avicii.img
Sending 'dtbo' (24576 KB)                          OKAY [  0.555s]
Writing 'dtbo'                                     OKAY [  0.095s]
Finished. Total time: 0.670s

C:\Platformtools\Oneplus\recovery-IMG-e-1.19.1-s-20240109372023-stable-avicii>fastboot flash vbmeta vbmeta-e-1.19.1-s-20240109372023-stable-avicii.img
Sending 'vbmeta' (8 KB)                            OKAY [  0.010s]
Writing 'vbmeta'                                   OKAY [  0.000s]
Finished. Total time: 0.020s

Then I flashed the recovery file and that seemed to work as well:

C:\Platformtools\Oneplus\recovery-IMG-e-1.19.1-s-20240109372023-stable-avicii>fastboot flash recovery recovery-e-1.19.1-s-20240109372023-stable-avicii.img
Sending 'recovery' (98304 KB)                      OKAY [  2.180s]
Writing 'recovery'                                 OKAY [  0.310s]
Finished. Total time: 2.508s

Started to get exited that it would work, but alas. I tried to reboot to recovery, but I could only reboot to bootloader. 
If I walk through the menu to "power off" and choose that by clicking the power button the screen turns 
black immediately, but I don't think it really powers off. When I use the power down and power off 
combination it restarts to bootloader. When in bootloader mode I navigate to "recovery mode" and choose 
that, I also return to bootlaoder mode.

The device is recognised in fastboot mode.

I wonder what went wrong this time? Did installing the recovery image fail? I got no failure notices. I hope
 there is some quick fix to this, because I have spent so much time already unbricking the devices and I
 was hoping installing E would work this time.

Looks like the device was bricked again. Whatever I did, it only returned to bootloader mode. So I used the MSM tool to revert to stock again. I’m glad that works fluently ;-).
Since this is appearently not working, is it a good idea to try the older version of Android 11 that worked before? I found threads in different forums that experienced a lot of difficulties with Android 12. I read that Oneplus and Oppo merged and they tried to merge the Oneplus and Oppo versions of Android, which is problematic. So I have the urge to stay away from Android 12.

One possibility, where recovery failed to boot is that the data partition is still “contaminated” by stuff from a previous Android version.

Two things would help rule that out. Factory reset after running MSM tool and running fastboot -w (again wipes data) before or after flashing recovery image.

Are you reluctant to go with Android 13 (T) ?

You are probably aware of all the helpful links off https://wiki.lineageos.org/devices/avicii/. Note that these pages are updated for Lineage 20 (… 13 … T).

Edit the pages today are updated for Lineage 21.

You must reboot direcly to recovery

1 Like