OnePlus X E1001

I tried to install the /e/ os on my OnePlus X.
I followed the instruction on this page :
First I had difficulties to install a recovery file : it did not work with the twrp files indicated. Finally I found on a forum the version twrp-3.0.2-0-onyx.img whih I could install.
Then I had difficulties installing the os with “adb sideload” (matters solved with this topic :
Now, after modifying the file " updater-script" it seems that the installation is ok when I launch “adb sideload …” but then I can’t reboot my phone.
Does somebody has the same problem or an idea of a solution ?
Thank you !

Hmm, okay - twrp-3.0.2-0-onyx.img is installed.

Now I would try to make a TWRP update to the current version 3.3.1-0.

This can be done with TWRP itself. Just use TWRP “Install” to integrate the twrp-3.3.1-0-onyx.img in the directory :black_medium_square:Recovery

TWRP Commando Wipe > Dalvik/Cache.

Now use TWRP “Install” to flash the /e/ OS-zip build

TWRP Commando Wipe > Dalvik/Cache.

Finally restart the phone. Try it out and tell us if it worked …

Thank you, I followed your method, but something dit not work :
First I updated the TWRP, then I deleted the cache and system
Then,I launched the “Install” through a terminal : “adb sideload”
While it was approximately at 49% it stopped. On the phone it was written
*" … *
detected filesystem ext4 for /dev/block/platform/msm_sdcc.1/by-name/system
script succeeded: result was [1.000000]"

I thought it was ok and tried to reboot (unless it was written “are you sure - no os installed” … : :confused: )

Now the phone is blocked : when I switch on I have or the 1+ logo or the fastboot mode launched. The matter is that my computer does not recognize the phone by “fastboot devices”. I don’t know what to do to launch TWRP again

Okay, this installation variant is usually a working alternative to the one I described. However, I already had a concrete ulterior motive when I suggested the “internal TWRP method”.

I read about adb & fastboot not working here in the forum over and over again.

Which operating system does your desktop PC use: macOS, Linux or Windows?

I am using Linux (Ubuntu)

It can be assumed that 49% cannot be OK!

Does ADB work on your Linux PC? Try the following terminal commands:

Plug your phone in and type “adb devices”. If it displays your phone’s serial number and says “device” next to it, you’re doing fine.

Then type “adb reboot bootloader”. It will bring you to where you are able to type fastboot commands. Type “fastboot devices”.

If it shows your device’s serial number and says “fastboot” next to it, then your Fastboot commands will work properly.

Yes I know about the 49% and the “no os installed” … I am beginner here and I understand now my mistakes … !

ADB works but not with this OnePlus X now - but it was ok before I starded reboot yesterday.

In “fastboot mode” on the screen of the smartphone I have :

Okay, I would start from scratch, so…

  1. Restart your Ubuntu PC (do not connect Phone OnePlus X to the PC)

  2. Now use the terminal window and enter the following commands in the correct order:

  • [sudo¹] add-apt-repository ppa:phablet-team/tools
  • [sudo¹] apt-get update
  • [sudo¹] apt-get install phablet-tools android-tools-adb android-tools-fastboot
  1. Connect your OnePlus X to the Ubuntu PC .The next command should show the unique ID number of your device:
  • [sudo¹] ] fastboot devices
  1. Now flash TWRP Recovery with the following command
  • [sudo¹] fastboot flash twrp-3.3.1-0-onyx.img (twrp-3.0.2-0-onyx.img)
  1. the flashing process takes a few seconds.

  2. When the installation is complete, disconnect the OnePlus X from the Ubuntu PC and press and hold the On/Off button to exit the Quick Start mode.

  3. TWRP Custom Recovery should now be installed on your OnePlus X

Note: [sudo¹] is not preferred by every user

I try
It seems that “phablet-tools” can’t be install anymore, “repo” is suggested to replace “phablet tools”.
Do I have totype “[sudo¹] apt-get install repo android-tools-adb android-tools-fastboot” ?

Maybe one update via »apt-get update« is enough?!

Since I don’t know which Ubunto edition they use, please try it. Not all editions of Ubuntu support all commands.

Ubuntu 19.10 x64 behaves differently than Ubuntu 17.10 32-bit version or elementary OS 5.1.

My Ubuntu 19.10 x64 edition accepts the following command …

$ sudo apt-get install android-tools-adb android-tools-fastboot

… and …

reads various package lists, builds a dependency tree, reads status information and installs a larger number of additional packages. Additionally a kB of archives are downloaded.

Thank you ! I succeded to launch the recovery.

Now I start again to update the recovery from 3.0.2-0 to 3.3.1-0.
When I do Install and I choose the file to install (the file is on the SD card) do I have to chose “Boot” or “Recovery” ?
I guess “Recovery” as you wrote in the directory Recovery. When I do that it seems to work :

Image to flash: ‘/external_sd/Image TWRP Delph/twrp-3.3.1-0-onyx.img’
Calculating restore details…

but the version is still 3.0.2-0. I tried to rebbot, still 3.2.2-0

Do you have an idea ?

Great! I’m happy for you.

Yes, select option © Recovery only!

Yeah, if twrp-3.0.2-0-onyx.img is installed - no reboot (!) but immediately in TWRP “Install” > twrp-3.3.1-0-onyx.img

Attention: Do not reboot in this case either, but …

  1. Disconnect the Ubunto PC,
  2. Then switch off the OnePlus X completely manually.

Now restart TWRP Recovery by pressing a key combination on the OnePlus X.

If TWRP 3.3.1-0 logo is displayed “Install” > /e/ OS-zip build

I recommend you to make a “Clean Install” including “Format data” via TWRP.

I keep my fingers crossed …

I tried, but I have still the 3.0.2-0 version … I am going on holidays tomorrow, I will continue later !

Well, I am back and hat time today to try again to install TWRP 3.3.1-0 without sucess … :frowning:

I can boot the TWRP 3.2.2-0 from by Ubuntu computer with fastboot boot twrp-3.0.2-0-onyx.img

Then I want to update from 3.2.2-0 version to 3.3.1-1, so on TWRP I do Install > I select the image file TWRP 3.3.1-0 > I chose recovery and Swipe. Then It is written :
Image to flash: ‘/external_sd/Image TWRP Delph/twrp-3.3.1-0-onyx.img’
Calculating restore details…

Then I disctonnect the Ubuntu PC, switch off the phone and restart by Power and volume - => the screen stay on a 1+ logo.

I believe I followed what Archie said, any idea ?

@DelphineMe, please read → here for the keyword “bootloader”. Maybe it will help you too …

Yes !! It helped a lot : I succeeded to install /e/
Thank you Archie :smiley:

That’s great, @DelphineMe :blush: Welcome to the /e/ club

1 Like