OP 8 pro (instantnoodlep) fingerprint scanner not working


yesterday I installed /e/ (20220629.022025 dev-keys)on my OP 8 pro. The fingerprint scanner is not working from the first boot on. When I try to add fingerprints, the scanner starts to light up, so it recognizes the touch, but it actually doesn’t scan the finger. The fingerprint symbol then stays lit until I either on/off the display or I press the home-button.

Is there a way to get the scanner working or is it still a wip-bug?

best regards

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

I use the OP8P as a backup device. Fingerprints haven’t been working since 1.0 came onto the scene. I ended up installing Lineage w/ MicroG on that device and then doing my best to recreate the /e/ suite of applications and settings.
It’s actually not a bad setup, I use Shelter to separate FOSS applications from proprietary ones, and having the Trebuchet launcher makes them much easier to access.

Hi HellsBells,
thanks for your quick reply. Today I also installed Lineage with MicroG and I think I’m going to stick to it - at least as long as /e/ OS for the OP8 pro is still a nightly.


I opened a bug ticker regarding this issue:

Feel free to catch logs of the issue after it occurs using one of the following methods, and to share it in a comment on the bug ticket:

Hi guys,
Is it a problem that every OP8 Pro encounters or is it only few people ?
I have seen that some people have this kind of issue after using a boot.img that is not exactly for their model. Since there is different model for regions, maybe it could be the issue on that point ?
I am personnaly form France and have a IN2023 model which I consider to use on eOS (not a huge fan of OOS12 which is losing lot of feature that I appreciated on OOS11)

Deleted content – sorry reading wrong model. :blush:

So we read https://doc.e.foundation/devices/instantnoodle scroll to the bottom of the page for supported models and I came to wrong answer.

And I am talking about OnePlus 8 PRO which models supported are :

Models Supported

  • IN2020
  • IN2023
  • IN2025
    Other models are not supported

It is because of those different models compatibility that I suggest to confirm which models are concerned with that fingerprint issue. Maybe one of them are using a 100% compatible boot.img so FP cna work on this type but not on others.

Again , that theory is based on other topics I’ve seen which were talking about rooting method for this device, using magisk patch boot.img file to get root or flashing it differently

1 Like

Just tried to install eOS on my OP8Pro using easy installer and I can confirm that fingerprint is still not working :frowning: I will revert back to stock ROM then but still disappointed to see that update are still coming while this issue stay active.

Hi guys,
Just installed E/OS on my OP8 Pro today with easyinstaler and still the issue appear with the finger print :confused:
(e/os 1.12.3-520230614299637-stable-instantnoodlep)

Do any fix is planned to correct the finger print issue in the next months ?

Thank you in advance,