Opencamera Pano mode broken

Hi,

Is Panoramic mode working for you?
Everything is working correctly but when Open camera tries to save the picture it crashes and the picture is never saved.

I am surprised I am the only one with this issue?
Forgot to mention I am running /e/ on Mi8

I have never seen a “Panorama” or “Pano” mention in my Open Camera app so I just recently learned that it was possible in Open Camera. Not for me obviously.

Si you got the same issue?

I don’t see any panorama mode.

I found it and just tried it, it works for me :slight_smile:

I know that there are some features that are in Open Camera code (I saw all the strings in WebLate) but they are not available on my phone.
Don’t know why my phone couldn’t do panorama though.

I don’t have Noise Reduction (NR) either.

Which phone is it you have? Do you have camera2-API?

Galaxy J5 2015 and no I don’t have Camera2 API, which is probably the reason why indeed.

According to Mark (developer of OpenCamera) on the OpenCamera forum The technical requirement is needing at least 256MB of “large heap” (and Android 5+, and gyro sensors). Open Camera shows the available large heap in Settings/About.. So the feature seems to depend from the device.

2 Likes

On my side, all the pano mode is working fine (following the blue dots ) but when I hit the check button I see ‘processing’ and OpenCamera crashes

How long do you wait before checking? For me it tells me in some command which images it is processing and also when it is done :slight_smile:

Not sure I got your point. I am following the workflow and following the blue dots and let’s say that after 3 blue dots I want to finish , I click on the checkmark below and this is where I got the “processing message” and straight after that OC crashes. Do I miss something or do you do something different ?

Hmm i guess for me it just works… Just tested it the way you do it and no crashes… Are you on official rom? On which version number of /e/ and which android version?
EDIT: on my redmi note 4x which i use for testing purposes it crashes aswell…

Yes on latest official build (0.82020041649926) basée on Android 9.
Same issue on all builds so far

Hi all.
I have the same problem.
I have tried the Pano mode and after 3 or 4 pictures, when clicking on the check button, appli works then crashes. Each time and no picture is added in Gallery.
In App, I have downloaded Open Camera. When I use that one, panoramic photos are working. I have the picture in Gallery.
My FP3 is running with /e/OS 0.9-2020042851613.

@PKT many thanks ! I haven’t think about that and yes the new version 1.48.1 is solving the issue, it is definitively a bug into the default version used inside /e/.

2 Likes