OS think's I'm offline even though i'm not - captive portal server?


I use /e/OS / Android 11 on my FP3+
Besides that I really should upgrade the OS, since today my mobile as well as my wifi connection both state that the device is not connected to the internet. However: I’m online and can use my browser as well as messengers without any problems.
Some apps, however, won’t work as long as the device won’t state a proper online status.

After some research I found a thread that says I might could fix that by changing the “captive portal server”.

I used thermux to get the current server set and got “null” as a return, as expected as a default.

So, before I look for alternative captive portal servers I thought someone here might as a tip - or other troubleshooting threads for me?

I mean: Obviously I don’t want to put “google.com” there :wink:


Regain your privacy! Adopt /e/OS the deGoogled mobile OS and online servicesphone

1 Like

I fixed it by updating my /e/OS from 1.x to 2.0

0 - Backup data
I simply export contacts, messenger chats etc “locally” to my phone and run adb pull /storage/* <targetpath> and note down passwords, if required, to a sheet of paper

1 - fastboot

2 - Download the latest stable build (for FP3+ follow this link: https://images.ecloud.global/stable/FP3/)

3 - unzip the just downloaded archive

3.1 - open the install script flash_FP3_factory.sh, search for oem lock and just remove that line

4 - chmod +x flash_FP3_factory.sh and run it

4.1 - just hit enter when asked if data should be wiped (otherwise follow instructions to wipe data)

5 - Wait till done & reboot

(6 - Burn the sheet of paper with the passwords as soon as you don’t need it anymore)

Even though I successfully updated without any data loss and kept root that way, ALWAYS backup your data BEFORE flashing anything


So this is the only solution?
This seems too complicated for me…
I did try to make a start by doing a back-up of my whatsapp but that doesn’t even work. In an act of desperation I want to back up my whatsapp to a google account. When choosing for a google account to make a back up, there is an error. I give my gmail and it says this account already exists on this phone and I can’t go any further. But it specifically says that you have to enter an existing account…
But other than that I don’t even know how to do step 0.
Is there another way this can be fixed?

As I just saw on Twitter/X: They’re hosting a live stream right now celebrating the /e/OS 2.0 launch.

So my best guess here is that the issue with the offline-status has something todo with that, as they might setup / upgrade some service servers.

So there’s pretty much just 3 “solutions”:

  • just wait till the issue resolves itself, maybe it’s fixed by the end of the week
  • wait for an update for your device to appaer as a usual system update
  • update it yourself, either manual as I described above or by using the “easy-installer”. Just check out https://e.foundation for further info
1 Like

Thank you! Fingers corssed it will be fixed because the last update was April 2022, not expecting anything any time soon…

1 Like

This is something to fix, you should be getting updates nearly every month! What is your build and version string?

A similar date features in this reply.

The phone saying no internet, even when wifi is working alone is just annoying.
However, some apps are not working because the os “thinks” i am offline.
Most annoyingly, my app store will not perform any updates or install new software.

I was using neostore and could not figure out how to solve the problem from the app settings. Installing fdroid enabled me to update.
Mobile internet was turned off the entire time😃

Oh thanks! I was not aware of this! It does explain a lot, damn…
I have a Fairphone 3, /e/OS 0.23-20220412177701 (Android 9)
So I have to install /e/OS like a new? The back up part is already confusing. The last time I tried nextcloud I was super confused. I will try again (I am recovering from brain injury).
If I back up my phone to a laptop, can I restore my whatsapp after I install /e/OS again?

Yes, I am afraid that is the way to go, please consider a method on the linked thread, How do I upgrade from Android version 9 to a higher major version? - #2 by aibd.

  • (Feel free to continue there with further issues as you may get better visibility to your upgrade issue than on this thread.)

Many guides advocate a whole system backup, so this becomes extra confusing. I prefer to have several means of backup. If you use Mumena ecloud successfully, then quite a lot is already backed up. (That is to say that the things you see from your PC are already backed up there.)

The support topic guide https://doc.e.foundation/support-topics/backup-and-restore-ephone takes as its starting position the things you may regard as most important.

As you will be potentially making a big jump in Android version from Android 9 (P) to Android 13 (T), it might be useful to install List My Apps, de.onyxbits.listmyapps. Save to output somewhere easily read and edited like your PC. Now be harsh in preparing to uninstall all apps where you really could do without their data after the Factory reset. Also check if any apps you need offer an option to “Export data”. I feel the tangibility of an Exported file a most useful form of backup.

Sorry I am not a Whatsapp user, but I think this may be your hardest bit! I include this link, while quite old I hope it describes (as I understand it) the permission issue you will face and the apparent need to have your restored material on your new system, before reinstalling Whatsapp and logging in. https://android.stackexchange.com/questions/150071/how-to-manually-transfer-entire-whatsapp-installation-to-another-device-the-har .

There is this [HOWTO] Transfer WhatsApp messages from Google Android to /e/ (backup and restore)

And of course Search forum for backup.

If you do use Nextcloud there is this method Whatsapp backup - #11 by daan-banaan. As a “backup alternative” you might experiment with https://itsfoss.com/whatsapp-linux-desktop/.

1 Like

same problem here with Fairphone 3, Android 11, /e/ OS 1.8.1.
But - like probably many other users - I am not able to “flash” my phone.
Will the update to 2.0 NOT be included in the list of available updates soon?

I have not looked up the answer but this will depend whether your phone has a dev (community) build or a stable (official) build.

Only the stable versions receive OTA Android version Upgrade.

While dev builds stop updating the /e/OS version when an Android version change happens and the user has to do a manual upgrade of Android version.

You can see dev or stable in the version string found in Settings > About phone > tap on Android version > Long press on /e/OS version to “copy to clipboard”.

1 Like

Hi guys, this issue is bothering me quite a bit as my work and private calendars no longer sync. It makes planning any new appointments a hassle.
As there were no problems before and no updates at my end, I assume this is a back end problem, maybe bought about to make /eos/ 2.0 work better.
Does anyone know when or if there is likely to be a fix for those of us unable to update?

In this German topic it’s mentioned that an update fixing this problem has been received:


Hi, all! I was able to resolve the issue by going into Settings and applying the 1.8.1 update (Feb 2023). :slightly_smiling_face:

1 Like

In order to troubleshoot which “older builds” are affected it would be useful to know your build and version string as given in Settings > About phone > Tap on Android version > Long press on /e/OS version to copy to clipboard.


1 Like

I am not suffering from this issue but I notice that on an Android 13 (T) build the system app CaptivePortalLogin does not exist, while it is present in my Android 11 (R) phone.

As a test (on R) I went to Settings > Apps and notifications > See all … apps > Top right 3 dot menu, Show system > CaptivePortalLogin

and disabled the app. Despite a warning that the phone may not work as intended, the phone seems ok in a short test.

If you were to try this disabling of CaptivePortalLogin does it have any effect? Does it seem connected with the problem?

1 Like

No offence @aibd but i tried what you said despite copying what strangers on the internet say not being a good idea.
“Disable” was greyed out so i hit “force stop”. After that both buttons were no longer greyed out, but pressing them did not seem to do anything. I restarted the phone, but the buttons still do not do anything.
Nothing seems to have changed for the better or worse.

Update: there was a negative consequence.
Before the change, it was possible to connect to open networks like at the train station or some businesses. For these networks the internet behaved normally. The last couple of days i have used them to sync my cals and update an app or two if possible.
Since making the change @aibd suggested, this is no longer working. CaptivePortalLogin still shows “disable” and “force stop”.
Any idea how i can re-enable it?
My keyboard is also misbehaving. Is this coincidence, or could it be related? Specifically, swipe typing and word suggestions no longer work.