OTA updater not working, how I fixed

For the last two updates I have not been able to get the OTA updater (Updater in settings) to show me the new version.
The first time I got to work I cleared an item cache/clear storage but I couldn’t remember which App cache.That was going from v1.2.3 to 1.3.

I have the same problem this time going from 1.3 to 1.4 eOS but I found where I think I did it, at least this worked:

Go to Setting>Apps>See all xx Apps (xx is number of app on phone)>Android Keyboard (ASOP)>Storage and cache and I cleared both storage and cache.

Exit or back out to: Settings>Updater then did a refresh and the 1.14 update is now available. Hope this helps someone if not covered already.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

You just need to refresh the updater a few times if the update doesn’t appear from the first time. (sometimes 4/5 times)

No need to clear the data/cache of a particular app. It was probably just a coincidence that the update popped up for you after that.


I made several refresh in a row over a number of days in the range of 100s of refresh and no update. I’m sure I am not the only one to experience this issue.

OTA updates previous to about eOS 1.2 what you said was true.

Phone is a Google Pixel 4a5G, bramble.

Do you still rememeber …?

This system response sounds to me like the recovery is still not managing the update correctly.

One possibility would be to test whether a manual update is successful:

Download e-1.14-s-20230818321663-dev-bramble.zip. Then boot into the e-Recovery > Apply update > Apply from ADB

Please note:
This is just an idea. I’ve not been running the /e/OS since the above ‘bramble’ OTA update bug and wish that the problem would be solved at the latest with the upgrade to /e/OS ‘T’ in September 2023.

This topic was automatically closed after 60 days. New replies are no longer allowed.