Phone encryption not working - LeEco 2

Hello,

This is my first post here as I’ve recently purchased a LeEco 2 and installed /e/. So far it’s been brilliant, and I’m enjoying the changes that it has brought with it (both having a modern phone and the OS).

I’m failing to get the phone encrypted, which is an important feature for me. Once I’ve selected the encryption option in the 'security section of the preferences, I briefly see the correct image (this isn’t mine - I get nowhere near 4%) - for under a second - then the phone reboots.

It’s charged, running the latest nightly, and the latest TWRP. It hasn’t been rooted, and Developer Options are turned on If anybody has suggestions on how to successfully encrypt the phone, it’d be great to hear them, please.

Maybe create an issue here:


Had a similar problem on FP2

1 Like

I managed to encrypt my test leeco s2, but that was using e V0.2 (oreo). I assume you use V0.1?. I did have a hard time to un-encrypt it again :(. I can send you a link to 0.2 but i have no experience with encryption, so i don’t know if everything is ok. I could not see yj pattern when unlocking the phone for instance, is this a safety feature? When you boot the phone you have to give your pattern before android boots, i guess thats normal behavior? I could not reset the device to not encrypted using TWPR, so i had to flash recover factory image…

2 Likes

For FP2 there is no /e/ V0.2 so far… I’m waiting…

Thanks for your responses, everyone. At least I know it’s not just me. Will file a bug report.

1 Like

I tried encrypting my LeEco 2 and not working, just reboots and still ‘not encrypted’.Running v0.7-p-20200118 (Jan 18, 2020 Pie). It’s fully charged, rooted, with TWRP 331. Tried several times to encrypt, same result…not encrypted. I even did a device reset to see if that would enable to encrypt…nope.

Has this issue been resolved? Is there a workaround for LeEco 2? Has anyone encrypted their LeEco 2? Thanks

You have 2 options:
1.) Advanced wipe, wipe every partition. reinstall /e/.
2.) follow the steps in this topic, data will remain.

1 Like

ok so I took option 1. and several attempts, but it finally worked.

I also did a data partition resize from the wipe menu because it was just rebooting. after I did a data partition resize and retired to do encryption again, then it worked.

so thank for the info.

Sorry, I forgot to post a response. Yes, I’ve been able to successfully encrypt my phone - without having to wipe any data from it, as andrelam has indicated. Resizing the partition to make it four blocks smaller is all it took.

Thanks, Andrelam!