Fairphone 2 (FP2) workaround

Someone gave this tip already in short on Telegram, but it wasn’t really clear at the time how to do this.
After installing /e/ on FP2 it seemed impossible to shutdown the device by long press the power-button and then “power off”, it just reboots. Also encrypting the device didn’t work; it just rebooted and remained not encrypted.
The workaround is simple:
Settings > buttons, under Power menu enable “Long press for torch”
So when the display is off, light up the torch with a long press, and with the torch on put the display back on with a short press on the power button. That allows to shutdown the phone: long press again and power off.
The same procedure for encrypting: display off, long press and torch on, display back on and encrypt the phone while the torch is on.
That’s how simple it was. Why it is so important to me to power off the phone? Visiting live classical music concerts, live poetry sessions and in theater it is really not done to leave your phone on.


This bug stays unsolved. Is a solution so difficult to find?

I believe flashing the latest modem file should fix it. I’m not 100% though as I still have the old camera module, so I was never affected by the bug.

1 Like

Bug remains unsolved.

Oh yeah sorry, it seems the fix is not integrated in the modem file, but the OS itself, so it will have to be added to /e/ by the developers. At least according to the Lineage bugtracker it seems the fix was integrated into LOS.

1 Like

Checking with @rhunault if the LOS patch was integrated in the /e/ builds. We will add the fix into the build if not already done.


Yes the patch was integrated in LOS, but on oreo branch (lineage-15.1). On our side, we are still using nougat branch for FP2 (waiting for a solution to do migration from nougat to oreo via OTA updates).


Not solved yet with the latest build installed on my Fairphone

On a FP2 (with new camera model) running a self-built/unofficial Oreo version

I couldn’t reproduce the issue (i.e. the device always did shut down on various attempts).
So I think there is hope. :slight_smile:

1 Like

Is such a solution foreseen you think? just asking. I’m not an expert.

We will work on it ASAP!

1 Like

Hi the original fairphone os nougat 7.1.2 has the exact same issue. I have two identical fp2 one with eos and the other with unchanged fos they both have very often random reboot issues at shutdown. Updates installs clearing cache removing some apps sometimes solves temporarily the problem. I still couldn’t figure out what causes and cures the issue.
Regards everyone

7.1.2 is the Android version. Which Fairphone OS version are you referring to? The current version FPOS 19.05.3?

It is indeed the fos build 19.05.3.
I forgot to mention it.


1 Like

Have you tried unofficial /e/ oreo or pie builds if they solve your issue?

1 Like

@ff2u Would an oreo/pie build of e work on a nougat Android? Maybe i missed something
Related question : is an Android nougat upgradable (or downgradable) toward another version?
I work hard on the Android question since i started supporting e but i feel like a beginner still…
Anyway could this reboot thing be a hardware issue of the fp2?

If your data partition is not encrypted then I assume updating from nougat to oreo or pie will work without wiping all data (more details).

But keep in mind that (currently) the only official (including OTA updates) /e/ versión for FP2 is the nougat version.

Yes and no.
Yes: it only happens when the “new” camera model is installed in the FP2. It does not happen with the original model. So it’s related to HW.
No: As it’s a driver issue it can be (and was) solved via software fix. So it can be fixed via SW.

@Louis, @rhunault on Fairphone OS Nougat there is a fix from what I’ve been told here:

Now we need it on /e/.
No idea why it hasn’t been done yet.

I think it’d be better to have a pie based official /e/ versión for FP2 than to backport the fix to nougat.

1 Like

Fine. I just requested it here: