"Please install Crypto.com App in Play store"

Hi !

I was using the app “Crypto.com” : it is like a neobank with a PrepaidCard with crypto on it, etc.
I know banking apps sometimes don’t work well with /e/, but this one was okay. But since 2 days ago, it’s not ! When I launch the app I just see the system message (on a gray temporary popup) “Please install Crypto.com App in Play store”.

The app was installed with Aurora. Would anyone know if there’s a way to bypass this problem ?
Thanks a a lot.


I’d like to know if there is a solution. I have the same issue.

1 Like

Yeah I’m also curious as to how an app can work fine then suddenly stop (I imagine this implies the app developer has inserted code to do that unless we have updated /e/)

Is there any update will anything be done?

damn I just deGoogled my phone as I saw this was on the list of working apps and now I can’t open it as it gets the “install app in play store” error. As they don’t have a web-app I’m kind of stuck. Quite annoying!

I’m going to hazard a guess at the problem being with MicroG not imitating Google Play Services properly? I have only just installed /e/ and the version of MicroG on my phone is 2.17 (released Jan 21: https://github.com/microg/GmsCore/releases). There has been a couple of new updates to it since then so I’m wondering if updating it will fix this problem. I don’t want to break my phone trying to do it though. Anyone else want to try first? xD

I could try this tomorrow on a spare device.

MicroG on eOS 0.16-q is still v0.2.17 and Crypto app will not open (same “install in play store” message )

On another device that has MicroG v0.2.18 running on LOS for MicroG 18.1 (Android 11), crypto app not working.

eOS version 0.17 which is currently in testing is reported as having “MicroG specific fixes”, so that may help.

It also looks like in version 0.17 MicroG will be updated to the latest : v0.2.19.211515

I read somewhere recently that apps installed through aurora should not be updated through any other app (e.g. /e/'s apps app) and vice versa.

Recently, however, I did try upgrading brave browser via the stock /e/ apps app, and my app icon went missing and wouldn’t even open from within that app (open button simy non responsive), although bin oils are the app still in my phones app settings; I downloaded ffupdater from fdroid, updated brave, and it opened with my state intact…

Sooooo I guess careful how you update?

I tried installing Brave through the /e/ app store on my fresh install of eOS and had the same problem. I uninstalled it and then installed it via Aurora instead and it worked just fine. Something wrong with the version on the /e/ store it would seem!

1 Like

So I just updated eOS which now has microG 2.19 but the crypto.com app still doesn’t work :frowning:

Yes, looks like you’re out of luck with that app. It just won’t start up with microg. Same on another device with android 11 + microg.

It’s full of trackers by the way!

I don’t know anything about this app or crypto currency etc, but noticed similar apps on aurora store. Crypto.com|DeFi Wallet seems to work. I guess it may be no use to you though.

I described the solution in the following gitlab ticket:

Root access needed in order to choose the “Root” installation method in Aurora Store instead of the “Native” one.

1 Like

Thanks this worked for me. I used TrackerControl to block all of the trackers and the app still works so that’s great too!


This Gitlab issue does not seem to exist anymore; could you share the solution you had?
Thank you!

Hi there, I can’t find a solution.
The previously refered to ticket no longer exists…
I tried installing the “Identite Numerique” App while logged with a Gmail account on Aurora, but it failed. The App wouln’t launch, and I have the message “you must install the app throught Google Play”…
Someone to help ?

I have the same problem with the LibreLink app from Abbott.

I have App Manager installed. Is there a way to use it to modify the app manifest somehow?

Wayback machine to the rescue

But he also summarized the gist:

This fixes it for me. (Verify that in the “App info” it says installed from fake store)

Just wanted to report, that on my FP5 with /e/OS (v1.17) and rooted with Magisk (version 26.4, having enabled hiding, zygote and added the app to the DenyList)
→ the Apps (both, crypto.com and the defi wallet) start and provide me a login (or the ability to create new accounts/wallets).

So, on the first look it seems to work. I’ll probably report back when I am logged in as well. But I am not sure if I am just creating new accounts/wallets and test for a while (so in the case of something bad happening my actual accounts/wallets don’t get compromised).

Add: And I’ve downloaded and installed it through /e/'s App Lounge Store.
Add: The defi wallet can restore a wallet properly and shows the expected balance… (don’t know tho if transactions also work - still testing)

This topic was automatically closed after 11 days. New replies are no longer allowed.