Problem with e installation on Samsung galaxy S10+

I have tried to install /e/OS on my new Samsung Galaxy S10+ (SM-G975F/DS) exactly following the description.

Info about Samsung Galaxy S10+ - beyond2lte –

I am stuck with loading the recovery (tested adb & sd card). The md5 of the img and zip are correct.
This ist the zip I used.

The screenshot shows the error message.

Can anybody help me please?

Hope that someone more knowledgeable would step in (aibd ?!). I have 0 experience with installing with the sdcard since I find using the adb and cable transfer very simple.

Most of the problems with Samsung phones come after the writing of /E/ OS recovery because the phone reboots automatically and if you don’t pres the right key combination the phones erases the /E/ OS recovery.

Your problem seem different though. Good luck!

Thanks for your feedback. To clarify this a bit, I used the normal procedure in the beginning. This means via ADB and the cable that didn’t work and gave the same error message. And my second attempt was by using the SD card as a desperate attempt, of course.

Ok, I’ve seen that, but thought you wanted to use the SD card approach.
You should try a different cable/different port.
Did you manage to install /E/ OS recovery and you are performing the writing of /E/ OS zip from the recovery?

Alright, my description of the issue is a bit confusing, I guess. So sorry for that confusion.

Anyway, I will definitely try a different cable. I had an issue in the past when I was installing /e/OS on my S9+.

I indeed installed the /e/OS recovery and then performed the writing of the /e/OS zip from the recovery.

Furthermore, I also paid attention to the fact that the device should not boot in between. So it was turned off, and I immediately used volume up + Bixby + power to get into the recovery mode.

The interesting part of the error message is that it “failed to verify the whole-file signature”. I think this is a hint that I need to follow somehow.

Thank you for clarifying the situation…
You could try to install 1.18 and then update to 1.19 (or wait for 1.20)

As a side note I also have a S9+ (I’m using it now with my company SIM) and a S10+ on original ROM that I was using for taking pictures (got recently a Note20 for that purpose).
I had no problem flashing S9+ directly with 1.19T… I always use a smaller (~40 cm) very good quality cable (Gopro) to perform flashing…

1 Like

Sorry, once again, I should have mentioned that. I also tried to install version 1.18, where the same error message came.

I do not suspect (hope) that it is the ROMs themselves, but the cause is to be searched elsewhere.

If I understand correctly, the signature for a file is something different than the MD5 sum.

Seeing that the T version should come with 1.20 I would wait (if you can=have another working phone)


I would advise you to :
-try another cable
-follow this guide [HOWTO] Install /e/ on a Samsung smartphone with Windows easily - #175 by sex
-if not working, follow this guide

1 Like

I have another smartphone that I can use. I’m just asking if I prefer to send back the new one or keep it.
But I think I shouldn’t take any risks with the smartphone. I looked again phone infor (Settings …) to see if I have the right model, which I do have.
As described in this forum post (Samsung - Galaxy S10+ - beyond2lte - Documentation Suggestions - #9 by Xenthos), this must be the SM-G975F/DS.

Hello, thank you for the answer. I will try.

Someone had a similar problem recently (can’t remember on which phone) and the cable/port was the culprit…

Then again someone had the same issue as you with a S10 recently: /e/OS Installation: Signature verification failed (error: 21)

Thank you very much. Then I can only hope that it is really the cable.

If it is the second report, then of course I have a problem.

I would like to ask a short question at this point. Does the recovery look like in the image?
If yes, it could be that the error could be right there, because I don’t see this picture. But for me it looks much more like a line interface with several entries in blue.

If that were the reason, it would also be clear why the signature cannot be verified. I assume that the recovery tool of /e/ does exactly that, and I probably end up with the one from Samsung, which it just can’t do.

E: Signature verification failed
E: error: 21

Is not itself a problem …

Install from ADB completed with status 2.
Installation aborted.

Is the point of failure … as if the recovery is wrong / non-functional in some way.

But now your image of e-recovery is e-recovery but why is it showing version 0.14 ?. [1]

I think I would be going back to reinstall recovery, and double checking all pre-install instructions at the same time. Ensure your battery level is at over 60%-70% at all times.

Was the phone newly delivered to you ? Had you had it online (and preferably with a SIM card) to have the phone make some connection with Samsung remote monitoring ? (I always think that instructions are written from the point of view that you have had the phone in normal use for a minimum of 7 days before attempting a Custom ROM). Hence the reason for

[1] Edit I am not a user of e-recovery, perhaps someone could chip in with current version numbering seen on their phone

Yes, /E/ Recovery is like in the picture… If you don’t see it then you don’t have /E/ Recovery installed… and I suppose you try to install the /E/ OS ROM using the original phone recovery… which of course doesn’t recognize the ROM…

And then you get to my first post:
"Most of the problems with Samsung phones come after the writing of /E/ OS recovery because the phone reboots automatically and if you don’t pres the right key combination the phones erases the /E/ OS recovery. "

On flashing my S9+ I had to repeat the flash of /E/ recovery at least 4 times (and I’m quick)…

Wonderful! Then I have exactly two good points to start from. On the one hand the cable that I will test and then of course the e-recovery, which will be the probable explanation for the problem. I’ll get back to you when I get there. Thanks!

I’m sorry that I wasted some of your time here too. I got the picture from the forum, where “my” (similar) problem was described by another user. From there I got the “version 0.14” picture.

I think @Cooler was right, and I started the Samsung stock recovery instead of the /e/ recovery. :man_facepalming:

I have to look again more closely if I really get the ROM transferred to the smartphone.

I will report.

That’s all quite complicated. If I think about it, I have installed /e/OS and other custom ROMs on Samsung S4, S6 edge, S8+ and S9+. So far, I have always managed to do it. I am confident, with all your help, I will somehow manage it again.

S10 series is not covered by this well but old howto where the step about flashing “vbmeta.img” along with “recovery.img” is missing.

Do you use Linux, Windows or macOS ?