Problems recovery S5 with ubuntu

I tried many times but I dont manage to get the recovery on the phone. I have Ubuntu 20.04.1 LTS and a samsung SM-A500H
the first time when I tried it I didnt have activated the debugging mode but after activating it, nothing changed, I still get the same errors. I have a proper cable, at least the phone shows up as a device when I plug it.
hope you can help me!! I dindnt find a forum or somewhere else

I put in command: sudo heimdall flash --RECOVERY twrp-3.3.1-1-a5y17lte.img.tar --no-reboot

Heimdall v1.4.2

Copyright © 2010-2017 Benjamin Dobell, Glass Echidna

This software is provided free of charge. Copying and redistribution is

If you appreciate this software and you would like to support future
development please consider donating:

Initialising connection…
Detecting device…
Claiming interface…
Setting up interface…

Initialising protocol…
Protocol initialisation successful.

Beginning session…

Some devices may take up to 2 minutes to respond.
Please be patient!

Session begun.

Downloading device’s PIT file…
PIT file download successful.

Uploading RECOVERY
ERROR: Failed to confirm end of file transfer sequence!
ERROR: RECOVERY upload failed!

Ending session…
Releasing device interface…

Hi, I hope we can help :slight_smile:
First thing to rule out, is your Samsung still locked in some Samsung way?

If you think this might be the case, please share a photo of the tiny text at the top of your Downloading mode screen, if that is possible, thanks.

In the title you talk about a Galaxy s5

In the text, You say you have a Galaxy a5(2015)

which Is the command for the Galaxy a5(2017)

ah sorry it says model number samsung SM-A500-H

when i am in the download mode the text up left says:

ODIN MODE(in red
AP SWAEV: S1, T1, H1, R1, A1, P1 (in grey)

So have you successfully flashed it before? If so what with? :slight_smile:

I think you need to unpack this file. Inside should be a *.img file. Flashing that should work.

Also had this happen to me.

Initialising connection…
Detecting device…
Claiming interface…
Setting up interface…

Initialising protocol…
ERROR: Protocol initialisation failed!

Releasing device interface…

I unpacked the twrp-3.5.0_9-0-a5xelte.img.tar file, and tried to flash with the recovery.img that is inside

umm well so far I succeded to to the step before where I install heimdall and the phone reboots. besides that nothing worked

SM-A500H is not on our list, is it?

1 Like

it is not, you are right, shit. I didnt think there where A5 that didnt work.

You will be able to recover the phone with a LineageOS, was just checking…
If you boot into recovery you will be able to read the device code for sure, in the format a5x?elte

It is still working on the normal system right now.
on the lineage page for that phone is not beneath the supported models, no?

I dont understand what it means do read the device code

It was an [UNOFFICIAL] that came up in a search.

Maybe you cannot boot into Recovery mode? I was just meaning you now want to know the device code for sure. :slight_smile:

I would really like to install another system on that phone. can you send me the link via the unofficial version?

i can boot into recovery

ah sory didtn see you posted the link already!! so I get their twrp and do everything as in the official manual?

Sounds good - you are ok with how to double check the device code?

no I have no idea what it means

When you looked on “our list” above, you would have seen, for instance: a5xelte -->> SM-A510F
a5xelte is the device code for that phone! Just in case your install becomes problematic, you want to know you have the right device code this time? :slight_smile:

yeh tell me if you know it or tell me how to find it out pls :wink:

When you boot into recovery, do you see it written there?

:warning: Also, that link was a very brief search, when I did not have your reliable device code! I would do a bit more searching, when you have the device code! :smiley:
Edit the device code in my link is