Problems with Account Manager after Update 0.6-2019053111832

After installing the Update 0.6-2019053111832 I can not sync my FP2 with my owncloud at home.
It seams that the Account Manager needs more permissions. The Changelog shows, that the Account Manager has been updated. Went there something wrong?
Best regards - Lipo

go in to settings -> apps -> show system -> account manager -> permissions

allow calendar and contacts and in my case tasks and it all should work again.

When I updated and also set permissions it still wouldn’t sync. Rebooted just in case but still no go. After awhile the /e/ Address Book disappeared from the Accounts section in Settings. When I tried to re-add my account it said it was already present.
Failing to sync I just removed and readded the account. All was good after that.

You are right, just checked and there were no address book. Had to remove and add my account again. Well, now it works.


Had the same issue.
Thanks for sharing the workaround

Had the same issue on my Nexus 5, and removing / re-adding the account fixed it :+1:

For me removing / re-adding the account does not work, the problem persists (moto g4). Is there already a gitlab ticket for this?

Hi All,
removing / re-adding the account (WebDAV) works fine for me. FP2 --> Owncloud
Thank you for answering!

@isa You are correct about this misleading redirect. Can you please create a new issue for this improvement?

Hi, I apologise for the inconvenience the latest update has caused. To get your Contacts, Calendar, Tasks, etc. to sync again, please do the following:

On Oreo versions of /e/:

  1. Remove your /e/ account (system Settings > Users & accounts > [your /e/ account] > Remove account)
  2. Add your /e/ account back (system Settings > Users & accounts > Add account > /e/)

On Nougat versions of /e/:

  1. Remove your /e/ account (system Settings > Accounts > /e/ > [your /e/ account] > 3 dot menu > Remove account)
  2. Add your /e/ account back (system Settings > Accounts > Add account > /e/)
  3. If you get a notification requesting some permissions, click on it and grant all requested permissions

@nihar1024 And if I don’t do anything will it be automatically fixed at the next update ?
I’m afraid to lose some data from my own nextcloud instance
(Essential with 7.1.2)

Hi, you will need to perform the steps mentioned above to get your data to sync again.

Regarding your concern, why would you lose any data? All your data should simply sync to your device again.

1 Like

Thanks @nihar1024, I experienced the same issue on my OPO. Following the steps you provided, the account started to sync correctly again and the permission switches appears also as they should.



It finally works after removing many times my accounts and installing DAVx5 and using it instead of DAVdroid

I take it you’re talking about a non-/e/ setup? Kind of confused since /e/'s account manager is based on / is a fork of DAVx5/DAVdroid.
Sorry, I got lost somewhere. :confused:

@marcdw I’m also lost somewhere
After removing many times my account (on the /e/ phone) I still couldn’t have a synchronization (Adress book & Agenda) with my own Nextcloud instance (cloud). And the Nextcloud App (on the phone) was telling me to install DAVx5. What I did
I hope next /e/ update won’t bring chaos !

I was able to access address book & agenda, that is hosted on my own Nextcloud instance without installing additional apps; for that I used the “WebDAV” account, that comes with /e/ preinstalled.
During the setup I had to select “Login with URL and user name”.

Yes @Markus that’s what I’ve expected and tried. But it was not working. What do you think, remove DAVx5 before next /e/ update ?

What errormessages did you get?
Did you use the correct URL? You can find it in the Nextcloud-web interface.
Nextcloud -> Calendar -> Settings & Imports (lower left corner) -> Primary CalDAV Address

Unfortunately I have no experience with DAVx5 and can not answer the question, but if you manage to access Nextcloud without it, you might as well deinstall it.

Thank you @Markus, I know that because I synchronize with other devices. The important think to know for me is that

/e/'s account manager is based on / is a fork of DAVx5/DAVdroid.

I’ll remove DAVx5 before next update