Problems with Wileyfox Swift (crackling)

Hello to all.
I’m new to the forum and /e/, as well as fairly new to flashing custom roms.
Nevertheless I took the plunge this morning. I flashed TWRP on my phone. so far, so good, but the moment I booted into recovery my pc and phone weren’t connected anymore. When I power off and on again, the phone is in fastboot mode, typing the command fastboot devices returns 81dac254 fastboot, but adb devices returns an empty list. When I’m in Recovery mode and give in the command adb push / sdcard/ it returns error: device not found. (I did replace filename by the actual filename)

I then copied the zip-file to the sd-card on my pc, then placed it back in the phone, bootee into recovery, tapped Install in TWRP, selected the zip-package and proceeded. It all seemed to go well, the installation finished, but when I reboot it goes back in fastboot mode.

So at the moment I’m stuck with a device that doesn’t do much, alas. Any help is very much appriciated!

Cheers, Gert

Have you done a full wipe with TWRP and format data before flashing ? If no it, pls do it and flash again.

I did the following:
Press Wipe, then Format data and then typed yes. Then tapped Advance Wipe, ticked the boxes System and Cache and swiped to wipe. In the Advanced Wipe section I left the boxes Dalvik / ART Cache, data, Internal Storage and MicroSD unticked.


sounds good. And when you are flashing the zip file no error from TWRP ??

No, if I press Install it does just that: Install zip 1 from 1.
I added a picture from the screen while installing, maybe something not right there?

In the picture above I tried to install Lineage, to see if that made a difference, but no. Same result.

that looking normal. Send a picture when flashing is finished, before booting

OK, looks also good. after flashing you must reboot into twrp to use data is written in the log. do you have done it?

When the installation was done I proceeded with the last step:

  1. Once installation has finished, return to the main menu, tap Reboot, and then System.

in the lock you can see:; ‘you may need to reboor recovery to be able to use data again’

So I would prefer, to start over again from beginning and after flash is ready boot into TWRP and NOT in system. And from TWRP reboot into system and I hope everything will work fine

Thanks, I will give that a try tonight and will post the result.


Sadly, that didn’t help.
I did the following:
Wiped and Advanced Wiped again. Installed the zip. When it was done I went back to the main screen, pressed Reboot and then Recovery. Once rebooted in TWRP I pressed Reboot again en then System.

Same result as before.

Oh, sh… that’s really worst. so I don’t know what to do. sorry

This is weird all the screens and steps look to be correct. Can you confirm you are using the correct TWRP for your model . As you mentioned neither lineage not /e/ is working for you.
From adb on your PC can you run this command. It will give us the device name.
adb shell getprop ro.product.device

Hello Gert,

I had similar experience. New to forum and today I did my first flashing with /e/ on my WIleyfox Swift, and ended also stuck in fastboot mode. But with this post ( I managed to get my phone working.

Download & extract the files, perform the fastboot flash steps, then install TWRP and continue with the usual steps.

It works… but I’m not feeling that comfortable - it is downloading something random on my device and clueless what it does… Even more because it’s a post from 2016!

I hope someone can shine a light on it?

Cheers, david

Hi David,

yesterday I found something similar on xda also, but haven’t had the time to try that out. Good to hear you managed to get your phone running, keeps my hopes up!
I’ll give it a try, but probably not before after the weekend and will report back here.


Hello all!

It took me a while longer to try the method David suggested, but tonight I did it, it worked brilliantly, so I’m a very happy man.

Thanks a lot!

Happy to read it helped! :smiley:
Though, I would like to know why? …

Not sure where to post the experience I like to share.
I have been using the official build of crackling (Wileyfox Swift with two SIM cards) for about a year. The system was running more or less smooth. Since the update to v15 my phone startet to go into spontaneous reboots, about once every day or two. I could live with that, although it was annoying.
From v16 on the reboots became so frequent, up to ten times a day, that the phone is getting quite unusable for me. It is difficult to receive a call during the day, because I always have to check for entering the PIN numbers.
I tried to uninstall several apps, I was suspicous about, but to no avail. My suspect is that it might have to do with the SMS function, because after reboot the phone frequently asks me to select the SIM for sending SMS.
For the moment I switched back to Lineage 17 to have a reliable device.
Furthermore I am wondering when will crackling be taken to a Oreo or Q build. Has been announced a long time gone, but no more rumors are to be heard.