ProtonMail crash

Hello,
I use /e/ with LeEco L2. Since the V0.6 i can’t use protonmail. It crashes when the application starts up. The last update was made with “Apps”. I try to delete and reinstall Protonmail with Apps, but the problem persists.

I’m the only one, with this problem ?

Best regards

Major Tom

Hello, Xiaomi Redmi Note 5 Whyred /e/ V 0.6 (oreo) with Protonmail app V 1.11.1 (613) installed via Yalp

no crash, working great

I tested on Leeco s2 it does not crash, but i use unofficial oreo build…

Same here on Xiaomi Capricorn with unofficial v06-Oreo no issue with protonmail from yalp

I’ve tried to install protonmail from Apps, APKPure and from playstore (with raccoon for the APK) and still the same problem. I’m with the “official” v0.6 nougat, maybe it’s the problem…

I could raise an issue under gitlab…

MT

In deed, under Oreo, protonmail works very well !

I am having the same issue on the L2 and have been for months. Not sure what else to try before ditching this…

in the meantime there should be a v7. could you pls check for updates, or have you build for your own. If yes, make a new build to get the latest sources

the unofficial build under Oreo is very stable, you can try this version…
https://community.e.foundation/t/pi-e-test-rom-for-the-leeco-s2/4484

Here is the last version of ProtonMail that will work :
https://www.apkmirror.com/apk/protonmail/protonmail-encrypted-email/protonmail-encrypted-email-1-11-0-release/protonmail-encrypted-email-1-11-0-android-apk-download/

This is the last version who needs at minimum Android 4.0.3 (Ice Cream Sandwich MR1, API 15).

All next version need at minimum Android 4.3 (Jelly Bean MR2, API 18).

So high chance the issue comes from here. But I don’t know if it’s an /e/ or a ProtonMail issue.

mhm, I’m using 1.12.2 on my 4 phones. And is working without any issue. OK, no push messages but that’s because I don’t have microG installed

Yes it works the majority of time. But for those who experieces crashes, that’s the last working version.

really, that’s crazy

Hello !
I do not use LeEco 2 since july 2019… So, i don’t know if the problem still existe.

same here , oneplus x eelo 0.7-20191115 , protonmail app crash every time , i have try another version , no change , alway crash …

Hi, welcome in our community.

Did you try the version I gave above ?

I have LeEco S2, with latest pushed out version, protonmail crashes. Is it because I disabled MicroG?

If ProtonMail was recently working then suddenly not, it might be a different issue.

Did you try the version I gave above ?

I have no microG on my MiMax2 and newest version of proton works. … without push messaged
But a lot of devices are only working with the version Anonyme has posted

Have you installed proton before or after disabling microG? If after installing proton, I would try to uninstall proton, wiping chace and davlik with twrp and installing proton again