Questions about install on Pixel 4a 5g bramble

Hi, I have a couple questions about how to install /e/ on a Pixel 4a 5g. I have read a number of other threads on this, thanks @Jets , @_marc, @menner and others.

First, this phone already has Android 13. The install instructions say to be on the latest version of Android 12, and yet users found it necessary to go back to Android 11. What should I do? The last discussion of this was more than six months ago, so does it work to install under 12 now? And if I have to downgrade from 13 to 11, can I skip straight to 11? (I expect to do whatever I need to through ADB rather than the online flash tool.)

Second, the instructions contain a warning:

Warning: Make sure that you can send and receive SMS and place and receive calls (also via WiFi and LTE, if available), otherwise it will not work on /e/OS as well. Additionally, some devices require that VoLTE/VoWiFi be utilized once on stock to provision IMS.

Is any of this necessary with the Pixel 4a 5g? I just got the phone and would rather not have to stick my SIM in it while it is still a Google device.

Thanks for any advice you may have to offer!

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Yes post talking about 11 are old and related to easy-installer

Edit : Looks like installation for this device is problematic :

https://community.e.foundation/search?q=Pixel%204a%20(5G)%20order%3Alatest

https://community.e.foundation/search?q=Bramble%20order%3Alatest

I guess this is a judgement to make, but the instructions are not generally verbose, so I personally would be inclined to follow the guidance. The full warning goes on to mention

to provision IMS

IP Multimedia Core Network Subsystem (IMS), little known by myself, but maybe of increasing significance if VoLTE/VoWiFi is important for the user.

Perhaps you could get a “starter” / “demo” SIM card for this job and throw it away afterwards, or choose one suitable for “testing purposes” only.

Well, I have hit a snag.
I downloaded the latest Android SDK tools. I successfully downgraded the phone to the latest version of A12 (July 2022, technically A12.1). I then followed the instructions and flashed the latest /e/OS Android S recovery, “recovery-e-1.12.3-s-20230628304336-dev-bramble.img” My PC screen showed “sending ‘vendor_boot_b’ … OKAY”, “writing ‘vendor_boot_b’ … OKAY”. I unplugged the USB cable and powered off the device. When I power it up with power + volume down, I get the fastboot screen, where I choose recovery mode and press power. The screen goes dark for a second and reappears as the fastboot mode screen, not any recovery menus.
Now what?
Does this mean that yes, I really do have to start from Android 11?

Side note to developers/admins like @Manoj The MD5 hash files at https://images.ecloud.global/dev/bramble/ are out of sync with the files, each hash applying to the file below it and no checksum for the topmost file. The SHA256 hashes are okay.

I believe you missed this suggestion in the install doc:

Tip: Outdated fastboot releases dropped legacy A/B support, so it might attempt to flash to boot__a / boot__b rather than boot_a / boot_b if you try to flash boot. In this case, you must update fastboot to a release newer than or equal to 31.0.2. Alternatively, you can manually specify which slot to flash to based on what slot fastboot failed to flash to. For example, if fastboot fails to flash to boot__a, you must flash to boot_a.

Not so much missed it as don’t understand it. I believe I am using the latest adb / fastboot, not an “outdated” release. I downloaded the latest version, 34.something before I started.
However, it does seem from the message I received that “boot_a or boot__a” (really? an extra underscore?) may not have been flashed. I honestly haven’t any idea what this means, but if someone can provide the syntax for the command to flash it, I’ll give it a try.

Ok, I found some helpful info at https://www.xda-developers.com/how-a-b-partitions-and-seamless-updates-affect-custom-development-on-xda/ but I still don’t know what the difference between boot_a and boot__a amounts to. Are we trying to flash the recovery into both ‘vendor_boot_a’ and ‘vendor_boot_b’?

Update: I tried flashing both vendor_boot_a and vendor_boot_b with the /e/ recovery. They flashed okay, but it made no difference – phone still won’t enter recovery mode, loops back to fastboot mode.

I do not know the device. Did your downgrade method include a Factory reset ?

If not perhaps remaining traces of Android 13 are an issue. From your current position

fastboot -w

might allow you to move on.

No, e/OS + Android OS version names and numbers? - #3 by aibd I expect you did already, but you could double check that you have the latest revision of Android 12.

Late edit in light of solution below, Android 12 (s) manufacturer firmware should be the correct starting point for any /e/OS-s build. However some as yet undefined problem is still preventing a standard install method for e-1.12.3-s-20230628304336-dev-bramble.

Yes, the downgrade involved a factory reset.
I have been working the last hour or so on trying it all a different way. I flashed the last version of A12 with the Android Flash Tool, and then tried the /e/ Easy Installer. Same result, essentially. When I was instructed to select Recovery Mode and confirm it with the power button, the phone then looped a couple times, showing the G-logo then back to the fastboot mode screen. The phone will not boot to stock or recovery now.
What would fastboot -w do for me?
At this point, I think I have to reflash the stock ROM … again.
These issues seem very much the same as those discussed back in February in this thread: https://community.e.foundation/t/google-pixel-4a5g-stuck-at-fastboot-will-not-switch-to-recovery/47230
I just had hoped that I could avoid the solution there, which is to go back to A11 …

It would just do a wipe similar to factory reset. But this was just an “If not” suggestion.

E. Henry,

Just use the android flash tool and downgrade the phone to A11. I forget the reason but at A12 it won’t work you have to go to android 11 (final version for your phone A11). Once at A11 make sure developer and I think USB debugging is enabled.

Then use eEasy installer or command line install to eOS e-1.8.1-r. Once at eOSr upgrade OTA to eOSs.

I am at work but will try to check in during the day. Jets

Thanks, @Jets. I downgraded to A11 with the android flash tool and the Easy installer worked to put eOS e-1.8.1-r on the device. There was no problem entering recovery mode from fastboot mode.

But what is the upgrade path to e-1.12.3-s ? There were no OTA updates available when I checked, and the upgrade documentation states that major version updates have to be done manually. That would be fine, but what confuses me is that the upgrade document says:

Caution: Before following these instructions please ensure that your smartphone is on the latest Android firmware available for your device. For example if available, before flashing /e/OS ‘S’ install Stock Android 12.

That is precisely what I’ve been trying to do and can’t! Or is it all magically fixed now that I got down to A11 / eOS-r running? If I now reflash the device with A12 stock, will eOS-s actually load?

Or perhaps as this device will be supported on eOS-t in the near future, would it be better to wait and skip A12 / eOS-s ?

If you are at eOSr try the OTA update a few times. If it doesn’t work you can go from eOSr to to eOSs without updating the stock ROM but you will need to use the command line method.

I am doing a fresh upgrade to a Pixel 4a5g tomorrow if time permits and I will post steps.

But yes if you are comfortable with command line upgrade you can got the next higher eOS without going back to stock ROM.

I hope your upgrade goes well @Jets, and if you do get time to post notes, that would be very helpful!

Okay, I got to S following hints above and in this discussion and this one, from @Jets, @menner, and @Sebb, to whom I am grateful.

I will recap the process for the sake of anyone else trying to do this.

  1. Downgrade to the most recent version of A11 using the android flash tool, get started here.

  2. Once your device is running on A11, use and follow the instructions of the /e/ Easy Installer. You don’t get to choose what version it will install. I found that it installed a version that was not listed for download on the images page, in my case, 1.12.3-r-20230614299637-stable-bramble

  3. Once /e/ r is running, enable developer options, USB debugging, and USB file transfer behavior.

  4. Follow the instructions in the upgrade documentation, but ONLY the steps under the “Manually upgrading your bramble to S” heading. You do NOT need to try flashing the phone to stock A12 firmware, and you do NOT need to download and install the recovery image file! Doing either of those may cause the problems discussed above. The recovery image that is already on the phone from step 2 will work to update your device to /e/OS s.

I did get one error during this process. It warned me that the signature verification had failed, failed to verify whole-file signature. I chose “install anyway”. I had checked the downloaded file against the SHA256 hash, but if anybody wants to tell me this means I got a corrupt version full of malware, please do so quickly!

I will note that @Sebb mentions a shortcut in this process that I did not try, since I already had done step 2 completely. He says he interrupted the Easy Installer process “when it restarted in Recovery mode, I closed easy installer and manually continued the installation starting with the wipe then adb sideload with verion 1.8.1-S (as mentioned in the guide)”.

I will also note that I do not know WHY the steps above work, specifically why the recovery for the r version works to install the s version, but the s version recoveries appear to cause the fastboot loop problem. That suggests that the s recoveries differ from the r recoveries by the introduction of some unnecessary bug!

1 Like

Also, to answer my original two questions, Yes, it appears to be necessary to downgrade to A11, and No, it is not necessary (or was not necessary for me) to use the device with a SIM card before flashing /e/. I find that VoLTE and VoWiFi are provisioned, that the phone makes & receives calls, sends & receives SMS and MMS just fine. I am not sure whether 5g is working, but it could easily be that my local tower has not been upgraded to 5g yet.

1 Like