Questions before installing /e/

I’ve investigating installation /e/ on my Oneplus 5T and I have several questions before running in the installation process.

  • Will I be able to restore my “old” phone OS if /e/ don’t work or doesn’t fit my needs ? How ?
  • Will I be able to install any app ? I see Yalp allow this, but is there restrictions for running for example Waze on my bank application ?
  • How stable /e/ is currently on Oneplus 5T ?

Thanks for your answers. Hope I can’t install /e/ shortly !

As indicated on the Oneplus 5T-installation page, you are required to install TWRP. As stated in “Installing /e/ from custom recovery Step 3.” you can create a backup with TWRP.
Recently I created a backup of my /e/-Nougat on LeEco Le2 and restored it afterwards and ran into a few problems, so I recommend to consult the documentation and tutorials about TWRP.

There are apps on Google-Play that can only be accessed after you purchase them. Apps like that require an google account, so you would need to submit your Google-account details via Yalp.

Google provides some services and infrastructure for app developers to utilize.
Since /e/ tries to reduce the amount of data, that is leaked to Google, they replaced some of these services and infrastructure by the open source project MicroG. MicroG is however not in all aspects compatible with the Google services, so there are apps that be installed, but not used on /e/. If you happen have problems with such an app, you can indicate such apps here on the forum.

As far as I know, otherwise all apps are supposed to be running on /e/.

/e/ is still a very young and evolving OS and still in beta phase, so it can be expected that there are several issues and inconveniences present. You can have a look at the known issues at But all basic functionalities are supposed to be working.

I believe these were not meant to be there. :wink:

hmm was that intended :smile:

I meant : CAN install :wink:


Hi, I tried Waze and it works but I use /e/ map app (by Magic Earth) that’s working pretty well. My bank’s app also works.

1 Like

@nico let us know if you were able to install the /e/ ROM

I did it !
Installation successful without any problem thanks to the wiki.
Now time to discover /e/

1 Like

Great!!! Once you have used it for a few days let us know your feedback on /e/ :slight_smile:


After a few days of usage, I’m quite happy with /e/ and I don’t regret switching. Here is a first of annoying things I’ve noticed:

  • I liked the “swipe fingerprint sensor to make status bar appear”. I haven’t found this feature currently on /e.
  • moving app icon to the screen border is too sensitive : you get instantly to first or last screen.
  • grouping apps in folder seems buggy : sometime, the app folder disappear.
  • battery consumption seems higher than before (compared with OnePlus android). After one day of use (out of home, LTE network, …) battery goes down to 60%, while with OnePlus Android it was about 70%

Thanks for your work.

1 Like

even with my Xiaomi Mido

1 Like

We have an issue for this in Gitlab

only drag between screens and since September 17… I was thinking about another launcher, Smart Launcher (ginlemon.flowerfree)

Are there also issue on grouping apps and battery depletion?

These two issues are not yet mentioned in Gitlab.
It would be great, if you could raise bugreports for then as described on

@nico I am currently in the process of installing /e/ on my oneplus 5t, but not having the best time :confused: You had no problems?
Been following the instructions here:

and everything is pretty much as described until it gets to using twrp. I downloaded and installed the latest version: twrp-3.2.3-1-dumpling.img
Some of the menues don’t seem to be the same, so that made me think that twrp was updated since the wiki got written. Still I can follow the general instructions up to the point where it is needed to push the /e/ install zip to the sd card, I get this error:
adb: error: failed to get feature set: no devices/emulators found
nevermind there is an “install form adb” option, so I tried that it asks me to use the adb sideload “filename” command, when I try that it starts transferring the file and finishes, but the install fails.
@supportpeeps am I doing something stupidly wrong, or should I use a different twrp version? not sure how to proceed


In my experience with several phones it’s too much simply to copy the ROM you want to flash to the memory card (SD) instead of doing via sideload.

How to do it? Enable the transfer of files on the USB menu in main screen or FTP it (if you have an app for FTP server just like “File manager HD” which implement FTP transfer directly to your device’s SD media). Copy the ROM to your SD media.

After that you can install the new ROM following the steps in the link: Wipe and, after did it, go to Install chose install > select storage > SD card. On your SD card directory chose your ZIP and install it. Wipe the cache as suggested and reboot on system.

(Sorry for my English)

1 Like

Hi @Erekoze,
Thanks for that advice, tried doing that and the files transfer nicely, when I try to install from internal storage it still ends on “installation failed” though.
I’ve realised that my oneplus seems to have been updated to the latest oxzygen os which is based on pie. Could that be the main issue? I might also try with a few different nightly builds, to see if that makes any difference
Thanks for the help man, much appreciated!

I don’t think so, @Carlos. The ROM’s didn’t “see” that. The obvious point is: It’s the ROM you downloaded correct? Did you checked the MD5 hash?

Im not gonna lie, I didnt really know what that was, but after I checked it now, it seems to be correct
Checked it on windows using "certutil -hashfile MD5
That the right way to do it?
If it helps in any way, if I do the adb sideload it seems to go well until roughly 50%, then the cmd prompt changes to Total xfer 1.00x and the phone screen changes to installation failed
Also get installation failed when I try to reinstall the latest firmware

I don’t use Wind**s, sorry. The only thing, for real, is that you’ll get better options if you copy the zip on the SD card, IMHO.

I checked and have a question: Do you have a ‘-hashfile’? I presume its a textfile. Am I wrong?

Hashfile? Do you mean from the command to query the md5 hash? it doesnt spit out a file, just the hash itself in cmd prompt, I compared it to the one provided in the install link and they matched.
The internal storage being “more likely to work” makes sense, but I end up with the same error. Even tho windows can be a potato, i think in this case its innocent