Redmi Note 8T (Ginkgo) stuck in fastboot mode after eOS 2.1 update (from 1.21)


I urgently need help with this one as I need to travel tomorrow and I don’t have a spare phone!

The title is pretty self explanatory, after the OTA update to 2.21 from 1.21 my phone is stuck in fastboot. I can see that the issue has been logged on GitHub and that it is possible to use advanced recovery to reboot back into 1.21 but when I use ‘fastboot devices’, the phone isn’t recognised, therefore I’m stuck.

(PS I don’t really know what I’m talking about, apologies if this is not clear.)

Any help much appreciated,


Regain your privacy! Adopt /e/OS the deGoogled mobile OS and online servicesphone

If using Windows please check my reply here How to mount encrypted /data partition in recovery mode? - #67 by aibd

I updated Windows but no joy :frowning: Have I missed something?

And thank you for getting back to me :slight_smile:

So it may be a problem with the device or else it is Windows. I will read more fully the reporter says

It then starts fastboot. From there I can start recovery and with “mount/unmount system” in the advanced recovery I can boot version 1.21. until now I did not find a way to boot V2.0

I am not familiar with your bootloader, is what he describes possible on the device ?

The full Windows driver routine

It is a known issue that there are often a variety of Windows drivers for some Android devices. It will vary by device, but Windows may have provided a simple driver allowing communication with the device normally, but not in fastboot mode. Sometimes the “full” driver might have the name “Combination driver”. Windows is expected to be able to find such driver automatically as follows.

To check and fix

Connect the phone, powered on, normally booted, to you Windows PC with a good usb data cable, and open Windows Device Manager.

Open a terminal alongside and use the command

adb devices

to check that you can communicate with the phone. The expected response is for the device to identify itself with serial number and another string, for example

abc2345def device

Any device with a driver issue whould appear in Device manager as :warning: Problem device.

If you see a :warning: Problem device, run Windows Update, ensure the warning clears.

Now importantly check the phone in the other bootable modes. Boot the phone into Recovery mode, Device Manager still open; use the command

adb devices

Boot into Fastboot mode and use the command

fastboot devices

Should the :warning: appear at any stage, run Windows Update again.

Still an issue, what is the output of

adb --version

Is it up to date compare with

Perhaps you could give feedback of what does or does not happen as you try to communicate with the phone from Windows. Is platform-tools up to date?

The install page does mention buggy USB support, did you try those suggestions?

Since no OTA update to version e-2.1-r-20240606407290-dev-ginkgo has been offered on the system so far, I have successfully carried out a manual update via PC and adb sideloadand, - also ended up in fastboot mode after the reboot.

After I installed recovery-e-2.1-r-20240606407290-dev-ginkgo and booted into e-Recovery, I am shown:

The system has been destroyed
Press powser button to shutdown

Next I installed PitchBlack Recovery Project and with it /e/OS-R v2.1, but again the system only booted into fastboot mode.

Now that /e/OS-R will no longer be officially supported in the foreseeable future (as of today, the latest Andrid security update is February 5, 2024), I successfully switched to crdroid 10.5 (Android 14) with MinMicroG.

OK, the Windows driver issue is now sorted and the computer is talking to the phone.

The issue now is that if I try to reboot into recovery it just goes back to fastboot :person_facepalming:

So now I have also tried fastboot flash recovery twrp.img and fastboot boot twrp.img with no joy, I just keep coming back to the fastboot screen.

How did you do the switch to crdroid? Did you lose all your data?

Thank you for all your help @aibd and @Xxpsilon

Yes! I even had to completely reinstall the Android 11 firmware to continue.
See also here

So this would mean flashing willow_global_images_V12.5.6.0.RCXMIXM_20220623.0000.00_11.0_global_f58e9a4cc8.tgz via fastboot?

Yes! (post must be at least 20 character)

With the experience of @Xxpsilon, his recommendation is clearly the best way forward … but

The methods which provided a temporary fix in the linked issue were to attempt to go back (rather than forward).

From my experience this is associated with a Super Partition or Dynamic partition device. You may be (likely) in this situation, but you might still try the workaround of @nanabanaman in the linked Gitlab issue, aiming to get back to what was previously working (e-1.21 and the recovery you were using then).

I was able to roll back by dirty flashing recovery and /e/ OS version 1.21.

As much as I love /e/OS, /e/OS-R for “willow” is a no-go from now on. It has no future, as /e/OS release “R” will soon no longer be supported.

@aibd I’m not sure how to “dirty flash recovery”. I have tried (standard…clean?) flashing and booting from both TWRP and the /e/ recovery and just end up back at the fastboot screen. I would prefer to roll back if possible. For now.

@Xxpsilon is this guide going to see me through going via your route?

Once again, thank you so much for your help both of you!

This is one of several possibilities.

I prefer flashing via flash_all.bat (unzip the downloaded .zip first)

Yes, this phone has been a bit unlucky with respect to /e/. First we had broken builds for maybe half a year and hence were locked out of security updates, then one update sent Bliss Launcher into a crash loop for a month or two for me, making it temporarily unusable, and now this 2.0 update.

I think the issue is just that the development team doesn’t have a phone of this model to test on. I guess community devices will get more stable as the project grows.

I went back to 1.21 for now by first flashing the old recovery and then the old version, plus a few other things. This allowed me to keep all data. I detailed the process in this post. Backups are still highly recommended of course.

I did the flashing from Linux (Mint) since it’s way too annoying to deal with Windows and trying to get it to recognize drivers and such. If you run into too much trouble on Windows, a live version of your favorite Linux distribution that you can boot from a USB thumbdrive would probably suffice.

Yes, I agree with your assessment.

/e/ supports around 250 devices. That is enormous and very commendable. But /e/ has far too little man power to offer reliable bug-fixing and generally reliable support. Of course, there are numerous devices that work very well, but - any update without prior data backup is always an increased risk.

Hey, thank you for this. I tried flashing the /e/ 1.21 recovery, rebooted and returned to fastboot. I used fastboot erase cache and tried again, still nothing. Have I gone wrong somewhere?

  • At this point, I may have extracted and flashed boot.img from the /e/ 1.21 image, but maybe that’s not necessary

@nanabanaman what do you mean here?

Thanks again

You can’t lose anything more than your data, so it’s worth a try.

I would install via fastboot (images from V1.21)


Erm…what are the commands to do that? (Sorry I need the basics)