Revolut on Q Herolte S7

Hi everyone! I’m using Q (unnoficial) on my Samsung S7 and sadly with the last Revolut update I’ve lost the app :pensive: Does somebody know a way to downgrade or to make it work again?
I’m thinking about downloading an APK and installing it but I’m not 100% convinced of the idea :slightly_smiling_face:
The app was working perfectly before the update. Thanks a lot for your time!
Have a nice day.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

It’s happening here as well since v8.30. Complain to customer support as a start.

1 Like

Exactly! :grinning_face_with_smiling_eyes: thanks for your answer @guandalf
Well… I’ve found a temporary “solution”. What I did was to install APK version 8.29.1 and it worked. I downloaded it from APK mirror site.
As you said @guandalf all versions after 8.3x have problems for the moment, I’ve tried them. If anyone needs the app as I do at least you have that alternative… it’s not the best but it works… I will complain anyways with Revolut :grinning_face_with_smiling_eyes:
Cheers everyone! and thanks for your support :slight_smile:

1 Like

So the customer support suggested me to retry after their partial disruption of services is solved keeping an eye here:

Hello. I am hammering the customer support and you’ll better do it yourself.
It’s quite dangerous to think the solution is just downgrading to working version 'cause at a certain point they’ll force us to upgrade and we would have lost all the time we have now to fight their new changes.

I’m having the same issue here with FP3, downgrading to version 8.29.1 works wonders, many thanks.

Could you keep us updated if you get any reply from the customer support?



@Wichtc91 no! And sorry in advance, not to be rude but you have to hammer the customer support yourself 'cause the only way to obtain a fix is to push for that from more and more users, not waiting for others to solve the issue. (read, it only one user has the issue, just drop it).
BTW they suggested me to use it on another device…

I am having the same issue and am right now in a chat with Tin from Revolut. He asked me to run:

The SafetyNet test failed. What does that say about /e/OS and the combibation with Revolut?

My other banking app ABN-AMRO is working fine.

It’s a bug in Revolut and they must fix this.

Revolut 8.32 works here (oneplus nord + murena 0.19 q stable)

I think we are not going to get safety net check working anymore, but what’s wrong here is that our “safety” is dictated by a choice of a US company. We have to stand against it.

As @guandalf suggested, I complained to Revolut’s support about this and this was their answer:

Thank you for waiting. As for the response of the relevant team, we’re afraid that you made need to use a device that comply with Safetynet. I’m afraid that there’s nothing we can do in this case. /e/OS is a custom ROM and it’s not compatible with Google SafetyNet, which is required by us. You may perform a SafetyNet check for your devices here : or here

I understand this is not the solution/answer you are expecting. I agree that this should’ve not happened.But I just wanted to let you know that I do really love to help you with this. I’m afraid that some things are unfortunately out of our support’s team control, but we always look for ways to improve in the future. I will definitely provide this as a feedback to our relevant team and I really hope the process will be changed in the near future. They are working really hard to improve our services. I really appreciate your understanding and I am really sorry for all the hassle!

Howerver, I can confirm version 8.32 works for me too. Maybe they received enough complaints to come back on their decision.

:grinning_face_with_smiling_eyes: :grinning_face_with_smiling_eyes: :grinning_face_with_smiling_eyes: :grinning_face_with_smiling_eyes: :grinning_face_with_smiling_eyes: :grinning_face_with_smiling_eyes: :grinning_face_with_smiling_eyes: :grinning_face_with_smiling_eyes: :grinning_face_with_smiling_eyes:
Cool! Thanks for the feedback @Aroun
FUCK Google!!! :upside_down_face: lol
Have a nice day.