S9+ not rcognized

Tried easy installer on s9+ 965f (can’t remember model number but it matches grequirement) and it just couldn’t find my phone.Followed all instructions. Tried manual install via Heidwhatever and it also failed. The only discrepancy I could find in the manual install instructions was it said “hold bixby” but this phone doesn’t have the bixby button. Other than that I followed the instructions. Any ideas?

1 Like


Try another data cable (original Samsung don’t work)

Or you are in prenormal rmm state

If you are in the U.S. the Samsung phones can’t be flashed with any roms. Only international Samsung phones can be flashed. If you’re outside the US I’m not sure what it could be.


Boot Modes


With the device powered off - hold Volume Up + Bixby + Power. When the blue text appears, release the buttons.


With the device powered off - hold Volume Down + Bixby + Power.

For Bixby read Home / Bixby being the hardware button lower centre of the main screen.

1 Like

Thank you! I did specifically buy the model 965f which is the international version of the S9+ !

1 Like

Thank you ! Is there any way I can confirm or deny I am in this state?

Informative ! I will try it again !

No physical button on center bottom of main screen. Got into download mode by power + volume down + button right beneath volume down.

What happens when I run heidall is I get this:

ERROR: Failed to send handshake!ERROR: Protocol initialisation failed!

Have tried multiple usb 3 cords… including ones I can read and write data to the phone with … :frowning:

Hmmm … this might be due to an internal usb hub in your PC – just a thought.

Great thought ! Will switch !

Out of USB ports to try… drat ! … thing is, this cord + hub can be used to transfer files to and fro, which makes me think they’re working OK…

when it says “downloading and the screen is teal blue, that screen, the tiny messages at the top say” RPMB Fuse Blown
RPMB Provisioned

some other stuff…

any of this meaningful to anyone?

This forum is great and people are friendly! I am going to bail on this project because I can’t figure it out. I really appreciate everyone’s input however THANK YOU !!!

Did this include https://doc.e.foundation/pages/enable-usb-debugging ?

Just FYI should you come back to the project one day, that tends not to be a good indicator of your ability to flash a ROM. If you are using heimdall I am guessing you are using Linux. In troubleshooting this I might look at the way that my distro provides libusb-1.0-0-dev

So before you even start with flashing your Samsung you would want to troubleshoot any failure in

 heimdall print-pit

Also, did you cover everything in the Requirements section of https://doc.e.foundation/devices/star2lte/install which includes https://doc.e.foundation/adb see also https://doc.e.foundation/pages/install-adb (and already mentioned https://doc.e.foundation/pages/enable-usb-debugging).

The command

adb devices

will do nothing to the device, but will also confirm if you have full two way communication with the device via platform-tools [1] aka Android Debug Bridge, before you even start with any flashing instructions.

[1] https://developer.android.com/studio/releases/platform-tools there is a fuller guide covering the use of plugdev group and udev rules here: https://developer.android.com/studio/run/device